0 Replies Latest reply on Sep 18, 2013 2:48 PM by Frank Grimes

    Minor nit - Logged Netty version can be incorrect/misleading

    Frank Grimes Newbie

      Hi

       

      I upgraded my Netty to 3.7.0.Final but when HornetQ logs the version it's using, it's based on the version it was compiled against instead of the one being used at runtime.

       

      e.g.

       

      Instead of "INFO: HQ221020: Started Netty Acceptor version 3.7.0.Final"

      I get "INFO: HQ221020: Started Netty Acceptor version 3.6.6.Final"

       

      This is because org.hornetq.core.remoting.impl.netty.NettyAcceptor.start() references org.jboss.netty.util.Version.Version.ID which is a public static final String (causing the constant to be inlined in the hornetq NettyAcceptor.class file.

       

      Cheers,

       

      Frank Grimes