2 Replies Latest reply on Dec 11, 2013 4:53 AM by Wolf-Dieter Fink

    Deployed XA DataSource - Error in Admin Console

    Nicholas Whitehead Newbie

      I have an EAR deployment which includes an XA datasource definition. Once deployed it works fine and I verified it is supplying XAConnections. I am using the built in H2 driver for the time being for my testing.

      So it's not a super critical issue, but I noticed that the XA datasource does not show up in the Admin Console's DataSources listings, as expected under the XA Data Sources tab. It runs me a little concerned because data-sources are the last thing I want to be in the dark about.

      More interestingly, when I clicked the XA Data Sources tab's Refresh button, I got this error:


      Unknown error


      Unexpected HTTP response: 500  Request { "address" => [ ("subsystem" => "datasources"), ("xa-data-source" => "ReportingXADS"), ("statistics" => "jdbc") ], "operation" => "read-resource", "include-runtime" => true }  Response  Internal Server Error { "outcome" => "failed", "failure-description" => "JBAS014883: No resource definition is registered for address [ (\"subsystem\" => \"datasources\"), (\"xa-data-source\" => \"ReportingXADS\"), (\"statistics\" => \"jdbc\") ]", "rolled-back" => true }


      My data source definition file is called ReportingDS.xml and is packaged in the ear's META-INF folder. Its listing is below.


      Can anyone suggest how to get around this ? Am I missing something in the DS ?






      <?xml version="1.0" encoding="UTF-8"?>

      <datasources xmlns="http://www.ironjacamar.org/doc/schema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

                      <xa-datasource jndi-name="java:jboss/datasources/ReportingXADS" pool-name="ReportingXADS" enabled="true" use-ccm="true">

                          <xa-datasource-property name="URL">jdbc:h2:mem:reporting;DB_CLOSE_DELAY=-1</xa-datasource-property>

                          <xa-datasource-property name="User">sa</xa-datasource-property>

                          <xa-datasource-property name="Password"></xa-datasource-property>