0 Replies Latest reply on Oct 9, 2013 7:08 AM by Max Rydahl Andersen

    Re: [forge-dev] JDK 7 still being used for compilation. We are still looking into the issue.

    Max Rydahl Andersen Master

      fyi - developer settings for jboss.org projects is documented here: https://community.jboss.org/wiki/MavenGettingStarted-Developers

       

       

      On Wed, Oct 09, 2013 at 11:06:38AM +0300, Ivan St. Ivanov wrote:

      >Shit, tried to syntax highlight the XML. Here it is without any

      >butifications:

       

      <profiles>

         <profile>

           <id>forge-20</id>

           <pluginRepositories>

             <pluginRepository>

               <id>build.snapshots</id>

               <url>

      >https://repository.jboss.org/nexus/content/repositories/snapshots</url>

             </pluginRepository>

           </pluginRepositories>

         </profile>

      </profiles>

       

      <activeProfiles>

         <activeProfile>forge-20</activeProfile>

      </activeProfiles>

       

      >Cheers,

      >Ivan

      >

      >On Wed, Oct 9, 2013 at 11:05 AM, Ivan St. Ivanov

      ><ivan.st.ivanov@gmail.com>wrote:

      >> Hi George,

      >>

      >> Thanks! That seemed to fix the issue. However, it was possible so far to

      >> build forge without special prepared setttings.xml. Now we have to do that

      >> (BTW, it is not documented). I wonder though, should we? There are two ways

      >> to avoid touching settings.xml:

      >>

      >> 1) Adding the snapshot results to the central maven repository

      >> 2) Adding the jboss snapshot repository to our parent pom.xml

      >>

      >> BTW, for those interested, here is what I added to my settings.xml:

      >>

      >>  stick to version 11? Maybe it's about time to go to Java 7!

      >>>>

      >>>> BTW, I cannot build Forge, because Maven can't find the Furnace

      >>>> artifacts in any repository. Did you remove them by chance?

      >>>>

      >>>> Cheers,

      >>>> Ivan

      >>>>

      >>>>

      >>>> On Sat, Oct 5, 2013 at 1:23 AM, Lincoln Baxter, III <

      >>>> lincolnbaxter@gmail.com> wrote:

      >>>>

      >>>>> In the mean time, please try to use JDK7 We'll be compatible with 6

      >>>>> again soon.

      >>>>>

      >>>>> --

      >>>>> Lincoln Baxter, III

      >>>>> http://ocpsoft.org

      >>>>> "Simpler is better."

      >>>>>

      >>>>> _______________________________________________

      >>>>> forge-dev mailing list

      >>>>> forge-dev@lists.jboss.org

      >>>>> https://lists.jboss.org/mailman/listinfo/forge-dev

      >>>>>

      >>>>

      >>>>

      >>> _______________________________________________

      >>> forge-dev mailing list

      >>> forge-dev@lists.jboss.org

      >>> https://lists.jboss.org/mailman/listinfo/forge-dev

      >>>

      >>>

      >>> _______________________________________________

      >>> forge-dev mailing list

      >>> forge-dev@lists.jboss.org

      >>> https://lists.jboss.org/mailman/listinfo/forge-dev

      >>>

      >>

      >>

       

      >_______________________________________________

      >forge-dev mailing list

      >forge-dev@lists.jboss.org

      >https://lists.jboss.org/mailman/listinfo/forge-dev

       

      _______________________________________________

      forge-dev mailing list

      forge-dev@lists.jboss.org

      https://lists.jboss.org/mailman/listinfo/forge-dev