5 Replies Latest reply on Oct 25, 2013 12:38 AM by Elias Ross

    RHQ Web Console not available  (4.9.0)

    Lukasz Szelag Newbie

      Hello,

       

      After installing the latest (4.9.0) RHQ (see below steps) the RHQ Web Console doesn't show up. For a fraction of a second I see RHQ logo and "Loading..." text, then the Web page becomes blank. When I did the same installation earlier today the login page came up after some time but I cannot make this work anymore. I recall having the same issue with the previous version. What could be wrong? I doubt I'm the only one who is experiencing this issue. The server log doesn't show any errors (except XA warnings related to Oracle but I expect these to go away once additional permissions are granted to the user).

       

      If someone is wondering, -Djava.security.egd=file:///dev/urandom is required for Oracle JDBC to work properly on a headless system (this is a known issue).

       

      Thanks,

      Lukasz

       

       

      Installation steps:

       

      1) Extract RHQ installation archive to <RHQ_HOME>

       

      2) Edit database and SMTP properties under <RHQ_HOME>/bin/rhq-server.properties

       

      3) Define the following property in <RHQ_HOME>/bin/rhqctl:

       

      RHQ_CONTROL_ADDITIONAL_JAVA_OPTS="-Djava.security.egd=file:///dev/urandom"

       

      4) Define the following property in <RHQ_HOME>/bin/rhq-server.sh:

       

      RHQ_SERVER_ADDITIONAL_JAVA_OPTS="-Djava.security.egd=file:///dev/urandom"

       

      5) Define the following property in <RHQ_HOME>/bin/rhq-installer.sh:

       

      RHQ_SERVER_INSTALLER_ADDITIONAL_JAVA_OPTS="-Djava.security.egd=file:///dev/urandom"

       

      6) Define the following property in <RHQ_HOME>/bin/rhq-storage-installer.sh:

       

      RHQ_STORAGE_INSTALLER_ADDITIONAL_JAVA_OPTS="-Djava.security.egd=file:///dev/urandom"

       

      7) Add the following JVM argument to <RHQ_HOME>/bin/wrapper/rhq-server-wrapper.conf:

       

      wrapper.java.additional.23=-Djava.security.egd=file:///dev/urandom

       

      8) Add the following JVM argument to <RHQ_HOME>/bin/wrapper/rhq-storage-wrapper.conf:

       

      wrapper.java.additional.18=-Djava.security.egd=file:///dev/urandom

       

      9) Install Oracle JDBC driver jar under <RHQ_HOME>/modules/org/rhq/oracle/main

       

      10) Edit Oracle JDBC driver's path in <RHQ_HOME>/modules/org/rhq/oracle/main/module.xml

       

      11) Install RHQ server, RHQ storage node and agent

       

      <RHQ_HOME>/bin/rhqctl install --storage-data-root-dir <RHQ_HOME>/data

       

      12) Go to URL http://hostname:7080

        • 1. Re: RHQ Web Console not available  (4.9.0)
          Lukasz Szelag Newbie

          The console showed up after some time (20 - 30 minutes) after the installation. Is this expected?

          1 of 1 people found this helpful
          • 2. Re: RHQ Web Console not available  (4.9.0)
            mazz Master

            a half hour is a long time, I suspect you have a slow (or less than optimal) database setup. I will say that the very first time you start up after an install, it will be slow (we've seen it up to 10 minutes) IF you deployed the AS7 plugin - because the AS7 plugin has a tremendous amount of metadata that needs to be stored in the database. That is what takes a long time - it needs to seed the database with the metadata. After that iniital time, the startup should be faster.

             

            But still - 30 minutes seems extreme.

            1 of 1 people found this helpful
            • 3. Re: RHQ Web Console not available  (4.9.0)
              Lukasz Szelag Newbie

              I'm using the standard configuration (not sure if AS7 is part of it). You may be right regarding the database - it is running on a development server, which may not be particularly fast. There are lots of XA recovery warnings in the RHQ server log, so perhaps this slows down the system.

              • 4. Re: Re: RHQ Web Console not available  (4.9.0)
                Stian Lund Expert

                I think I have encountered the same in my recent 4.9 installation.

                 

                After going through the installer without errors, installing Storage and Agent, the Server seems to start just fine:

                 

                15:36:59,556 INFO  [org.rhq.helpers.rtfilter.filter.RtFilter] (ServerService Thread Pool -- 63) Initialized response-time filter for webapp with context root 'rest'.

                15:36:59,586 INFO  [org.jboss.web] (ServerService Thread Pool -- 63) JBAS018210: Register web context: /rest-examples

                15:36:59,614 INFO  [org.jboss.web] (ServerService Thread Pool -- 63) JBAS018210: Register web context: /jboss-remoting-servlet-invoker

                15:36:59,677 INFO  [org.jboss.web] (ServerService Thread Pool -- 63) JBAS018210: Register web context: /coregui

                15:36:59,896 INFO  [org.rhq.helpers.rtfilter.filter.RtFilter] (ServerService Thread Pool -- 63) Initialized response-time filter for webapp with context root 'coregui'.

                15:36:59,924 INFO  [org.jboss.as.server] (management-handler-thread - 1) JBAS018559: Deployed "rhq.ear" (runtime-name : "rhq.ear")

                15:37:01,234 INFO  [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/jboss-remoting-servlet-invoker]] (http-/0.0.0.0:7080-3) ServerInvokerServlet: invokerObjectNameQuery=jboss.remoting:service=invoker,rhq.communications.connector.rhqtype=server,*

                 

                 

                Then when I go to port 7080 it just flashes the RHQ startup logo and just presents a blank (white) page. I have now waited almost an hour after startup.

                 

                Every time I access the coreGUI the following error is logged:

                 

                16:20:35,420 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/jboss-remoting-servlet-invoker].[ServerInvokerServlet]] (http-/0.0.0.0:7080-11) JBWEB000235: Allocate exception for servlet ServerInvokerServlet: javax.servlet.ServletException: Could not find the remoting servlet invoker: jboss.remoting:service=invoker,rhq.communications.connector.rhqtype=server,* - need to wait for remoting to be initialized later

                    at org.rhq.enterprise.communications.servlet.ServerInvokerServlet.getInvokerFromInvokerName(ServerInvokerServlet.java:78) [classes:]

                    at org.jboss.remoting.transport.servlet.web.ServerInvokerServlet.init(ServerInvokerServlet.java:78) [jboss-remoting-2.5.4.SP4.jar:]

                    at sun.reflect.GeneratedMethodAccessor80.invoke(Unknown Source) [:1.7.0_25]

                    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_25]

                    at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_25]

                    at org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:263) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:261) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.7.0_25]

                    at javax.security.auth.Subject.doAsPrivileged(Subject.java:536) [rt.jar:1.7.0_25]

                    at org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:295) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:155) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:108) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1188) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:950) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:151) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.jboss.as.jpa.interceptor.WebNonTxEmCloserValve.invoke(WebNonTxEmCloserValve.java:50) [jboss-as-jpa-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]

                    at org.jboss.as.jpa.interceptor.WebNonTxEmCloserValve.invoke(WebNonTxEmCloserValve.java:50) [jboss-as-jpa-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]

                    at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169) [jboss-as-web-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]

                    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920) [jbossweb-7.2.0.Final.jar:7.2.0.Final]

                    at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_25]

                 

                 

                I have tried clearing browser cache, using different browsers (IE, FF, Chrome), and just the same error.

                 

                Any ideas where to look?

                 

                -Stian

                • 5. Re: RHQ Web Console not available  (4.9.0)
                  Elias Ross Master


                  I've run into various issues with the server not coming up. You really need the agent and the storage all running (and in a good state) before the server UI will come up. Check all those logs too.