0 Replies Latest reply on Oct 10, 2013 10:12 AM by Rafael Vanderlei de Souza

    hibernate.cache.use_query_cache="true" causing issues to MBeanServer

    Rafael Vanderlei de Souza Newbie

      Hi.

       

      I am migrating an application from JBoss 4.2.2 to EAP 6.1.0 Final and I'm facing a weard situation.

       

      The application enables hibernate query cache (by setting property hibernate.cache.use_query_cache to "true" in persistence.xml). I'm using same Hibernate version that comes installed in EAP 6.1.0 (i.e. hibernate-core-4.2.0.Final-redhat-1)

       

      When I open jboss-eap-6.1.0\bin\jconsole.bat, connect locally to the JBoss process and navigate to MBeans tab, I see nothing but a blank tab. I can´t even see the basic MBeans that are usually registered (like jboss.* or java.lang.* MBeans).

       

      I notice that just by changing hibernate.cache.use_query_cache to "false" (or by removing the property, which has same effect in the end) everything works fine, i.e., I can see and manage MBeans from JConsole.

       

      I don't know if the bug (if there is any) is actually in Hibernate code or in JBoss code, but in any case I don´t know where to look at to fix this. Can anyone help me get both things working (Hibernate query cache and MBeans management through JConsole distributed in JBoss EAP installation)?

       

      To help isolate and reproduce the problem, I built a simple EAR with minimum resources required to reproduce this issue and attached to the discussion.

      Note: The only external requirement to deploy the EAR is the presence of the default datasource that comes in original EAP distribution ("java:jboss/datasources/ExampleDS").