1 Reply Latest reply on Oct 14, 2013 7:59 AM by Max Rydahl Andersen

    Unable to properly create new Eclipse projects for Drools or Guvnor in Windows8 (Drools disappears and server options aren't displayed)

    Chaya Cooper Newbie

      I've installed Eclipse on two machines (one is running Windows 8 and the other has Mac OS X v.10.5.8), but it doesn't seem to be running correctly in Windows 8 as I'm experiencing two significant problems while setting up a new project:

      1. When I use the wizard to Define a New Server in order to use Guvnor it only lists two Basic Server Type options (HTTP Preview & HTTP Server), even once I've downloaded additional servers/server adapters.
      2. Drools is running correctly for me until I set the runtime and restart Eclipse, when all the references to Drools vanish from the Eclipse workspace (including Preferences, File -> New, Perspective, or even as a result when I search in 'Quick Access'). It does however still showed Drools as installed (when I click on 'What is already installed?'). I've tried reinstalling Drools, as well as manually unzipping it and adding it to the plugin folder, but it still isn't showing up in Eclipse. In order to verify that Drools hadn't been corrupted, I created a 2nd instance of Eclipse on my desktop (where I repeated the plugin installation process) with the exact same result.

       

      I've installed both Apache (Apache HTTP Server 2.2.25) and JBoss Application Server 7 (EAP 6.1.0). In addition, I've downloaded JBoss Tools 4.1 to address the potential issue raised in this post https://community.jboss.org/en/tools/blog/2013/10/08/update-to-jboss-tools-41-and-developer-studio-70

       

      I'm running: Windows 8, Drools & Guvnor 6.0.0.CR4 and Eclipse Java EE IDE for Web Developers, Version: Kepler Service Release 1, Build id: 20130919-0819