4 Replies Latest reply on Oct 22, 2013 4:58 AM by Tomaz Cerar

    Create Vault via CLI failure on Windows

    Stylianos Koussouris Newbie

      I am attempting to add the vault in the standalone.xml but am failling

       

      The vault was initilalized as follows

       

      <vault>
        <vault-option name="KEYSTORE_URL" value="C:\Work\software\EAP\examvault\examvault.keystore"/>
        <vault-option name="KEYSTORE_PASSWORD" value="MASK-2GAtdnlXL8H"/>
        <vault-option name="KEYSTORE_ALIAS" value="examvault"/>
        <vault-option name="SALT" value="12345678"/>
        <vault-option name="ITERATION_COUNT" value="44"/>
        <vault-option name="ENC_FILE_DIR" value="C:\Work\software\EAP\examvault\\"/>
      </vault><management>
      
      
      

      In my attempt to add the vault via the CLI I continuously get the following error

       

      [standalone@localhost:9999 /] /core-service=vault:add(vault-options=[("KEYSTORE_URL"=>"C:\Work\software\EAP\examvault\examvault.keystore"),("KEYSTOR
      E_PASSWORD"=>"MASK-2GAtdnlXL8H"),("KEYSTORE_ALIAS"=>"examvault"),("SALT"=>"12438567"),("ITERATION_COUNT"=>"44"),("ENC_FILE_DIR"=>"C:\Work\software\E
      AP\examvault\\")])
      The closing '"' is missing.
      
      
      

       

      until I remove the trailing back slashes. but then I get

      [standalone@localhost:9999 /] /core-service=vault:add(vault-options=[("KEYSTORE_URL"=>"C:\Work\software\EAP\examvault\examvault.keystore"),("KEYSTOR
      E_PASSWORD"=>"MASK-2GAtdnlXL8H"),("KEYSTORE_ALIAS"=>"examvault"),("SALT"=>"12438567"),("ITERATION_COUNT"=>"44"),("ENC_FILE_DIR"=>"C:\Work\software\E
      AP\examvault")])
      {
          "outcome" => "failed",
          "failure-description" => "JBAS014749: Operation handler failed: JBAS015804: Error initializing vault --  org.jboss.as.server.services.security.V
      aultReaderException: JBAS013313: Vault Reader Exception:",
          "rolled-back" => true
      }
      
      
      

       

      For some reason the Windows back slashes seem to get ignored in the report (not sure if this is the issue)

      [standalone@localhost:9999 /] echo-dmr ./core-service=vault:add(vault-options=[("KEYSTORE_URL" => "C:\Work\software\EAP\examvault\examvault
      .keystore"), ("KEYSTORE_PASSWORD" => "MASK-2GAtdnlXL8H"), ("KEYSTORE_ALIAS" => "examvault"), ("SALT" => "12438567"),("ITERATION_COUNT" => "44"),("EN
      C_FILE_DIR"=>"C:\Work\software\EAP\examvault\\")])
      {
          "address" => [("core-service" => "vault")],
          "operation" => "add",
          "vault-options" => [
              ("KEYSTORE_URL" => "C:WorksoftwareEAPexamvaultexamvault.keystore"),
              ("KEYSTORE_PASSWORD" => "MASK-2GAtdnlXL8H"),
              ("KEYSTORE_ALIAS" => "examvault"),
              ("SALT" => "12438567"),
              ("ITERATION_COUNT" => "44"),
              ("ENC_FILE_DIR" => "C:WorksoftwareEAPexamvault")
          ]
      }
      
      
      

       

       

      whilst the unix style ones appear in the report

      [standalone@localhost:9999 /] echo-dmr ./core-service=vault:add(vault-options=[("KEYSTORE_URL" => "C:/Work/software/EAP/examvault/examvault.keystore
      "), ("KEYSTORE_PASSWORD" => "MASK-2GAtdnlXL8H"), ("KEYSTORE_ALIAS" => "examvault"), ("SALT" => "12438567"),("ITERATION_COUNT" => "44"),("ENC_FILE_DI
      R"=>"C:/Work/software/EAP/examvault/")])
      {
          "address" => [("core-service" => "vault")],
          "operation" => "add",
          "vault-options" => [
              ("KEYSTORE_URL" => "C:/Work/software/EAP/examvault/examvault.keystore"),
              ("KEYSTORE_PASSWORD" => "MASK-2GAtdnlXL8H"),
              ("KEYSTORE_ALIAS" => "examvault"),
              ("SALT" => "12438567"),
              ("ITERATION_COUNT" => "44"),
              ("ENC_FILE_DIR" => "C:/Work/software/EAP/examvault/")
          ]
      }
      
      
      

       

       

      Does anyone have any ideas?