0 Replies Latest reply on Oct 2, 2003 8:54 AM by David Sills

    Multiple versions of Oracle?

    David Sills Newbie

      I'm being asked to support multiple versions of Oracle (with driver incompatibility). I assume I cannot do this using datasources, since the Oracle classes all seem to have the same name and in instantiating the datasource it will simply pick up the first one it finds on the classpath, which may or may not be right.

      Has anyone tried using connections directly (ick!) and putting the drivers in the EAR file, so at least per EAR it will be a single driver type? Doesn't seem that that would represent a problem, but wanted to check.

      Any other ideas would be more than welcome.

      Thanks!