6 Replies Latest reply on Oct 17, 2013 6:10 PM by Michael Hirsch

    Why does errai-javax-enterprise break my app?

    Michael Hirsch Newbie

      We've been using errai for a while new.  Early on I figured out that I needed to exclude the errai-javax-enterprise jar file or the app won't load.  I just yields what we call a "white screen of death".  The page is blank and there is a very generic error that there was an error in bean initialization.

       

      I don't recall how I figured out to exclude that jar--I think by excluding one jar at a time until it worked.  A coworker says that it is because of a broken implementation of java.lang.reflect.Method, but I don't know how he knows that.

       

      Am I really the only one with this problem?  Any ideas of how to solve it?  Unfortunately, trying to upgrade to Errai 2.4.1 is failing because the CDI jar now requires the .gwt.xml file from the errai-javax-enterprises jar, so I can no longer exclude this jar file.

       

      Thanks,

       

      Michael

        • 1. Re: Why does errai-javax-enterprise break my app?
          Christian Sadilek Master

          Hi Michael,

           

          Is this an issue in DevMode with Jetty or in production mode with an app server?

           

          Can you check your browser's console log, dev mode log and server log for warnings, errors, and stacktraces and share them here? We should also take a look at your dependency graph and see if we can spot potential conflicts with the types we override in errai-javax-enterprise.

           

          Cheers,

          Christian

          • 2. Re: Why does errai-javax-enterprise break my app?
            Michael Hirsch Newbie

            Hi Christian,

             

            I get this error whether I am in jboss, or our test server, or dev mode.  I can't seem to get super dev mode to run right now.

             

            I should mention that there is no gwt or Errai code in our server.  Everything we do with Errai is limited to the client.

             

            When running in compiled mode I get this:

            D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 org.jboss.errai.ui.shared.TemplateUtil WARNING: WARNING: Replacing Element type [LABEL] with type [SPAN] D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 com.termalabs.ac.client.pages.PageController INFO: Loading D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 com.termalabs.ac.client.pages.pageselector.PageSelectorController INFO: Loading D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 com.termalabs.ac.client.AnalyticsConsoleController INFO: Loading D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 org.jboss.errai.ui.shared.TemplateUtil WARNING: WARNING: Replacing Element type [LABEL] with type [SPAN] D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 OverlayWidget INFO: OverlayWidget is loading D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 com.termalabs.ac.client.panels.addpanel.AddPanelController INFO: Loading D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 com.termalabs.ac.client.widgets.authentication.UserControlsController INFO: Loading D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 org.jboss.errai.ui.shared.TemplateUtil WARNING: WARNING: Replacing Element type [LABEL] with type [SPAN] D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 org.jboss.errai.ui.shared.TemplateUtil WARNING: WARNING: Replacing Element type [LABEL] with type [DIV] D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 org.jboss.errai.ui.shared.TemplateUtil WARNING: WARNING: Replacing Element type [LABEL] with type [DIV] D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 org.jboss.errai.ui.shared.TemplateUtil WARNING: WARNING: Replacing Element type [LABEL] with type [DIV] D14128C887824A4AF68E12206D7E61AE.cache.html:20030

            Thu Oct 17 11:55:44 GMT-600 2013 com.termalabs.ac.client.widgets.authentication.LoginWidget INFO: LoginWidget is loading

            errai] error initializing bean: com.termalabs.ac.client.widgets.authentication.LoginWidget: Widget must implement either com.google.gwt.user.client.ui.HasValue or com.google.gwt.user.client.ui.HasText! D14128C887824A4AF68E12206D7E61AE.cache.html:80363

            1. Uncaught java.lang.RuntimeException: critical error in IOC container bootstrap: java.lang.RuntimeException: error in bean initialization D14128C887824A4AF68E12206D7E61AE.cache.html:9115

             

            I put in some logging statements I can see that the that the LoginWidget.PostConstruct () has completed immediately before this message.  LoginWidget does not implement HasText or HasValue.  I changed it to implement HasText but I still get that message.  From my debugging experiments in DevMode it looked a bit like maybe it was actually throwing the error on one of the Labels in LoginWidget.  Label, of course, does implement HasText.

             

            In dev mode I get the same warnings about LABEL being replaced with DIV and SPAN (what is that about?) and then:

            ERROR: Unable to load module entry point class org.jboss.errai.ioc.client.Container (see associated exception for details)

            java.lang.RuntimeException: critical error in IOC container bootstrap: java.lang.RuntimeException: error in bean initialization

              at org.jboss.errai.ioc.client.Container.bootstrapContainer(Container.java:82)

              at org.jboss.errai.ioc.client.Container.onModuleLoad(Container.java:39)

              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

              at java.lang.reflect.Method.invoke(Method.java:597)

              at com.google.gwt.dev.shell.ModuleSpace.onLoad(ModuleSpace.java:406)

              at com.google.gwt.dev.shell.OophmSessionHandler.loadModule(OophmSessionHandler.java:200)

              at com.google.gwt.dev.shell.BrowserChannelServer.processConnection(BrowserChannelServer.java:526)

              at com.google.gwt.dev.shell.BrowserChannelServer.run(BrowserChannelServer.java:364)

              at java.lang.Thread.run(Thread.java:662)

            ERROR: Failed to load module 'AnalyticsConsole' from user agent 'Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36' at localhost.localdomain:48462

             

            I tried to debug things, but it dies in code my IDE won't show me.  The last thing I saw was in ModuleSpace:

             

              public Object invokeNativeObject(String name, Object jthis, Class<?>[] types,

                  Object[] args) throws Throwable {

                JsValue result = invokeNative(name, jthis, types, args);

                String msgPrefix = composeResultErrorMsgPrefix(name, "a Java object");

                return JsValueGlue.get(result, getIsolatedClassLoader(), Object.class,

                    msgPrefix);

              }

             

            And somewhere I saw something that made me think it was trying to do something with a Label.  Of course, Label also implements HasText.

             

            I'll put my dependencies in the next posting (in 15 minutes :-)

             

            Michael

            • 3. Re: Why does errai-javax-enterprise break my app?
              Michael Hirsch Newbie

              Gradle has way too many ways to list dependencies.  Not really knowing which is important, here they all are:

               

               

              compile - Compile classpath for source set 'main'.

              +--- jaws-errai.thirdparty:slickgrid:4.3.1dev

              |    +--- com.google.guava:guava:14.0 -> 14.0.1

              |    +--- com.google.guava:guava-gwt:14.0 -> 14.0.1

              |    |    +--- com.google.code.findbugs:jsr305:1.3.9

              |    |    \--- com.google.guava:guava:14.0.1

              |    +--- com.google.gwt:gwt-dev:2.5.1

              |    |    \--- org.json:json:20090211

              |    \--- com.google.gwt:gwt-user:2.5.1

              |         +--- javax.validation:validation-api:1.0.0.GA

              |         \--- org.json:json:20090211

              +--- jaws-errai.common:query:4.3.1dev

              |    +--- org.antlr:antlr-runtime:3.2

              |    |    \--- org.antlr:stringtemplate:3.2

              |    |         \--- antlr:antlr:2.7.7

              |    \--- com.google.guava:guava:14.0 -> 14.0.1

              +--- com.google.gwt:gwt-dev:2.5.1 (*)

              +--- com.google.gwt:gwt-user:2.5.1 (*)

              +--- org.jboss.errai:errai-ui:2.4.1.Final

              |    +--- org.jboss.errai:errai-cdi-client:2.4.1.Final

              |    |    +--- org.jboss.errai:errai-bus:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final

              |    |    |    |    \--- org.jboss.errai.reflections:reflections:2.4.1.Final

              |    |    |    |         +--- com.google.guava:guava:14.0.1

              |    |    |    |         +--- org.javassist:javassist:3.15.0-GA

              |    |    |    |         +--- org.slf4j:slf4j-api:1.6.1

              |    |    |    |         \--- dom4j:dom4j:1.6.1

              |    |    |    |              \--- xml-apis:xml-apis:1.0.b2

              |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-marshalling:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final

              |    |    |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    |    |    +--- org.mvel:mvel2:2.1.7.Final

              |    |    |    |    |    \--- junit:junit:4.10

              |    |    |    |    |         \--- org.hamcrest:hamcrest-core:1.1

              |    |    |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.1.Final

              |    |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4

              |    |    |    |         +--- org.jboss.spec.javax.interceptor:jboss-interceptors-api_1.1_spec:1.0.0.Beta1

              |    |    |    |         +--- javax.annotation:jsr250-api:1.0

              |    |    |    |         \--- javax.inject:javax.inject:1

              |    |    |    +--- com.google.inject:guice:3.0

              |    |    |    |    +--- aopalliance:aopalliance:1.0

              |    |    |    |    \--- org.sonatype.sisu.inject:cglib:2.2.1-v20090111

              |    |    |    |         \--- asm:asm:3.1

              |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    +--- org.mvel:mvel2:2.1.7.Final

              |    |    |    +--- org.slf4j:slf4j-api:1.6.1

              |    |    |    +--- junit:junit:4.10 (*)

              |    |    |    +--- org.javassist:javassist:3.15.0-GA

              |    |    |    +--- org.jboss.errai.io.netty:netty:4.0.0.Alpha1.errai.r1

              |    |    |    +--- com.google.guava:guava:14.0.1

              |    |    |    \--- org.jgroups:jgroups:3.2.0.Final

              |    |    +--- org.jboss.errai:errai-ioc-bus-support:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-ioc:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final (*)

              |    |    |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.1.Final

              |    |    |    |    +--- com.google.inject:guice:3.0 (*)

              |    |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

              |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    +--- org.jboss.errai:errai-bus:2.4.1.Final (*)

              |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final (*)

              |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

              |    |    \--- org.jboss.errai:errai-ioc:2.4.1.Final (*)

              |    +--- org.codehaus.jackson:jackson-mapper-asl:1.9.12

              |    |    \--- org.codehaus.jackson:jackson-core-asl:1.9.12

              |    +--- org.jsoup:jsoup:1.7.1

              |    +--- org.apache.stanbol:org.apache.stanbol.enhancer.engines.htmlextractor:0.10.0

              |    |    +--- org.apache.clerezza:rdf.core:0.12-incubating

              |    |    |    +--- org.osgi:org.osgi.core:4.2.0

              |    |    |    +--- org.osgi:org.osgi.compendium:4.2.0

              |    |    |    +--- org.apache.clerezza:utils:0.1-incubating

              |    |    |    |    +--- commons-codec:commons-codec:1.5

              |    |    |    |    +--- org.apache.httpcomponents:httpcore:4.1

              |    |    |    |    +--- org.osgi:org.osgi.core:4.2.0

              |    |    |    |    +--- org.wymiwyg:wymiwyg-commons-core:0.7.6

              |    |    |    |    |    +--- commons-logging:commons-logging-api:1.1

              |    |    |    |    |    +--- javax.activation:activation:1.1

              |    |    |    |    |    \--- org.slf4j:slf4j-api:1.5.8 -> 1.6.1

              |    |    |    |    \--- org.slf4j:slf4j-api:1.6.1

              |    |    |    \--- org.slf4j:slf4j-api:1.6.1

              |    |    +--- org.slf4j:slf4j-api:1.6.1

              |    |    \--- org.jsoup:jsoup:1.7.1

              |    \--- org.lesscss:lesscss:1.3.3

              |         +--- commons-io:commons-io:2.4

              |         +--- commons-logging:commons-logging:1.1.1

              |         +--- org.apache.commons:commons-lang3:3.1

              |         \--- org.mozilla:rhino:1.7R4

              +--- org.jboss.errai:errai-data-binding:2.4.1.Final

              |    +--- org.jboss.errai:errai-marshalling:2.4.1.Final (*)

              |    \--- com.google.guava:guava-gwt:14.0.1 (*)

              \--- com.allen-sauer.gwt.dnd:gwt-dnd:3.2.0

               

               

              default - Configuration for default artifacts.

              +--- jaws-errai.thirdparty:slickgrid:4.3.1dev

              |    +--- com.google.guava:guava:14.0 -> 14.0.1

              |    +--- com.google.guava:guava-gwt:14.0 -> 14.0.1

              |    |    +--- com.google.code.findbugs:jsr305:1.3.9

              |    |    \--- com.google.guava:guava:14.0.1

              |    +--- com.google.gwt:gwt-dev:2.5.1

              |    |    \--- org.json:json:20090211

              |    \--- com.google.gwt:gwt-user:2.5.1

              |         +--- javax.validation:validation-api:1.0.0.GA

              |         \--- org.json:json:20090211

              +--- jaws-errai.common:query:4.3.1dev

              |    +--- org.antlr:antlr-runtime:3.2

              |    |    \--- org.antlr:stringtemplate:3.2

              |    |         \--- antlr:antlr:2.7.7

              |    \--- com.google.guava:guava:14.0 -> 14.0.1

              +--- com.google.gwt:gwt-dev:2.5.1 (*)

              +--- com.google.gwt:gwt-user:2.5.1 (*)

              +--- org.jboss.errai:errai-ui:2.4.1.Final

              |    +--- org.jboss.errai:errai-cdi-client:2.4.1.Final

              |    |    +--- org.jboss.errai:errai-bus:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final

              |    |    |    |    \--- org.jboss.errai.reflections:reflections:2.4.1.Final

              |    |    |    |         +--- com.google.guava:guava:14.0.1

              |    |    |    |         +--- org.javassist:javassist:3.15.0-GA

              |    |    |    |         +--- org.slf4j:slf4j-api:1.6.1

              |    |    |    |         \--- dom4j:dom4j:1.6.1

              |    |    |    |              \--- xml-apis:xml-apis:1.0.b2

              |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-marshalling:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final

              |    |    |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    |    |    +--- org.mvel:mvel2:2.1.7.Final

              |    |    |    |    |    \--- junit:junit:4.10

              |    |    |    |    |         \--- org.hamcrest:hamcrest-core:1.1

              |    |    |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.1.Final

              |    |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4

              |    |    |    |         +--- org.jboss.spec.javax.interceptor:jboss-interceptors-api_1.1_spec:1.0.0.Beta1

              |    |    |    |         +--- javax.annotation:jsr250-api:1.0

              |    |    |    |         \--- javax.inject:javax.inject:1

              |    |    |    +--- com.google.inject:guice:3.0

              |    |    |    |    +--- aopalliance:aopalliance:1.0

              |    |    |    |    \--- org.sonatype.sisu.inject:cglib:2.2.1-v20090111

              |    |    |    |         \--- asm:asm:3.1

              |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    +--- org.mvel:mvel2:2.1.7.Final

              |    |    |    +--- org.slf4j:slf4j-api:1.6.1

              |    |    |    +--- junit:junit:4.10 (*)

              |    |    |    +--- org.javassist:javassist:3.15.0-GA

              |    |    |    +--- org.jboss.errai.io.netty:netty:4.0.0.Alpha1.errai.r1

              |    |    |    +--- com.google.guava:guava:14.0.1

              |    |    |    \--- org.jgroups:jgroups:3.2.0.Final

              |    |    +--- org.jboss.errai:errai-ioc-bus-support:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-ioc:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final (*)

              |    |    |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.1.Final

              |    |    |    |    +--- com.google.inject:guice:3.0 (*)

              |    |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

              |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    +--- org.jboss.errai:errai-bus:2.4.1.Final (*)

              |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final (*)

              |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

              |    |    \--- org.jboss.errai:errai-ioc:2.4.1.Final (*)

              |    +--- org.codehaus.jackson:jackson-mapper-asl:1.9.12

              |    |    \--- org.codehaus.jackson:jackson-core-asl:1.9.12

              |    +--- org.jsoup:jsoup:1.7.1

              |    +--- org.apache.stanbol:org.apache.stanbol.enhancer.engines.htmlextractor:0.10.0

              |    |    +--- org.apache.clerezza:rdf.core:0.12-incubating

              |    |    |    +--- org.osgi:org.osgi.core:4.2.0

              |    |    |    +--- org.osgi:org.osgi.compendium:4.2.0

              |    |    |    +--- org.apache.clerezza:utils:0.1-incubating

              |    |    |    |    +--- commons-codec:commons-codec:1.5

              |    |    |    |    +--- org.apache.httpcomponents:httpcore:4.1

              |    |    |    |    +--- org.osgi:org.osgi.core:4.2.0

              |    |    |    |    +--- org.wymiwyg:wymiwyg-commons-core:0.7.6

              |    |    |    |    |    +--- commons-logging:commons-logging-api:1.1

              |    |    |    |    |    +--- javax.activation:activation:1.1

              |    |    |    |    |    \--- org.slf4j:slf4j-api:1.5.8 -> 1.6.1

              |    |    |    |    \--- org.slf4j:slf4j-api:1.6.1

              |    |    |    \--- org.slf4j:slf4j-api:1.6.1

              |    |    +--- org.slf4j:slf4j-api:1.6.1

              |    |    \--- org.jsoup:jsoup:1.7.1

              |    \--- org.lesscss:lesscss:1.3.3

              |         +--- commons-io:commons-io:2.4

              |         +--- commons-logging:commons-logging:1.1.1

              |         +--- org.apache.commons:commons-lang3:3.1

              |         \--- org.mozilla:rhino:1.7R4

              +--- org.jboss.errai:errai-data-binding:2.4.1.Final

              |    +--- org.jboss.errai:errai-marshalling:2.4.1.Final (*)

              |    \--- com.google.guava:guava-gwt:14.0.1 (*)

              +--- com.allen-sauer.gwt.dnd:gwt-dnd:3.2.0

              +--- org.jboss.errai:errai-javax-enterprise:2.4.1.Final

              \--- org.slf4j:slf4j-log4j12:1.6.1

                   +--- org.slf4j:slf4j-api:1.6.1

                   \--- log4j:log4j:1.2.16

               

               

              findbugs - The FindBugs libraries to be used for this project.

              No dependencies

               

               

              findbugsPlugins - The FindBugs plugins to be used for this project.

              No dependencies

               

               

              generateCompile - Compile classpath for source set 'generate'.

              No dependencies

               

               

              generateRuntime - Runtime classpath for source set 'generate'.

              \--- jaws-errai.server:common-rest:4.3.1dev

                   +--- jaws-errai.server:base:4.3.1dev

                   |    +--- jaws-errai.common:util:4.3.1dev

                   |    |    +--- log4j:log4j:1.2.17

                   |    |    +--- commons-lang:commons-lang:2.6

                   |    |    +--- dom4j:dom4j:1.4 -> 1.6.1

                   |    |    |    \--- xml-apis:xml-apis:1.0.b2 -> 2.0.2

                   |    |    \--- org.bouncycastle:bcprov-jdk15:1.46

                   |    +--- jaws-errai.common:dto:4.3.1dev

                   |    |    +--- jaws-errai.common:util:4.3.1dev (*)

                   |    |    +--- com.thoughtworks.xstream:xstream:1.4.1

                   |    |    |    +--- xmlpull:xmlpull:1.1.3.1

                   |    |    |    \--- xpp3:xpp3_min:1.1.4c

                   |    |    +--- xerces:xerces:2.4.0

                   |    |    |    \--- xerces:xercesImpl:2.4.0 -> 2.6.2

                   |    |    +--- com.google.inject:guice:3.0

                   |    |    |    +--- javax.inject:javax.inject:1

                   |    |    |    +--- aopalliance:aopalliance:1.0

                   |    |    |    \--- org.sonatype.sisu.inject:cglib:2.2.1-v20090111

                   |    |    |         \--- asm:asm:3.1

                   |    |    \--- jaxen:jaxen:1.1.1

                   |    |         +--- dom4j:dom4j:1.6.1 (*)

                   |    |         +--- jdom:jdom:1.0

                   |    |         +--- xml-apis:xml-apis:1.3.02 -> 2.0.2

                   |    |         +--- xerces:xercesImpl:2.6.2

                   |    |         \--- xom:xom:1.0

                   |    |              +--- xerces:xmlParserAPIs:2.6.2

                   |    |              +--- xerces:xercesImpl:2.6.2

                   |    |              \--- xalan:xalan:2.6.0

                   |    |                   \--- xml-apis:xml-apis:2.0.2

                   |    +--- jaws-errai.connector:ca7-impl:4.3.1dev

                   |    |    +--- jaws-errai.connector:ca7-api:4.3.1dev

                   |    |    |    \--- jaws-errai.common:util:4.3.1dev (*)

                   |    |    +--- log4j:log4j:1.2.15 -> 1.2.17

                   |    |    \--- commons-net:commons-net:2.0

                   |    +--- jaws-errai.product:thinclient:4.3.1dev

                   |    |    +--- com.thoughtworks.xstream:xstream:1.4.1 (*)

                   |    |    \--- xerces:xerces:2.4.0 (*)

                   |    +--- jaws-errai.server:ejbintf:4.3.1dev

                   |    |    +--- jaws-errai.common:dto:4.3.1dev (*)

                   |    |    \--- jaws-errai.product:thinclient:4.3.1dev (*)

                   |    +--- org.hibernate:hibernate-core:3.3.2.GA

                   |    |    +--- antlr:antlr:2.7.6 -> 2.7.7

                   |    |    +--- commons-collections:commons-collections:3.1

                   |    |    +--- dom4j:dom4j:1.6.1 (*)

                   |    |    +--- javax.transaction:jta:1.1

                   |    |    \--- org.slf4j:slf4j-api:1.5.8

                   |    +--- com.google.inject:guice:3.0 (*)

                   |    +--- com.google.inject.extensions:guice-throwingproviders:3.0

                   |    |    \--- com.google.inject:guice:3.0 (*)

                   |    +--- jfree:jfreechart:1.0.13

                   |    |    \--- jfree:jcommon:1.0.16

                   |    +--- avalon-framework:avalon-framework-impl:4.2.0

                   |    +--- org.apache.xmlgraphics:batik-svggen:1.7

                   |    |    +--- org.apache.xmlgraphics:batik-awt-util:1.7

                   |    |    |    \--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    +--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    \--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    +--- org.apache.xmlgraphics:fop:0.95

                   |    |    +--- org.apache.xmlgraphics:xmlgraphics-commons:1.3.1

                   |    |    |    +--- commons-io:commons-io:1.3.1

                   |    |    |    \--- commons-logging:commons-logging:1.0.4 -> 1.1.3

                   |    |    +--- org.apache.xmlgraphics:batik-svg-dom:1.7

                   |    |    |    +--- org.apache.xmlgraphics:batik-anim:1.7

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-awt-util:1.7 (*)

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-dom:1.7

                   |    |    |    |    |    +--- org.apache.xmlgraphics:batik-css:1.7

                   |    |    |    |    |    |    +--- org.apache.xmlgraphics:batik-ext:1.7

                   |    |    |    |    |    |    |    \--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    |    |    |    |    |    +--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    |    |    |    |    +--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    |    |    |    |    |    \--- xml-apis:xml-apis-ext:1.3.04

                   |    |    |    |    |    +--- org.apache.xmlgraphics:batik-ext:1.7 (*)

                   |    |    |    |    |    +--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    |    |    |    +--- org.apache.xmlgraphics:batik-xml:1.7

                   |    |    |    |    |    |    \--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    |    |    |    +--- xalan:xalan:2.6.0 (*)

                   |    |    |    |    |    +--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    |    |    |    |    \--- xml-apis:xml-apis-ext:1.3.04

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-ext:1.7 (*)

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-parser:1.7

                   |    |    |    |    |    +--- org.apache.xmlgraphics:batik-awt-util:1.7 (*)

                   |    |    |    |    |    +--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    |    |    |    \--- org.apache.xmlgraphics:batik-xml:1.7 (*)

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-svg-dom:1.7 (*)

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    |    |    +--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    |    |    |    \--- xml-apis:xml-apis-ext:1.3.04

                   |    |    |    +--- org.apache.xmlgraphics:batik-awt-util:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-css:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-dom:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-ext:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-parser:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    |    +--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    |    |    \--- xml-apis:xml-apis-ext:1.3.04

                   |    |    +--- org.apache.xmlgraphics:batik-bridge:1.7

                   |    |    |    +--- org.apache.xmlgraphics:batik-anim:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-awt-util:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-css:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-dom:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-ext:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-gvt:1.7

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-awt-util:1.7 (*)

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-bridge:1.7 (*)

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    |    |    \--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    |    |    +--- org.apache.xmlgraphics:batik-parser:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-script:1.7

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-bridge:1.7 (*)

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-dom:1.7 (*)

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-ext:1.7 (*)

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-svg-dom:1.7 (*)

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    |    |    +--- org.apache.xmlgraphics:batik-js:1.7

                   |    |    |    |    |    \--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    |    |    |    \--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    |    |    +--- org.apache.xmlgraphics:batik-svg-dom:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    |    +--- org.apache.xmlgraphics:batik-xml:1.7 (*)

                   |    |    |    +--- xalan:xalan:2.6.0 (*)

                   |    |    |    +--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    |    |    \--- xml-apis:xml-apis-ext:1.3.04

                   |    |    +--- org.apache.xmlgraphics:batik-awt-util:1.7 (*)

                   |    |    +--- org.apache.xmlgraphics:batik-gvt:1.7 (*)

                   |    |    +--- org.apache.xmlgraphics:batik-transcoder:1.7

                   |    |    |    +--- org.apache.xmlgraphics:batik-awt-util:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-bridge:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-dom:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-gvt:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-svg-dom:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-svggen:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    |    +--- org.apache.xmlgraphics:batik-xml:1.7 (*)

                   |    |    |    +--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    |    |    \--- xml-apis:xml-apis-ext:1.3.04

                   |    |    +--- org.apache.xmlgraphics:batik-extension:1.7

                   |    |    |    +--- org.apache.xmlgraphics:batik-awt-util:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-bridge:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-css:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-dom:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-ext:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-gvt:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-parser:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-svg-dom:1.7 (*)

                   |    |    |    +--- org.apache.xmlgraphics:batik-util:1.7

                   |    |    |    +--- xml-apis:xml-apis:1.3.04 -> 2.0.2

                   |    |    |    \--- xml-apis:xml-apis-ext:1.3.04

                   |    |    +--- org.apache.xmlgraphics:batik-ext:1.7 (*)

                   |    |    +--- commons-logging:commons-logging:1.0.4 -> 1.1.3

                   |    |    +--- commons-io:commons-io:1.3.1

                   |    |    \--- org.apache.avalon.framework:avalon-framework-api:4.3.1

                   |    +--- javax.mail:mail:1.4.7

                   |    |    \--- javax.activation:activation:1.1

                   |    +--- org.jetlang:jetlang:0.2.10

                   |    +--- org.hibernate:hibernate-c3p0:3.3.2.GA

                   |    |    +--- org.hibernate:hibernate-core:3.3.2.GA (*)

                   |    |    +--- c3p0:c3p0:0.9.1

                   |    |    \--- org.slf4j:slf4j-api:1.5.8

                   |    +--- org.hibernate:hibernate-ehcache:3.3.2.GA

                   |    |    +--- org.hibernate:hibernate-core:3.3.2.GA (*)

                   |    |    +--- net.sf.ehcache:ehcache:1.2.3

                   |    |    |    +--- commons-logging:commons-logging:1.0.4 -> 1.1.3

                   |    |    |    \--- commons-collections:commons-collections:2.1 -> 3.1

                   |    |    \--- org.slf4j:slf4j-api:1.5.8

                   |    +--- net.sourceforge.jtds:jtds:1.2.6

                   |    +--- org.slf4j:slf4j-log4j12:1.5.2

                   |    |    +--- org.slf4j:slf4j-api:1.5.2 -> 1.5.8

                   |    |    \--- log4j:log4j:1.2.14 -> 1.2.17

                   |    +--- commons-logging:commons-logging:1.1.3

                   |    +--- commons-codec:commons-codec:1.8

                   |    +--- com.sun.xml.bind:jaxb-impl:2.2.7

                   |    |    +--- com.sun.xml.bind:jaxb-core:2.2.7

                   |    |    |    +--- javax.xml.bind:jaxb-api:2.2.7

                   |    |    |    \--- com.sun.istack:istack-commons-runtime:2.16

                   |    |    \--- com.sun.xml.fastinfoset:FastInfoset:1.2.12

                   |    |         \--- javax.xml.bind:jsr173_api:1.0

                   |    \--- org.apache.httpcomponents:httpclient:4.0

                   |         +--- org.apache.httpcomponents:httpcore:4.0.1

                   |         +--- commons-logging:commons-logging:1.1.1 -> 1.1.3

                   |         \--- commons-codec:commons-codec:1.3 -> 1.8

                   +--- jaws-errai.common:query:4.3.1dev

                   |    +--- org.antlr:antlr-runtime:3.2

                   |    |    \--- org.antlr:stringtemplate:3.2

                   |    |         \--- antlr:antlr:2.7.7

                   |    \--- com.google.guava:guava:14.0

                   +--- com.sun.jersey:jersey-core:1.13

                   +--- com.sun.jersey:jersey-server:1.13

                   |    \--- asm:asm:3.1

                   +--- jparsec:jparsec:2.0.1

                   |    \--- cglib:cglib:2.1_3

                   |         \--- asm:asm:1.5.3 -> 3.1

                   +--- org.codehaus.jettison:jettison:1.1

                   |    \--- stax:stax-api:1.0.1

                   \--- javax.servlet:servlet-api:2.4

               

               

              integTestCompile - Compile classpath for source set 'integ test'.

              No dependencies

               

               

              integTestRuntime - Runtime classpath for source set 'integ test'.

              \--- com.googlecode.gwt-test-utils:gwt-test-utils:0.44

               

               

              perfTestCompile - Compile classpath for source set 'perf test'.

              No dependencies

               

               

              perfTestRuntime - Runtime classpath for source set 'perf test'.

              No dependencies

               

               

              runtime - Runtime classpath for source set 'main'.

              +--- jaws-errai.thirdparty:slickgrid:4.3.1dev

              |    +--- com.google.guava:guava:14.0 -> 14.0.1

              |    +--- com.google.guava:guava-gwt:14.0 -> 14.0.1

              |    |    +--- com.google.code.findbugs:jsr305:1.3.9

              |    |    \--- com.google.guava:guava:14.0.1

              |    +--- com.google.gwt:gwt-dev:2.5.1

              |    |    \--- org.json:json:20090211

              |    \--- com.google.gwt:gwt-user:2.5.1

              |         +--- javax.validation:validation-api:1.0.0.GA

              |         \--- org.json:json:20090211

              +--- jaws-errai.common:query:4.3.1dev

              |    +--- org.antlr:antlr-runtime:3.2

              |    |    \--- org.antlr:stringtemplate:3.2

              |    |         \--- antlr:antlr:2.7.7

              |    \--- com.google.guava:guava:14.0 -> 14.0.1

              +--- com.google.gwt:gwt-dev:2.5.1 (*)

              +--- com.google.gwt:gwt-user:2.5.1 (*)

              +--- org.jboss.errai:errai-ui:2.4.1.Final

              |    +--- org.jboss.errai:errai-cdi-client:2.4.1.Final

              |    |    +--- org.jboss.errai:errai-bus:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final

              |    |    |    |    \--- org.jboss.errai.reflections:reflections:2.4.1.Final

              |    |    |    |         +--- com.google.guava:guava:14.0.1

              |    |    |    |         +--- org.javassist:javassist:3.15.0-GA

              |    |    |    |         +--- org.slf4j:slf4j-api:1.6.1

              |    |    |    |         \--- dom4j:dom4j:1.6.1

              |    |    |    |              \--- xml-apis:xml-apis:1.0.b2

              |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-marshalling:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final

              |    |    |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    |    |    +--- org.mvel:mvel2:2.1.7.Final

              |    |    |    |    |    \--- junit:junit:4.10

              |    |    |    |    |         \--- org.hamcrest:hamcrest-core:1.1

              |    |    |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.1.Final

              |    |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4

              |    |    |    |         +--- org.jboss.spec.javax.interceptor:jboss-interceptors-api_1.1_spec:1.0.0.Beta1

              |    |    |    |         +--- javax.annotation:jsr250-api:1.0

              |    |    |    |         \--- javax.inject:javax.inject:1

              |    |    |    +--- com.google.inject:guice:3.0

              |    |    |    |    +--- aopalliance:aopalliance:1.0

              |    |    |    |    \--- org.sonatype.sisu.inject:cglib:2.2.1-v20090111

              |    |    |    |         \--- asm:asm:3.1

              |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    +--- org.mvel:mvel2:2.1.7.Final

              |    |    |    +--- org.slf4j:slf4j-api:1.6.1

              |    |    |    +--- junit:junit:4.10 (*)

              |    |    |    +--- org.javassist:javassist:3.15.0-GA

              |    |    |    +--- org.jboss.errai.io.netty:netty:4.0.0.Alpha1.errai.r1

              |    |    |    +--- com.google.guava:guava:14.0.1

              |    |    |    \--- org.jgroups:jgroups:3.2.0.Final

              |    |    +--- org.jboss.errai:errai-ioc-bus-support:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-ioc:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final (*)

              |    |    |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.1.Final

              |    |    |    |    +--- com.google.inject:guice:3.0 (*)

              |    |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

              |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    +--- org.jboss.errai:errai-bus:2.4.1.Final (*)

              |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final (*)

              |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

              |    |    \--- org.jboss.errai:errai-ioc:2.4.1.Final (*)

              |    +--- org.codehaus.jackson:jackson-mapper-asl:1.9.12

              |    |    \--- org.codehaus.jackson:jackson-core-asl:1.9.12

              |    +--- org.jsoup:jsoup:1.7.1

              |    +--- org.apache.stanbol:org.apache.stanbol.enhancer.engines.htmlextractor:0.10.0

              |    |    +--- org.apache.clerezza:rdf.core:0.12-incubating

              |    |    |    +--- org.osgi:org.osgi.core:4.2.0

              |    |    |    +--- org.osgi:org.osgi.compendium:4.2.0

              |    |    |    +--- org.apache.clerezza:utils:0.1-incubating

              |    |    |    |    +--- commons-codec:commons-codec:1.5

              |    |    |    |    +--- org.apache.httpcomponents:httpcore:4.1

              |    |    |    |    +--- org.osgi:org.osgi.core:4.2.0

              |    |    |    |    +--- org.wymiwyg:wymiwyg-commons-core:0.7.6

              |    |    |    |    |    +--- commons-logging:commons-logging-api:1.1

              |    |    |    |    |    +--- javax.activation:activation:1.1

              |    |    |    |    |    \--- org.slf4j:slf4j-api:1.5.8 -> 1.6.1

              |    |    |    |    \--- org.slf4j:slf4j-api:1.6.1

              |    |    |    \--- org.slf4j:slf4j-api:1.6.1

              |    |    +--- org.slf4j:slf4j-api:1.6.1

              |    |    \--- org.jsoup:jsoup:1.7.1

              |    \--- org.lesscss:lesscss:1.3.3

              |         +--- commons-io:commons-io:2.4

              |         +--- commons-logging:commons-logging:1.1.1

              |         +--- org.apache.commons:commons-lang3:3.1

              |         \--- org.mozilla:rhino:1.7R4

              +--- org.jboss.errai:errai-data-binding:2.4.1.Final

              |    +--- org.jboss.errai:errai-marshalling:2.4.1.Final (*)

              |    \--- com.google.guava:guava-gwt:14.0.1 (*)

              +--- com.allen-sauer.gwt.dnd:gwt-dnd:3.2.0

              +--- org.jboss.errai:errai-javax-enterprise:2.4.1.Final

              \--- org.slf4j:slf4j-log4j12:1.6.1

                   +--- org.slf4j:slf4j-api:1.6.1

                   \--- log4j:log4j:1.2.16

               

               

              testCompile - Compile classpath for source set 'test'.

              +--- jaws-errai.thirdparty:slickgrid:4.3.1dev

              |    +--- com.google.guava:guava:14.0 -> 14.0.1

              |    +--- com.google.guava:guava-gwt:14.0 -> 14.0.1

              |    |    +--- com.google.code.findbugs:jsr305:1.3.9

              |    |    \--- com.google.guava:guava:14.0.1

              |    +--- com.google.gwt:gwt-dev:2.5.1

              |    |    \--- org.json:json:20090211

              |    \--- com.google.gwt:gwt-user:2.5.1

              |         +--- javax.validation:validation-api:1.0.0.GA

              |         \--- org.json:json:20090211

              +--- jaws-errai.common:query:4.3.1dev

              |    +--- org.antlr:antlr-runtime:3.2

              |    |    \--- org.antlr:stringtemplate:3.2

              |    |         \--- antlr:antlr:2.7.7

              |    \--- com.google.guava:guava:14.0 -> 14.0.1

              +--- com.google.gwt:gwt-dev:2.5.1 (*)

              +--- com.google.gwt:gwt-user:2.5.1 (*)

              +--- org.jboss.errai:errai-ui:2.4.1.Final

              |    +--- org.jboss.errai:errai-cdi-client:2.4.1.Final

              |    |    +--- org.jboss.errai:errai-bus:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final

              |    |    |    |    \--- org.jboss.errai.reflections:reflections:2.4.1.Final

              |    |    |    |         +--- com.google.guava:guava:14.0.1

              |    |    |    |         +--- org.javassist:javassist:3.15.0-GA

              |    |    |    |         +--- org.slf4j:slf4j-api:1.6.1

              |    |    |    |         \--- dom4j:dom4j:1.6.1

              |    |    |    |              \--- xml-apis:xml-apis:1.0.b2

              |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-marshalling:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final

              |    |    |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    |    |    +--- org.mvel:mvel2:2.1.7.Final

              |    |    |    |    |    \--- junit:junit:4.10

              |    |    |    |    |         \--- org.hamcrest:hamcrest-core:1.1

              |    |    |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.1.Final

              |    |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4

              |    |    |    |         +--- org.jboss.spec.javax.interceptor:jboss-interceptors-api_1.1_spec:1.0.0.Beta1

              |    |    |    |         +--- javax.annotation:jsr250-api:1.0

              |    |    |    |         \--- javax.inject:javax.inject:1

              |    |    |    +--- com.google.inject:guice:3.0

              |    |    |    |    +--- aopalliance:aopalliance:1.0

              |    |    |    |    \--- org.sonatype.sisu.inject:cglib:2.2.1-v20090111

              |    |    |    |         \--- asm:asm:3.1

              |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    +--- org.mvel:mvel2:2.1.7.Final

              |    |    |    +--- org.slf4j:slf4j-api:1.6.1

              |    |    |    +--- junit:junit:4.10 (*)

              |    |    |    +--- org.javassist:javassist:3.15.0-GA

              |    |    |    +--- org.jboss.errai.io.netty:netty:4.0.0.Alpha1.errai.r1

              |    |    |    +--- com.google.guava:guava:14.0.1

              |    |    |    \--- org.jgroups:jgroups:3.2.0.Final

              |    |    +--- org.jboss.errai:errai-ioc-bus-support:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-ioc:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final (*)

              |    |    |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.1.Final

              |    |    |    |    +--- com.google.inject:guice:3.0 (*)

              |    |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

              |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    +--- org.jboss.errai:errai-bus:2.4.1.Final (*)

              |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final (*)

              |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

              |    |    \--- org.jboss.errai:errai-ioc:2.4.1.Final (*)

              |    +--- org.codehaus.jackson:jackson-mapper-asl:1.9.12

              |    |    \--- org.codehaus.jackson:jackson-core-asl:1.9.12

              |    +--- org.jsoup:jsoup:1.7.1

              |    +--- org.apache.stanbol:org.apache.stanbol.enhancer.engines.htmlextractor:0.10.0

              |    |    +--- org.apache.clerezza:rdf.core:0.12-incubating

              |    |    |    +--- org.osgi:org.osgi.core:4.2.0

              |    |    |    +--- org.osgi:org.osgi.compendium:4.2.0

              |    |    |    +--- org.apache.clerezza:utils:0.1-incubating

              |    |    |    |    +--- commons-codec:commons-codec:1.5

              |    |    |    |    +--- org.apache.httpcomponents:httpcore:4.1

              |    |    |    |    +--- org.osgi:org.osgi.core:4.2.0

              |    |    |    |    +--- org.wymiwyg:wymiwyg-commons-core:0.7.6

              |    |    |    |    |    +--- commons-logging:commons-logging-api:1.1

              |    |    |    |    |    +--- javax.activation:activation:1.1

              |    |    |    |    |    \--- org.slf4j:slf4j-api:1.5.8 -> 1.6.1

              |    |    |    |    \--- org.slf4j:slf4j-api:1.6.1

              |    |    |    \--- org.slf4j:slf4j-api:1.6.1

              |    |    +--- org.slf4j:slf4j-api:1.6.1

              |    |    \--- org.jsoup:jsoup:1.7.1

              |    \--- org.lesscss:lesscss:1.3.3

              |         +--- commons-io:commons-io:2.4

              |         +--- commons-logging:commons-logging:1.1.1

              |         +--- org.apache.commons:commons-lang3:3.1

              |         \--- org.mozilla:rhino:1.7R4

              +--- org.jboss.errai:errai-data-binding:2.4.1.Final

              |    +--- org.jboss.errai:errai-marshalling:2.4.1.Final (*)

              |    \--- com.google.guava:guava-gwt:14.0.1 (*)

              +--- com.allen-sauer.gwt.dnd:gwt-dnd:3.2.0

              +--- junit:junit:4.8.2 -> 4.10 (*)

              +--- org.hamcrest:hamcrest-library:1.1

              |    \--- org.hamcrest:hamcrest-core:1.1

              +--- jaws-errai.common:util:4.3.1dev

              |    +--- log4j:log4j:1.2.17

              |    +--- commons-lang:commons-lang:2.6

              |    +--- dom4j:dom4j:1.4 -> 1.6.1 (*)

              |    \--- org.bouncycastle:bcprov-jdk15:1.46

              +--- org.jmock:jmock:2.5.1

              |    +--- org.hamcrest:hamcrest-core:1.1

              |    \--- org.hamcrest:hamcrest-library:1.1 (*)

              +--- org.jmock:jmock-legacy:2.5.1

              |    +--- org.jmock:jmock:2.5.1 (*)

              |    +--- org.objenesis:objenesis:1.0

              |    \--- cglib:cglib-nodep:2.1_3

              \--- org.jmock:jmock-script:2.5.1

                   +--- org.jmock:jmock:2.5.1 (*)

                   \--- org.beanshell:bsh:2.0b4

               

               

              testRuntime - Runtime classpath for source set 'test'.

              +--- jaws-errai.thirdparty:slickgrid:4.3.1dev

              |    +--- com.google.guava:guava:14.0 -> 14.0.1

              |    +--- com.google.guava:guava-gwt:14.0 -> 14.0.1

              |    |    +--- com.google.code.findbugs:jsr305:1.3.9

              |    |    \--- com.google.guava:guava:14.0.1

              |    +--- com.google.gwt:gwt-dev:2.5.1

              |    |    \--- org.json:json:20090211

              |    \--- com.google.gwt:gwt-user:2.5.1

              |         +--- javax.validation:validation-api:1.0.0.GA

              |         \--- org.json:json:20090211

              +--- jaws-errai.common:query:4.3.1dev

              |    +--- org.antlr:antlr-runtime:3.2

              |    |    \--- org.antlr:stringtemplate:3.2

              |    |         \--- antlr:antlr:2.7.7

              |    \--- com.google.guava:guava:14.0 -> 14.0.1

              +--- com.google.gwt:gwt-dev:2.5.1 (*)

              +--- com.google.gwt:gwt-user:2.5.1 (*)

              +--- org.jboss.errai:errai-ui:2.4.1.Final

              |    +--- org.jboss.errai:errai-cdi-client:2.4.1.Final

              |    |    +--- org.jboss.errai:errai-bus:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final

              |    |    |    |    \--- org.jboss.errai.reflections:reflections:2.4.1.Final

              |    |    |    |         +--- com.google.guava:guava:14.0.1

              |    |    |    |         +--- org.javassist:javassist:3.15.0-GA

              |    |    |    |         +--- org.slf4j:slf4j-api:1.6.1

              |    |    |    |         \--- dom4j:dom4j:1.6.1

              |    |    |    |              \--- xml-apis:xml-apis:1.0.b2

              |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-marshalling:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final

              |    |    |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    |    |    +--- org.mvel:mvel2:2.1.7.Final

              |    |    |    |    |    \--- junit:junit:4.10

              |    |    |    |    |         \--- org.hamcrest:hamcrest-core:1.1

              |    |    |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.1.Final

              |    |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4

              |    |    |    |         +--- org.jboss.spec.javax.interceptor:jboss-interceptors-api_1.1_spec:1.0.0.Beta1

              |    |    |    |         +--- javax.annotation:jsr250-api:1.0

              |    |    |    |         \--- javax.inject:javax.inject:1

              |    |    |    +--- com.google.inject:guice:3.0

              |    |    |    |    +--- aopalliance:aopalliance:1.0

              |    |    |    |    \--- org.sonatype.sisu.inject:cglib:2.2.1-v20090111

              |    |    |    |         \--- asm:asm:3.1

              |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    +--- org.mvel:mvel2:2.1.7.Final

              |    |    |    +--- org.slf4j:slf4j-api:1.6.1

              |    |    |    +--- junit:junit:4.10 (*)

              |    |    |    +--- org.javassist:javassist:3.15.0-GA

              |    |    |    +--- org.jboss.errai.io.netty:netty:4.0.0.Alpha1.errai.r1

              |    |    |    +--- com.google.guava:guava:14.0.1

              |    |    |    \--- org.jgroups:jgroups:3.2.0.Final

              |    |    +--- org.jboss.errai:errai-ioc-bus-support:2.4.1.Final

              |    |    |    +--- org.jboss.errai:errai-ioc:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-config:2.4.1.Final

              |    |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final (*)

              |    |    |    |    +--- org.jboss.errai:errai-codegen-gwt:2.4.1.Final

              |    |    |    |    +--- com.google.inject:guice:3.0 (*)

              |    |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

              |    |    |    +--- org.jboss.errai:errai-common:2.4.1.Final (*)

              |    |    |    +--- org.jboss.errai:errai-bus:2.4.1.Final (*)

              |    |    |    +--- org.jboss.errai:errai-codegen:2.4.1.Final (*)

              |    |    |    +--- javax.inject:javax.inject:1

              |    |    |    +--- javax.annotation:jsr250-api:1.0

              |    |    |    \--- javax.enterprise:cdi-api:1.0-SP4 (*)

              |    |    \--- org.jboss.errai:errai-ioc:2.4.1.Final (*)

              |    +--- org.codehaus.jackson:jackson-mapper-asl:1.9.12

              |    |    \--- org.codehaus.jackson:jackson-core-asl:1.9.12

              |    +--- org.jsoup:jsoup:1.7.1

              |    +--- org.apache.stanbol:org.apache.stanbol.enhancer.engines.htmlextractor:0.10.0

              |    |    +--- org.apache.clerezza:rdf.core:0.12-incubating

              |    |    |    +--- org.osgi:org.osgi.core:4.2.0

              |    |    |    +--- org.osgi:org.osgi.compendium:4.2.0

              |    |    |    +--- org.apache.clerezza:utils:0.1-incubating

              |    |    |    |    +--- commons-codec:commons-codec:1.5

              |    |    |    |    +--- org.apache.httpcomponents:httpcore:4.1

              |    |    |    |    +--- org.osgi:org.osgi.core:4.2.0

              |    |    |    |    +--- org.wymiwyg:wymiwyg-commons-core:0.7.6

              |    |    |    |    |    +--- commons-logging:commons-logging-api:1.1

              |    |    |    |    |    +--- javax.activation:activation:1.1

              |    |    |    |    |    \--- org.slf4j:slf4j-api:1.5.8 -> 1.6.1

              |    |    |    |    \--- org.slf4j:slf4j-api:1.6.1

              |    |    |    \--- org.slf4j:slf4j-api:1.6.1

              |    |    +--- org.slf4j:slf4j-api:1.6.1

              |    |    \--- org.jsoup:jsoup:1.7.1

              |    \--- org.lesscss:lesscss:1.3.3

              |         +--- commons-io:commons-io:2.4

              |         +--- commons-logging:commons-logging:1.1.1

              |         +--- org.apache.commons:commons-lang3:3.1

              |         \--- org.mozilla:rhino:1.7R4

              +--- org.jboss.errai:errai-data-binding:2.4.1.Final

              |    +--- org.jboss.errai:errai-marshalling:2.4.1.Final (*)

              |    \--- com.google.guava:guava-gwt:14.0.1 (*)

              +--- com.allen-sauer.gwt.dnd:gwt-dnd:3.2.0

              +--- org.jboss.errai:errai-javax-enterprise:2.4.1.Final

              +--- org.slf4j:slf4j-log4j12:1.6.1

              |    +--- org.slf4j:slf4j-api:1.6.1

              |    \--- log4j:log4j:1.2.16 -> 1.2.17

              +--- junit:junit:4.8.2 -> 4.10 (*)

              +--- org.hamcrest:hamcrest-library:1.1

              |    \--- org.hamcrest:hamcrest-core:1.1

              +--- jaws-errai.common:util:4.3.1dev

              |    +--- log4j:log4j:1.2.17

              |    +--- commons-lang:commons-lang:2.6

              |    +--- dom4j:dom4j:1.4 -> 1.6.1 (*)

              |    \--- org.bouncycastle:bcprov-jdk15:1.46

              +--- org.jmock:jmock:2.5.1

              |    +--- org.hamcrest:hamcrest-core:1.1

              |    \--- org.hamcrest:hamcrest-library:1.1 (*)

              +--- org.jmock:jmock-legacy:2.5.1

              |    +--- org.jmock:jmock:2.5.1 (*)

              |    +--- org.objenesis:objenesis:1.0

              |    \--- cglib:cglib-nodep:2.1_3

              \--- org.jmock:jmock-script:2.5.1

                   +--- org.jmock:jmock:2.5.1 (*)

                   \--- org.beanshell:bsh:2.0b4

               

               

              (*) - dependencies omitted (listed previously)

              • 4. Re: Why does errai-javax-enterprise break my app?
                Christian Sadilek Master

                Hi Michael,

                 

                The error message above indicates that the initialization of LoginWidget failed because the data binding decorators encountered a bound field that doesn't implement HasText or HasValue.

                 

                Can you check for that or maybe post your LoginWidget? This stops IOC from bootstrapping further which explains the problem you're seeing.

                 

                Cheers,

                Christian

                • 5. Re: Why does errai-javax-enterprise break my app?
                  Christian Sadilek Master

                  And another thing you can check for is the generated BootstrapperImpl.java in your .errai folder. If you search for LoginWidget in there you should see a list of .bind calls to a data binder which will help identify the widgets you attempted to bind to.

                  • 6. Re: Why does errai-javax-enterprise break my app?
                    Michael Hirsch Newbie

                    Man, but you're good.  That was exactly the tip I needed.  Yes, we were trying to bind a ListBox.  The LoginWidget was the first widget we ever built and we got that one annotation wrong.  It's pretty weird that if we exclude that jar file it works, but at least it works, now.

                     

                    Thanks so much, Christian.  This has been bothering me for months.

                     

                    Michael