2 Replies Latest reply on Oct 28, 2013 7:12 AM by Rachid AIT YAAZZA

    Modeshape repository not fully initialized

    Rachid AIT YAAZZA Newbie

      i got this error when trying to startup an application on jboss 7.1.1 with modeshape 3.1.1.Final  :

       

      16:05:31,233 DEBUG [org.modeshape.jcr.cache.RepositoryCache] (MSC service thread 1-4) Waiting for repository 'nbeportal' to be fully initialized by another process in the cluster

      16:05:32,234 ERROR [org.modeshape.jcr.cache.RepositoryCache] (MSC service thread 1-4) Repository 'nbeportal' is still not fully initialized after 10 minutes. Aborting.

      16:05:32,235 DEBUG [org.modeshape.jcr.JcrRepository] (EJB default - 1) Starting 'nbeportal' repository with configuration:

      { "name" : "nbeportal" , "jndiName" : "" , "monitoring" : { "enabled" : true } , "workspaces" : { "allowCreation" : true , "default" : "default" } , "storage" : { "cacheName" : "nbeportal" , "transactionManagerLookup" : "org.infinispan.transaction.lookup.JBossTransactionManagerLookup" , "cacheConfiguration" : "content" , "binaryStorage" : { "type" : "file" , "directory" : "/home/jboss/jboss/standalone/data/modeshape/nbeportal/nbeportal/binaries" } } , "query" : { "indexing" : { "rebuildOnStartup" : { "when" : "NEVER" } , "backend" : { "type" : "lucene" } , "analyzer" : "org.apache.lucene.analysis.standard.StandardAnalyzer" , "threadPool" : "modeshape-indexing-workers" , "batchSize" : -1 , "readerStrategy" : "SHARED" , "mode" : "SYNC" , "asyncThreadPoolSize" : 1 , "asyncMaxQueueSize" : 1 } , "indexStorage" : { "type" : "filesystem" , "location" : "/home/jboss/jboss/standalone/data/modeshape/nbeportal/indexes" } } , "security" : { "jaas" : { "policyName" : "modeshape-security" } , "anonymous" : { "username" : "<anonymous>" , "useOnFailedLogin" : false } , "providers" : [ { "classname" : "servlet" , "name" : "Authenticator that uses the Servlet context" } ] } , "garbageCollection" : { "threadPool" : "modeshape-gc" , "initialTime" : "00:00" , "intervalInHours" : 24 } }

      16:05:32,238 ERROR [com.numen.nbeportal.services.repository.RepositoryInitializer] (MSC service thread 1-4) javax.jcr.RepositoryException: Error while starting 'nbeportal' repository: Repository 'nbeportal' is still not fully initialized after 10 minutes. Aborting.

      16:05:32,240 DEBUG [org.modeshape.jcr.JcrRepository] (EJB default - 1) Loading cache 'nbeportal' from cache container modeshape

      16:05:32,241 DEBUG [org.infinispan.schematic.internal.CacheContext] (EJB default - 1) No DELTA_WRITE flag available

      16:05:32,246 DEBUG [org.infinispan.schematic.internal.CacheContext] (EJB default - 1) Using cache with flags [SKIP_REMOTE_LOOKUP] during SchematicEntry updates

      16:05:32,248 DEBUG [org.infinispan.schematic.internal.CacheContext] (EJB default - 1) Deltas will NOT be used to serializing changes to documents in 'nbeportal'.

      16:05:32,249 DEBUG [org.infinispan.schematic.internal.CacheContext] (EJB default - 1) Explicit locks will NOT be used when modifying documents in 'nbeportal' (Infinispan's locking mode is not PESSIMISTIC).

      16:05:32,249 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.deployment.unit."nbeportal.war".component.RepositoryInitializer.START: org.jboss.msc.service.StartException in service jboss.deployment.unit."nbeportal.war".component.RepositoryInitializer.START: Failed to start service

       

      1-Any idea how to solve this issue?

      2- If my repository is corrupt, how can i repair it?

        • 1. Re: Modeshape repository not fully initialized
          Randall Hauch Master

          That error does not necessarily mean that the repository is corrupted, since it basically means that this process think that another process is attempting to initialize the repository, so it is waiting but has not seen any changes. If there are multiple processes running in the cluster, it is possible that this process has not actually joined the cluster and will thus never receive any updates signaling that the repository is fully initialized.

           

          Can you describe the situation? Are there other processes in the cluster? Is the repository really supposed to be initializing, or had it been initialized by another earlier process? If the latter, is that process still running, and were there any errors in those logs.

           

          Is there a reason you haven't upgraded to 3.1.3.Final or better yet 3.2.0.Final? Do you not want to upgrade to 3.5.0.Final because it uses EAP6.1 instead of AS7.1.1?

          • 2. Re: Modeshape repository not fully initialized
            Rachid AIT YAAZZA Newbie

            Thank you for your answer.

            Actually we don't use clusters even in the production environment.

            Which makes me believe that the deposit is corrupt, is that when it is replaced by an old one it works well.

            About upgrading to a new version of modeshape with jboss EAP6, we already planned that but not yet find the time because will have many impacts on our application GUI.