9 Replies Latest reply on Jan 15, 2014 7:07 AM by Otávio Garcia

    Beta 1 - Error when use wrapped HttpServletRequest

    Otávio Garcia Newbie

      I need to wrap HttpServletRequest and HttpServletResponse in my application. When I use JBoss AS 7.1 all works fine. But testing my application with Wildfly beta 1, I got this error:

       

      java.lang.IllegalArgumentException: UT010023: Request [CustomRequest io.undertow.servlet.spec.HttpServletRequestImpl@4f519a0a] was not original or a wrapper

       

      What's wrong?