0 Replies Latest reply on Oct 30, 2013 7:48 AM by ant klad

    The requested resource is not available

    ant klad Newbie

      I have installed jboss developer studio 7 and I'm trying to create a new seam project. I created the project following exactly the procedure in Seam_Developer_Tools_Reference_Guide. The only difference is that the wizard did not present me with default seam facet settings so I downloaded jboss-seam-2.3.1.Final and using Add it added it. All other settings are the default except for the datasource that I used a Microsoft SQL Server Driver that pinged the DB.
      After the project is created I tried to run it (using right click on the project, Run As -> Run on Server) but it fails with the following message :

       

      HTTP Status 404 - /test4/

      type Status report
      message /test4/

      description The requested resource (/test4/) is not available.

      JBoss Web/7.0.13.Final


      and the error in the log is :


      11:47:10,866 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/test4]] (MSC service thread 1-1) Error configuring application listener of class org.jboss.seam.servlet.SeamListener: java.lang.ClassNotFoundException: org.jboss.seam.servlet.SeamListener from [Module "deployment.test4.war:main" from Service Module Loader]
      at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
      at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
      at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
      at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
      at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
      at org.jboss.as.web.deployment.WebInjectionContainer.newInstance(WebInjectionContainer.java:72) [jboss-as-web-7.1.1.Final.jar:7.1.1.Final]
      at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3342) [jbossweb-7.0.13.Final.jar:]
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:3850) [jbossweb-7.0.13.Final.jar:]
      at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:90) [jboss-as-web-7.1.1.Final.jar:7.1.1.Final]
      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [rt.jar:1.6.0_43]
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [rt.jar:1.6.0_43]
      at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_43]

      I believe I'm doing something wrong here, about seam configuration but I dont know what and I have already wasted 4 days searching for answers in forums and google. Could some one give me some info about this?