0 Replies Latest reply on Nov 8, 2013 1:30 AM by Adarsh CU

    CLI Public API on Jboss 7.1.1 Final

    Adarsh CU Newbie

      Hi All,

       

      I had a question regarding Jboss 7.1.1 Final release and use of Jboss CLI Public API for server side programming. I would like to control deploy/undeploy of our application on the server. I am able to use jboss-cli.bat and connect to the controller and execute the deploy/undeploy commands. It is showing as connected on standalone@localhost:9999 through the batch file but gives me an exception when the same is tried through the program. Tried options  by setting credentials, changing localhost to 127.0.0.1,etc.. But its not working. I am doing something very silly i believe or this not available for this version ?

       

      This is the exception that is thrown from my Eclipse Program

       

      8 Nov, 2013 11:35:52 AM org.xnio.Xnio <clinit>

      INFO: XNIO Version 3.0.3.GA

      org.jboss.as.cli.CommandLineException: The controller is not available at localhost:9999

        at org.jboss.as.cli.impl.CommandContextImpl.connectController(CommandContextImpl.java:639)

        at org.jboss.as.cli.impl.CommandContextImpl.connectController(CommandContextImpl.java:613)

        at com.unisys.jboss.trials.JbossCLIHandler.main(JbossCLIHandler.java:45)

       

      This is the output from jboss-cli.bat

       

      D:\Softwares_Umashaac\jboss-as-7.1.1.Final\bin>jboss-cli.bat

      You are disconnected at the moment. Type 'connect' to connect to the server or 'help' for the list of supported commands.

      [disconnected /] connect

      [domain@localhost:9999 /] quit

       

       

      Press any key to continue . . .