0 Replies Latest reply on Nov 8, 2013 11:45 AM by John Franey

    class needed for every jboss component in components.xml? (seam 2.3, eap 6.1)

    John Franey Novice

      We used themes in 2.2 on AS6, and I'm porting the app to 2.3 for eap6.1.

       

      On 2.3, themes were not bring found. Exception from ThemeSelector, line 66, IllegalStateException "no themes defined".

       

      This is the component:

      <theme:theme-selector cookie-enabled="true">

        <theme:available-themes>

           <value>...</value>

           ....

        </theme:available-themes>

      </theme:them-selector>

       

      When I add the attribute class="org.jboss.seam.theme.ThemeSelector", things work.

       

       

      But I'm still facing problems with the migration, and I suspect I should have to provide a class attribute to EVERY jboss component.  However, this migration page does not say the 'class' attribute is needed on ANY jboss component (Chapter 4. Migration from 2.2 to 2.3)

       

      So, which is it?

       

      Thanks.