1 Reply Latest reply on Nov 16, 2013 10:28 AM by Wolf-Dieter Fink

    Error starting one host into one domain, in diferent machine

    zatopek zatopek Newbie

      hello.

      i have configured into one machine (192.168.1.10) one domain controller. Into this machine i also have configured one host with two servers (into one group). theses starts well.

      i have configured into othe machine (192.168.1.2) one host with one server (into one difernt group)

       

      when i start this second host (into the machine 2) i have this error:

      00:42:20,239 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss EAP 6.1.1.GA (AS 7.2.1.Final-redhat-10) inició en 5266ms - Inició 146 de 264 servicios (117 servicios son pasivos o por demanda)

      00:42:22,180 ERROR [org.hornetq.core.server] (Old I/O server worker (parentId: -858008382, [id: 0xccdbd4c2, /192.168.1.2:5695])) HQ224018: Failed to create session: HornetQException[errorType=SECURITY_EXCEPTION message=HQ119031: Unable to validate user: HORNETQ.CLUSTER.ADMIN.USER]

        at org.hornetq.core.security.impl.SecurityStoreImpl.authenticate(SecurityStoreImpl.java:123) [hornetq-server-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]

        at org.hornetq.core.server.impl.HornetQServerImpl.createSession(HornetQServerImpl.java:962) [hornetq-server-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]

       

      the host configuration is this:

      <?xml version='1.0' encoding='UTF-8'?>

      <host name="host_2_1" xmlns="urn:jboss:domain:1.4">

          <management>

              <security-realms>

                  <security-realm name="ManagementRealm">

                      <authentication>

                          <properties path="mgmt-users.properties" relative-to="jboss.domain.config.dir"/>

                           </authentication>

                            <server-identities>

                            <secret value="MTIzNHF3ZXJf" />

                            </server-identities>

                  </security-realm>

                  <security-realm name="ApplicationRealm">

                      <authentication>

                          <local default-user="$local" allowed-users="*" />

                          <properties path="application-users.properties" relative-to="jboss.domain.config.dir" />

                      </authentication>

                      <authorization>

                          <properties path="application-roles.properties" relative-to="jboss.domain.config.dir"/>

                      </authorization>

                  </security-realm>

              </security-realms>

              <management-interfaces>

                  <native-interface security-realm="ManagementRealm">

                      <socket interface="management" port="${jboss.management.native.port:9999}"/>

                  </native-interface>

                  <http-interface security-realm="ManagementRealm">

                      <socket interface="management" port="${jboss.management.http.port:9990}"/>

                  </http-interface>

              </management-interfaces>

          </management>

      <domain-controller>

          <remote host="192.168.1.10" port="9999" username="admin" security-realm="ManagementRealm" />

          </domain-controller>

          <interfaces>

              <interface name="management">

                  <inet-address value="${jboss.bind.address.management:192.168.1.2}"/>

              </interface>

              <interface name="public">

                 <inet-address value="${jboss.bind.address:192.168.1.2}"/>

              </interface>

              <interface name="unsecure">

                  <inet-address value="${jboss.bind.address.unsecure:192.168.1.2}"/>

              </interface>

          </interfaces>

        <jvms>

          <jvm name="default">

                <heap size="64m" max-size="256m"/>

                <permgen size="256m" max-size="256m"/>

                  <jvm-options>

                      <option value="-server"/>

                  </jvm-options>

             </jvm>

        </jvms>

          <servers>

              <server name="server-three" group="second-server-group" auto-start="true">

                  <socket-bindings port-offset="250"/>

              </server>

          </servers>

      </host>

       

      Can you help me for solving this problem?

       

      thanks