2 Replies Latest reply on Nov 26, 2013 10:15 PM by jaikiran pai

    JBoss EAP 6 Migration Error in the JBoss libraries

    Meriam Jab Newbie

      I am migrating my application to JBoss EAP 6, and I am working on the JBoss Developer Studio. I have a Web application, and I am not using Maven. When I set my runtime to JBoss Eap6 in the JAva Build Path, some of the JBoss libraries are shown but not all (are these libs, the implicit lib which JBoss loads or what ?).

      I have thus an error in the import of system lib such as "org.jboss.jca.adapters.jdbc.jdk6.WrappedPreparedStatementJDK6" which belongs to "C:\jboss-eap-6.1\modules\system\layers\base\org\jboss\ironjacamar\jdbcadapters" I have added this dependency to jboss-deployment-structure.xml as below.

       

      <jboss-deployment-structure>
        <deployment>
        <dependencies>
        <module name="javax.servlet.api" />
        <module name="org.jboss.ironjacamar.jdbcadapters" />
        </dependencies>
        </deployment>
      </jboss-deployment-structure>
      

       

      What should I do to fix this ?

       

      Thanks for your help.