0 Replies Latest reply on Nov 21, 2013 11:45 PM by Keith West

    Some designer system properties don't work...

    Keith West Newbie

      I'm working with jBPM 5.4, running under JBOSS AS 7.2 and java 1.7. Rather than having to explode the designer war file to modify some of the externalloadurl properties in the jbpm.xml file, I set the following properties on the JBOSS AS start command line:

       

      designer.external.usr

      designer.external.pwd

       

      I set these to a known user id/password. I did not add the usr or pwd to the jbpm.xml in the designer war file. Designer and Guvnor couldn't sync up when I tried to edit a BPMN file when in Guvnor. The following was in the JBOSS server log:

       

      ... long stack trace...

      java.lang.IllegalArgumentException: Unable to authenticate user.

      2013-11-22 00:23:00,536 ERROR [org.jbpm.designer.web.repository.impl.UUIDBasedJbpmRepository] (http-/0.0.0.0:8080-15) Unable to connect to Gunvor. Is it running? [Server returned HTTP response code: 500 for URL: http://localhost:8080/drools-guvnor/org.drools.guvnor.Guvnor/oryxeditor?uuid=fde1ba72-9369-4cf5-835c-3774a33b2fb5&usr=null&pwd=null]

       

      Note the usr and pwd are null. However, when I set the usr and pwd to the same user id/password within the jbpm.xml, all worked fine.

       

      I took a look at the designer source code, and in org.jbpm.designer.web.repository.impl.UUIDBasedJbpmRepository, in the buildExternalLoadURL method were the following 2 lines:

       

          buff.append("&usr=").append(profile.getUsr());
          buff.append("&pwd=").append(profile.getPwd());

       

      To be able to pick up the system properties, I believe these should be more like the following:

       

          buff.append("&usr=").append(ExternalInfo.getExternalUsr(profile));
          buff.append("&pwd=").append(ExternalInfo.getExternalPwd(profile));

       

      Is this correct, or am I missing something?

       

      Thanks,

      Keith