1 Reply Latest reply on Nov 25, 2013 11:51 AM by Justin Bertram

    Unable to validate user: HORNETQ.CLUSTER.ADMIN.USER

    mike just Master

      I have followed the link AS7 Cluster Howto - JBoss AS 7.2 - Project Documentation Editor and when I come to here

       

      after I changed

      <server name="server-three" group="other-server-group" auto-start="false">
          <!-- server-three avoids port conflicts by incrementing the ports in
               the default socket-group declared in the server-group -->
          <socket-bindings port-offset="250"/>
      </server>
      

      to:

      <server name="server-three" group="other-server-group" auto-start="true">
          <!-- server-three avoids port conflicts by incrementing the ports in
               the default socket-group declared in the server-group -->
          <socket-bindings port-offset="250"/>
      </server>
      

      and also the change on slave. When I start both domain.bat on master and slave. Such error will show repeatedly after slave is registered on master.

       

      [Server:server-three] 17:38:43,372 ERROR [org.hornetq.core.server] (Old I/O server worker (parentId: 216710576, [id: 0x0
      ceabdb0, /10.10.2.7:5695])) HQ224032: Failed to create session: HornetQException[errorType=SECURITY_EXCEPTION message=HQ
      119061: Unable to validate user: HORNETQ.CLUSTER.ADMIN.USER]
      [Server:server-three]   at org.hornetq.core.security.impl.SecurityStoreImpl.authenticate(SecurityStoreImpl.java:123) [ho
      rnetq-server-2.3.0.CR1.jar:]
      [Server:server-three]   at org.hornetq.core.server.impl.HornetQServerImpl.createSession(HornetQServerImpl.java:910) [hor
      netq-server-2.3.0.CR1.jar:]
      [Server:server-three]   at org.hornetq.core.protocol.core.impl.HornetQPacketHandler.handleCreateSession(HornetQPacketHan
      dler.java:151) [hornetq-server-2.3.0.CR1.jar:]
      [Server:server-three]   at org.hornetq.core.protocol.core.impl.HornetQPacketHandler.handlePacket(HornetQPacketHandler.ja
      va:78) [hornetq-server-2.3.0.CR1.jar:]
      [Server:server-three]   at org.hornetq.core.protocol.core.impl.ChannelImpl.handlePacket(ChannelImpl.java:616) [hornetq-c
      ore-client-2.3.0.CR1.jar:]
      

       

      Any idea what it means and how to fix it? Where should HORNETQ be related? I have no idea what is going on with HORNETQ..

      jboss version eap 6.1.0 Alpha1.

       

      host.xml on master:

      <?xml version='1.0' encoding='UTF-8'?>
      
      
      <host name="master" xmlns="urn:jboss:domain:1.4">
      
      
          <management>
              <security-realms>
                  <security-realm name="ManagementRealm">
                      <authentication>
                          <local default-user="$local" />
                          <properties path="mgmt-users.properties" relative-to="jboss.domain.config.dir"/>
                      </authentication>
                  </security-realm>
                  <security-realm name="ApplicationRealm">
                      <authentication>
                          <local default-user="$local" allowed-users="*" />
                          <properties path="application-users.properties" relative-to="jboss.domain.config.dir" />
                      </authentication>
                      <authorization>
                          <properties path="application-roles.properties" relative-to="jboss.domain.config.dir"/>
                      </authorization>
                  </security-realm>
              </security-realms>
              <management-interfaces>
                  <native-interface security-realm="ManagementRealm">
                      <socket interface="management" port="${jboss.management.native.port:9999}"/>
                  </native-interface>
                  <http-interface security-realm="ManagementRealm">
                      <socket interface="management" port="${jboss.management.http.port:9990}"/>
                  </http-interface>
              </management-interfaces>
          </management>
      
      
          <domain-controller>
             <local/>
             <!-- Alternative remote domain controller configuration with a host and port -->
             <!-- <remote host="${jboss.domain.master.address}" port="${jboss.domain.master.port:9999}" security-realm="ManagementRealm"/> -->
          </domain-controller>
      
      
          <interfaces>
              <interface name="management">
                  <inet-address value="${jboss.bind.address.management:10.10.2.7}"/>
              </interface>
              <interface name="public">
                 <inet-address value="${jboss.bind.address:10.10.2.7}"/>
              </interface>
              <interface name="unsecure">
                  <!-- Used for IIOP sockets in the standard configuration.
                       To secure JacORB you need to setup SSL -->
                  <inet-address value="10.10.2.7"/>
              </interface>
          </interfaces>
      
      
        <jvms>
          <jvm name="default">
                <heap size="64m" max-size="256m"/>
                <permgen size="256m" max-size="256m"/>
                  <jvm-options>
                      <option value="-server"/>
                  </jvm-options>
             </jvm>
        </jvms>
      
      
          <servers>
              <server name="server-one" group="main-server-group">
                  <!-- Remote JPDA debugging for a specific server
                  <jvm name="default">
                    <jvm-options>
                      <option value="-agentlib:jdwp=transport=dt_socket,address=8787,server=y,suspend=n"/>
                    </jvm-options>
                 </jvm>
                 -->
              </server>
              <server name="server-two" group="main-server-group" auto-start="true">
                  <!-- server-two avoids port conflicts by incrementing the ports in
                       the default socket-group declared in the server-group -->
                  <socket-bindings port-offset="150"/>
              </server>
              <server name="server-three" group="other-server-group" auto-start="true">
                  <!-- server-three avoids port conflicts by incrementing the ports in
                       the default socket-group declared in the server-group -->
                  <socket-bindings port-offset="250"/>
              </server>
          </servers>
      </host>
      

       

      host.xml on slave:

      <?xml version='1.0' encoding='UTF-8'?>
      
      
      <host name="slave" xmlns="urn:jboss:domain:1.4">
      
      
          <management>
              <security-realms>
                  <security-realm name="ManagementRealm">
           <server-identities>
                          <secret value="UGFzc3dvcmQxQGM=" />
                      </server-identities>
                      <authentication>
                          <local default-user="$local" />
                          <properties path="mgmt-users.properties" relative-to="jboss.domain.config.dir"/>
                      </authentication>
                  </security-realm>
                  <security-realm name="ApplicationRealm">
                      <authentication>
                          <local default-user="$local" allowed-users="*" />
                          <properties path="application-users.properties" relative-to="jboss.domain.config.dir" />
                      </authentication>
                      <authorization>
                          <properties path="application-roles.properties" relative-to="jboss.domain.config.dir"/>
                      </authorization>
                  </security-realm>
              </security-realms>
              <management-interfaces>
                  <native-interface security-realm="ManagementRealm">
                      <socket interface="management" port="${jboss.management.native.port:9999}"/>
                  </native-interface>
                  <http-interface security-realm="ManagementRealm">
                      <socket interface="management" port="${jboss.management.http.port:9990}"/>
                  </http-interface>
              </management-interfaces>
          </management>
      
      
          <domain-controller>
          <remote host="10.10.2.7" port="9999" security-realm="ManagementRealm"/>
             <!-- <local/> -->
             <!-- Alternative remote domain controller configuration with a host and port -->
             <!-- <remote host="${jboss.domain.master.address}" port="${jboss.domain.master.port:9999}" security-realm="ManagementRealm"/> -->
          </domain-controller>
      
      
          <interfaces>
              <interface name="management">
                  <inet-address value="${jboss.bind.address.management:10.10.2.14}"/>
              </interface>
              <interface name="public">
                 <inet-address value="${jboss.bind.address:10.10.2.14}"/>
              </interface>
              <interface name="unsecure">
                  <!-- Used for IIOP sockets in the standard configuration.
                       To secure JacORB you need to setup SSL -->
                  <inet-address value="10.10.2.14"/>
              </interface>
          </interfaces>
      
      
        <jvms>
          <jvm name="default">
                <heap size="64m" max-size="256m"/>
                <permgen size="256m" max-size="256m"/>
                  <jvm-options>
                      <option value="-server"/>
                  </jvm-options>
             </jvm>
        </jvms>
      
      
          <servers>
              <server name="server-one" group="main-server-group">
                  <!-- Remote JPDA debugging for a specific server
                  <jvm name="default">
                    <jvm-options>
                      <option value="-agentlib:jdwp=transport=dt_socket,address=8787,server=y,suspend=n"/>
                    </jvm-options>
                 </jvm>
                 -->
              </server>
              <server name="server-two" group="main-server-group" auto-start="true">
                  <!-- server-two avoids port conflicts by incrementing the ports in
                       the default socket-group declared in the server-group -->
                  <socket-bindings port-offset="150"/>
              </server>
              <server name="server-three-slave" group="other-server-group" auto-start="true">
                  <!-- server-three avoids port conflicts by incrementing the ports in
                       the default socket-group declared in the server-group -->
                  <socket-bindings port-offset="250"/>
              </server>
          </servers>
      </host>