10 Replies Latest reply on Dec 11, 2013 9:34 PM by Adit Bhiday

    Problem using Modeshape 3.6.0 JCA adapter

    Adit Bhiday Newbie

      Hi,

      am having problems using the Modeshape 3.6.0 JCA adapter rar file. I am able to deploy the rar file on Glassfish 3.1.2 and specify the path to the repository configuration file. However when I try to access the repository it gives the following error:

      Unexpected exception while creating resource for pool modeshapePool. Exception : javax.resource.ResourceException: Failed to create session: Error while starting 'My Repository' repository: Unable to load component metadata!|#].

       

      On some digging, found that it was due to the Infinispan 5.x jars which are bundled inside the JCA rar file. That issue seems to be fixed in Infinispan 6.x.

      This was sometime back. Recently again when I tried to reproduce the same issue, then I got the following error with a near ideantical configuration:

       

      INFO: Could not complete requestjavax.jcr.RepositoryException: com.sun.appserv.connectors.internal.api.PoolingException: Failed to create session: Error while starting 'sample' repository: java.util.ServiceConfigurationError: org.infinispan.configuration.parsing.ConfigurationParser: Provider org.infinispan.loaders.bdbje.configuration.BdbjeCacheStoreConfigurationParser52 not a subtype

       

      This happens although I am not using the Berkley Database to persist the Infinispace data. The Infinispace configuration specifies FileCacheStore for it.

      Does anyone know as to what the solutions for this is? Additionally, has anyone tried using the Modeshape JCA 3.6.0 adapter on Glassfish? Would appreciate your response.

      Thanks,

      Adit