4 Replies Latest reply on Apr 7, 2014 4:09 AM by Claus Ibsen

    Error installing starting jboss-fuse

    Anupama Pradhan Newbie

      When starting the server, I am seeing this error in the log file. I am running jboss-fuse-6.1.0.redhat-139 on windows 7

       

      13:25:34,780 | ERROR | de startup timer | MavenIndexerFacade           | 241 - io.hawt.hawtio-maven-indexer - 1.2.0.M-redhat-83 | Failed to update the maven repository indices: java.io.IOException: Transfer for nexus-maven-repository-index.properties failed; Error transferring file: Connection timed out: connect

      java.io.IOException: Transfer for nexus-maven-repository-index.properties failed; Error transferring file: Connection timed out: connect

          at org.apache.maven.index.updater.WagonHelper$WagonFetcher.retrieve(WagonHelper.java:241)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at org.apache.maven.index.updater.WagonHelper$WagonFetcher.retrieve(WagonHelper.java:201)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at org.apache.maven.index.updater.DefaultIndexUpdater.downloadIndexProperties(DefaultIndexUpdater.java:459)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at org.apache.maven.index.updater.DefaultIndexUpdater.access$000(DefaultIndexUpdater.java:76)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at org.apache.maven.index.updater.DefaultIndexUpdater$IndexAdaptor.setProperties(DefaultIndexUpdater.java:589)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at org.apache.maven.index.updater.DefaultIndexUpdater.fetchAndUpdateIndex(DefaultIndexUpdater.java:814)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at org.apache.maven.index.updater.DefaultIndexUpdater.fetchAndUpdateIndex(DefaultIndexUpdater.java:157)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at io.hawt.maven.indexer.MavenIndexerFacade.downloadOrUpdateIndices(MavenIndexerFacade.java:171)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at io.hawt.maven.indexer.MavenIndexerFacade.init(MavenIndexerFacade.java:136)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at io.hawt.maven.indexer.AsyncMavenIndexerFacadeFactory.createMavenIndexer(AsyncMavenIndexerFacadeFactory.java:129)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at io.hawt.maven.indexer.AsyncMavenIndexerFacadeFactory$1.run(AsyncMavenIndexerFacadeFactory.java:54)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at java.util.TimerThread.mainLoop(Timer.java:555)[:1.7.0_45]

          at java.util.TimerThread.run(Timer.java:505)[:1.7.0_45]

      Caused by: org.apache.maven.wagon.TransferFailedException: Error transferring file: Connection timed out: connect

          at org.apache.maven.wagon.providers.http.LightweightHttpWagon.fillInputData(LightweightHttpWagon.java:143)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at org.apache.maven.wagon.StreamWagon.getInputStream(StreamWagon.java:116)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at org.apache.maven.wagon.StreamWagon.getIfNewer(StreamWagon.java:88)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at org.apache.maven.wagon.StreamWagon.get(StreamWagon.java:61)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          at org.apache.maven.index.updater.WagonHelper$WagonFetcher.retrieve(WagonHelper.java:219)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

          ... 12 more

      Caused by: java.net.ConnectException: Connection timed out: connect

          at java.net.DualStackPlainSocketImpl.connect0(Native Method)[:1.7.0_45]

          at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:79)[:1.7.0_45]

          at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)[:1.7.0_45]

          at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)[:1.7.0_45]

          at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)[:1.7.0_45]

          at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)[:1.7.0_45]

          at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)[:1.7.0_45]

          at java.net.Socket.connect(Socket.java:579)[:1.7.0_45]

          at java.net.Socket.connect(Socket.java:528)[:1.7.0_45]

          at sun.net.NetworkClient.doConnect(NetworkClient.java:180)[:1.7.0_45]

          at sun.net.www.http.HttpClient.openServer(HttpClient.java:432)[:1.7.0_45]

          at sun.net.www.http.HttpClient.openServer(HttpClient.java:527)[:1.7.0_45]

          at sun.net.www.http.HttpClient.<init>(HttpClient.java:211)[:1.7.0_45]

          at sun.net.www.http.HttpClient.New(HttpClient.java:308)[:1.7.0_45]

          at sun.net.www.http.HttpClient.New(HttpClient.java:326)[:1.7.0_45]

          at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:996)[:1.7.0_45]

          at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:932)[:1.7.0_45]

          at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:850)[:1.7.0_45]

          at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1300)[:1.7.0_45]

          at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:468)[:1.7.0_45]

          at org.apache.maven.wagon.providers.http.LightweightHttpWagon.fillInputData(LightweightHttpWagon.java:115)[241:io.hawt.hawtio-maven-indexer:1.2.0.M-redhat-83]

        • 1. Re: Error installing starting jboss-fuse
          Torsten Mielke Apprentice

          Quick sanity check: You are connected to the Internet on the machine in question?

           

          Perhaps there was a once-off connectivity problem to the Nexus server that caused a connection time out. Wait a few minutes and retry again. If not, check your connectivity to the configured repositories.

          • 2. Re: Error installing starting jboss-fuse
            Anupama Pradhan Newbie


            I have tried that. I also updated the ip from 0.0.0.0 to 127.0.0.0. Still the same issue. I have switched to use the 6.0 GA version. Will get to this again next week. Thanks

            • 3. Re: Error installing starting jboss-fuse
              Joel Holder Newbie

              Hi Anupama, did you ever resolve this?  We are running into the same error.  When we configure JBoss Fuse 6.1 to pull from our Nexus repo, we get this error:

               

              19:12:25,527 | INFO  | de startup timer | MavenIndexerFacade               | 250 - io.hawt.hawtio-maven-indexer - 1.2.0.redhat-374 | Failed to fetch the maven repository indices due to: Transfer for nexus-maven-repository-index.properties failed; Error transferring file: Connection timed out

               

              This is not a network or http level connectivity issue, as we can curl the repo's content and see it.

               

              We added this configuration in: etc/org.ops4j.pax.url.mvn.cfg

               

              org.ops4j.pax.url.mvn.repositories= \

                  http://ourmavenserver:8081/nexus/content/repositories/esb-qa@id=esb-qa

               

              Can anyone help us understand what we're doing wrong or if this feature is broken?

               

              Thanks,

               

              Joel

              • 4. Re: Error installing starting jboss-fuse
                Claus Ibsen Master

                The MavenIndexerFacade logs a INFO about it cannot download a maven index file. You can ignore this, as its only needed for the hawtio maven plugin, which allows you to use the web console to search maven repositories.

                 

                JBoss Fuse should work just fine.

                 

                Also in later builds we have disabled the maven indexer out of the box, as it suits better offline and production environments. People now need to explicit add the hawtio-maven-indexer feature if they want to use it.