5 Replies Latest reply on Dec 17, 2013 3:19 AM by Joe Wertz

    Defaut Transaction Timeout not working - Jboss EAP 6

    Harinder Singh Newbie

      We have default transaction timeout set in standalone-full-ha.xml to 300 , which as per documentation is 5 minutes.

       

      But my transaction timeout within 1 minute or 60 seconds.

       

       

      "

      <subsystem xmlns="urn:jboss:domain:transactions:1.3">

                  <core-environment>

                      <process-id>

                          <uuid/>

                      </process-id>

                  </core-environment>

                  <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>

                  <coordinator-environment enable-statistics="true" default-timeout="3000"/>

              </subsystem>

      "

       

       

      Why so, Is it BUG  in Jboss EAP 6 ? OR i have configured wrongly.

       

      I tried changing default value to 3000 it still timeout within 1 minute ?? But if i change transaction timeout to -1 then it works perfectly OK.

       

      Please provide your inputs which can lead to resolve the issue.