2 Replies Latest reply on Dec 18, 2013 2:01 PM by Thomas Fleck

    Error installing JON 3.2.0 on win32

    Thomas Fleck Newbie

      I cannot get jon-server-3.2.0.ER3 running on Windows Server 2008 (32-bit).  I've had no problems with it on RHEL 6.4(x86_64).   This is just a test environment,

      postgresql is running, storage & server will be on the same host.   This new version takes a lot more memory which was the first problem but I've got past that.  But

      I cannot seem to get past this error:

       

      C:\opt\jon-server-3.2.0.ER3>bin\rhqctl install --start

      ...

      13:29:14,665 ERROR [org.rhq.enterprise.server.installer.Installer] An error occurred: java.lang.Exception: Could not complete Cassandra schema installation: All host(s) tried for query failed (tried: /10.189.1.184 ([/10.189.1.184] Cannot connect))

              at org.rhq.enterprise.server.installer.InstallerServiceImpl.prepareDatabase(InstallerServiceImpl.java:551) [rhq-installer-util-4.9.0.JON320ER3.jar:4.9.0.JON320ER3]

              at org.rhq.enterprise.server.installer.InstallerServiceImpl.install(InstallerServiceImpl.java:306) [rhq-installer-util-4.9.0.JON320ER3.jar:4.9.0.JON320ER3]

              at org.rhq.enterprise.server.installer.Installer.doInstall(Installer.java:116) [rhq-installer-util-4.9.0.JON320ER3.jar:4.9.0.JON320ER3]

              at org.rhq.enterprise.server.installer.Installer.main(Installer.java:57) [rhq-installer-util-4.9.0.JON320ER3.jar:4.9.0.JON320ER3]

              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.6.0_45]

      ...

      13:31:10,165 INFO  [org.rhq.server.control.command.Install] It has been over [2] minutes - you may want to ensure your server initialization is proceeding as expected. You can check the log at [C:\opt\jon-server-3.2.0.ER3\logs\server.log].

      Stopping the RHQ Server [rhqserver-WIN-H60H4R24H31] service...

      RHQ Server [rhqserver-WIN-H60H4R24H31] stopped.

      The rhqstorage-WIN-H60H4R24H31 service is not installed - The specified service does not exist as an installed service. (0x424)

      RHQ storage node has stopped

      Terminate batch job (Y/N)? y

       

      C:\opt\jon-server-3.2.0.ER3>bin\rhqctl status

      13:31:34,056 INFO  [org.jboss.modules] JBoss Modules version 1.2.2.Final-redhat-1

       

      C:\opt\jon-server-3.2.0.ER3>ipconfig

      Windows IP Configuration

       

      Ethernet adapter Local Area Connection:

       

         Connection-specific DNS Suffix  . : ocsystems.com

         IPv4 Address. . . . . . . . . . . : 10.189.1.184

         Subnet Mask . . . . . . . . . . . : 255.255.255.0

         Default Gateway . . . . . . . . . : 10.189.1.254

       

      I've searched a lot and found https://community.jboss.org/thread/230190 but that wasn't quite the same nor was it resolved.   Any suggestions would be appreciated!

       

       

      Tom

        • 1. Re: Error installing JON 3.2.0 on win32
          jay shaughnessy Expert

          I think this is likely an issue with host resolution of the VPN address on the win box.  I would suggest, prior to install, edit rhq-storage.properties and set:

           

          rhq.storage.hostname=127.0.0.1

          rhq.storage.seeds=127.0.0.1

           

          See if that helps out.  Also, there are more recent spins of JON, ping me (jshaughn) in IRC if you're looking for something newer (although I don't think that is your problem).

          1 of 1 people found this helpful
          • 2. Re: Error installing JON 3.2.0 on win32
            Thomas Fleck Newbie

            Thanks for the reply.  That changed the behavior a bit, but still no joy.  Same message but just with 127.0.0.1 instead of IP.

             

            So I tried installing more incrementally:

             

            bin\rhqctl install --storage --start  // this started the agent, but not storage manager

            bin\rhqctl install --storage // this installed the storage manager, but didn't start it

            bin\rhqctl start --storage  // now both agent and storage are running

            bin\rhqctl install --server // now everything is installed, but storage & server are not running

            bin\rhqctl start  // everything is now running!

             

            C:\opt\jon-server-3.2.0.ER3>bin\rhqctl status

            13:53:37,048 INFO  [org.jboss.modules] JBoss Modules version 1.2.2.Final-redhat-1

            The RHQ Storage [rhqstorage-WIN-H60H4R24H31] Service is installed.

              Start Type: Automatic

              Interactive: No

              Running: No

            The RHQ Server [rhqserver-WIN-H60H4R24H31] Service is installed.

              Start Type: Automatic

              Interactive: No

              Running: No

            The RHQ Agent [rhqagent-WIN-H60H4R24H31] Service is installed.

              Start Type: Automatic

              Interactive: No

              Running: Yes

             

            Success, I can log into 127.0.0.1:7080/coregui, see agent running, etc.

             

            This installation process sure is fragile!  Is there a more reliable, step-by-step process documented somewhere?