2 Replies Latest reply on Dec 19, 2013 10:22 AM by Unni N

    Migrating from JBoss 5.1.0.GA

    Unni N Newbie

      Can some one please help me on what would be the best version of JBoss AS to migrate to?

       

      Currently our application is running on JBoss 5.1.0.GA with Seam 2.2 and Richfaces. I understand that I need Seam 2.3 at least to make it compatible with JBoss 7.

       

      Looks like following are my options.

       

      Build

      Version

      Date Released

      License for Production

      Wildfly

      8.0.0.Beta1

      10/4/2013

      Free

      JBoss Application Server AS 7.3

      EAP 6.2.0 GA

      12/4/2013

      Subscription needed

      JBoss Application Server AS 7.3

      EAP 6.2.0 Beta

      10/17/2013

      Subscription needed

      JBoss Application Server AS 7.2

      EAP 6.1.0 Final

      5/20/2013

      Subscription needed

      JBoss Application Server

      EAP 6.1.0 Alpha

      3/7/2013

      Free

       

      Anyone knows what version of AS is used in EAP 6.1.0.Alpha? Is it same as using JBoss AS 7.1.1.Final?

        • 1. Re: Migrating from JBoss 5.1.0.GA
          Wolf-Dieter Fink Master

          The simple answer is - That depends on your requirements

           

          If you try 6.1.0.Alpha, this will be the equivalent to AS7.2.0.Final.

           

          If you don't want to pay a subscription, i.e. for low budget installations, you might use the community edition.

          If you will have a server with the latest EE features you should use WildFly 8.0 and maybe the final version if you finish the migration.

          But remember that you will have to update the installation for bugfixes or fix/integrate it by yourself.

           

          If you are lokking for a stable and reliable productive installation for a couple of years you should consider the EAP versions where you have a lot of benefits

          • access to the Red Hat Knowledgebase
          • Open cases with SLA to ask questions or if you have problems
          • receive fixes and security updates (since 6.2 with a simple patching procedure) for years
          1 of 1 people found this helpful
          • 2. Re: Migrating from JBoss 5.1.0.GA
            Unni N Newbie

            Thanks a lot for your answer..