1 Reply Latest reply on Dec 23, 2013 6:52 AM by Tomaz Cerar

    Why wildfly-8.0.0.CR1 still contains the bug "WELD-000340"?

    xiang yingbing Master

      Dear guys,

       

                 Why wildfly-8.0.0.CR1 still contains the bug "WELD-000340"?

             java.lang.IllegalStateException: A request must be associated with the context in order to load the known conversations when using JSF with 8.0.0.Alpha4

       

                 I deployed the JSF app into wildfly-8.0.0.CR1, but still got this error:

       

      Caused by: java.lang.IllegalStateException: WELD-000340: A request must be associated with the context in order to load the known conversations

          at org.jboss.weld.context.AbstractConversationContext.checkIsAssociated(AbstractConversationContext.java:406) [weld-core-impl-2.1.1.Final.jar:2013-12-03 09:59]

          at org.jboss.weld.context.AbstractConversationContext.getCurrentConversation(AbstractConversationContext.java:420) [weld-core-impl-2.1.1.Final.jar:2013-12-03 09:59]

          at org.jboss.weld.jsf.ConversationAwareViewHandler.getActionURL(ConversationAwareViewHandler.java:110) [weld-core-jsf-2.1.1.Final.jar:2013-12-03 09:59]

          ...

       

       

               Please NOTE that my JSF app works well in jboss 7.2.0 Final.

       

       

               If I put beans.xml into WEB-INF, then this exception disappear.

               Must I do so even I do NOT use CDI?