1 Reply Latest reply on Dec 27, 2013 10:54 AM by Deepak Angeswar

    How to control Transaction Isolation level in Modeshale

    Deepak Angeswar Newbie

      All,

       

      I am using Modeshale 2.7.

      I want to control the Transaction Isolation level - can some one guide me on this?

       

      As per https://issues.jboss.org/browse/MODE-983

      It appears this should be possible.

       

      Can this be set in modeshapeconf.xml?

       

       

      regards,

      Deepak.

        • 1. Re: How to control Transaction Isolation level in Modeshale
          Deepak Angeswar Newbie

          I can see from the below link

          https://docs.jboss.org/author/display/MODE27/Database+Connector

           

          it is possible to do this. I was using Jboss JNDI for the database connectivity.

          But after setting the connection details explicitly (instead of JNDI)

           

          mode:driverClassName="net.sourceforge.jtds.jdbc.Driver"

          mode:password="XXXXX"

          mode:url="jdbc:jtds:sqlserver://LDN-LRM-PC-189:1433/reform;instance=MSSQLServer"

          mode:username="username"

          mode:isolationLevel="TRANSACTION_READ_UNCOMMITTED"

          mode:maximumConnectionsInPool="5"

           

          Th exception I got was -missing class: org.hibernate.connection.C3POConnectionProvider

          I copied hibernate-c3p0-3.5.2-Final.jar to jboss-5.1.0.GA\server\default\lib\

           

          Bu now I don't see the index creation for repository at all.

           

          The below 2 lines do not appear (when datasource is not JNDI)

           

          2013-12-27 14:35:42,536 INFO  [org.modeshape.jcr.RepositoryQueryManager] (modeshape-start-repo-2-thread-1) Started rebuilding indexes for repository 'repository'

          2013-12-27 14:35:42,560 INFO  [org.modeshape.jcr.RepositoryQueryManager] (modeshape-start-repo-2-thread-1) Completed rebuilding indexes for repository 'repository'

           

          Amy pointers on what is going wrong

           

          regards,

          Deepak.