1 Reply Latest reply on Jan 28, 2014 3:08 AM by Lars Heinemann

    FuseIDE in combination with routeContext elements from external files

    Ronny Aerts Newbie

      Hello,

      I started about a half year ago using Camel in combination ActiveMQ and I feel good with this esb solution. I created all xml files and related files using an xml or text editor. I would like to switch to a more visual editor and I came across the FuseIDE. Everthing seems to work fine except for my sub-routes. I use the routeContext functionality as sub-routes in the main route file. A sub-routes are predefined reusable routes which, dependable on the customer, are included or not (in the main file). I already have a collection of sub-routes which is extending every week.

      My main routes file is called TrisESB-config-intris-erp.xml and the sub-route are attached.

      I found the same issue in eclipse-344 (http://fusesource.com/forums/thread.jspa?messageID=17641) but it should have solved quite some time ago. I am very confused about the version information for the FuseIDE product. Eclipse-344 indicates that this issue is solved in version 2.1.0 but I can't find this version number anywhere. I download the FuseIDE as part of the jboss fuse page and this gives me a download file FuseIDE-6.0.0.129-win32.win32.x86_64.zip. A see here a version 6.0.0.129 and zip contains a folder FuseIDE-6.0.0.
      The "About FuseIDE" window (in eclipse) shows a version 7.6.2 (but I think this is the eclipse.exe version).

      Can someone please clear out this version confusion? Can someone tell me why my sub-route design windows is blank when I open it?