1 Reply Latest reply on Dec 31, 2013 5:11 PM by Robert Panzer

    Arquillian with WAS container

    Arvind Gupta Newbie

      Dear All ,     

                I am trying to make pom file to work with WAS V8.0 - Embedded container . but when I am trying to add dependency regarding WAS . it shows an error missing artifact id (Missing artifact org.jboss.arquillian.container:arquillian-was-embedded-8:jar:1.0.0.Alpha2) . I am not much familiar with arquillian . Can anybody figure out where I am doing mistake.

       

      Thanks,

      Arvind

       

      <!--pom.xml-->

       

       

      <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

        xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">

        <modelVersion>4.0.0</modelVersion>

       

       

        <groupId>org.arquillian.example</groupId>

        <artifactId>arquillian-tutorial</artifactId>

        <version>1.0-SNAPSHOT</version>

        <packaging>jar</packaging>

       

       

        <name>arquillian-tutorial</name>

        <url>http://maven.apache.org</url>

       

       

        <properties>

          <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>

        <version.selenium>2.33.0</version.selenium>

       

        </properties>

       

       

        <build>

              <plugins>

                  <plugin>

                      <artifactId>maven-compiler-plugin</artifactId>

                      <version>2.3.2</version>

                      <configuration>

                          <source>1.6</source>

                          <target>1.6</target>

                      </configuration>

                  </plugin>

        <plugin>

        <artifactId>maven-surefire-plugin</artifactId>

        <version>2.16</version>

        </plugin>

       

              </plugins>

       

        <!-- test resource filtering evaluates ${browser} expression in arquillian.xml -->

        <testResources>

        <testResource>

        <directory>src/test/resources</directory>

        <filtering>true</filtering>

        </testResource>

        </testResources>

        </build>

       

        <dependencyManagement>

          <dependencies>

        <dependency>

         <groupId>org.jboss.arquillian</groupId>

         <artifactId>arquillian-bom</artifactId>

         <version>1.1.2.Final</version>

         <type>pom</type>

         <scope>import</scope>

        </dependency>

        <dependency>

         <groupId>org.jboss.arquillian.extension</groupId>

         <artifactId>arquillian-drone-bom</artifactId>

         <version>1.2.0.Final</version>

         <type>pom</type>

         <scope>import</scope>

        </dependency>

          </dependencies>

        </dependencyManagement>

       

       

        <dependencies>

        <dependency>

         <groupId>org.jboss.arquillian.extension</groupId>

         <artifactId>arquillian-drone-api</artifactId>

         <scope>test</scope>

        </dependency>

        <!--drone-->

        <dependency>

        <groupId>org.jboss.arquillian.extension</groupId>

        <artifactId>arquillian-drone-impl</artifactId>

        <scope>test</scope>

        </dependency>

        <dependency>

        <groupId>org.jboss.arquillian.extension</groupId>

        <artifactId>arquillian-drone-selenium</artifactId>

        <scope>test</scope>

        </dependency>

        <dependency>

        <groupId>org.jboss.arquillian.extension</groupId>

        <artifactId>arquillian-drone-selenium-server</artifactId>

        <scope>test</scope>

        </dependency>

        <dependency>

        <groupId>org.seleniumhq.selenium</groupId>

        <artifactId>selenium-java</artifactId>

        <scope>test</scope>

        </dependency>

        <dependency>

        <groupId>org.seleniumhq.selenium</groupId>

        <artifactId>selenium-server</artifactId>

        <scope>test</scope>

        <exclusions>

        <exclusion>

        <groupId>org.mortbay.jetty</groupId>

        <artifactId>servlet-api-2.5</artifactId>

        </exclusion>

        </exclusions>

        </dependency>

       

        <!--basic requirement-->

       

        <dependency>

         <groupId>junit</groupId>

         <artifactId>junit</artifactId>

         <scope>test</scope>

          <version>4.8.1</version>

        </dependency>

        <dependency>

         <groupId>org.jboss.arquillian.testng</groupId>

         <artifactId>arquillian-testng-container</artifactId>

         <scope>test</scope>

        </dependency>

        <dependency>

        <groupId>org.jboss.arquillian.junit</groupId>

        <artifactId>arquillian-junit-container</artifactId>

        <scope>test</scope>

        </dependency>

        <dependency>

        <groupId>org.slf4j</groupId>

        <artifactId>slf4j-simple</artifactId>

        <version>1.6.6</version>

        </dependency>

       

       

       

        </dependencies>

        <profiles>

        <!-- was  -->

        <profile>

        <id>was</id>

        <activation>

        <activeByDefault>true</activeByDefault>

        </activation>

        <dependencies>

        <dependency>

         <groupId>org.jboss.arquillian.container</groupId>

         <artifactId>arquillian-was-embedded-8</artifactId>

         <version>1.0.0.Alpha2</version>

         <scope>test</scope>

        </dependency>

       

       

        </dependencies>

        </profile>

       

        

      </profiles>

      </project>