7 Replies Latest reply on Sep 1, 2015 7:17 PM by Luís Cachulo

    start.demo fails to start jbpm-console v6

    Tanya Ruttenberg Expert

      I downloaded jbpm-installer the full version.  Trying to start the jbpm-console using "ant start.demo.noeclipse".

      It's not working. I'm appending my server.log.

       

      TDR

        • 1. Re: start.demo fails to start jbpm-console v6
          Diyar Bakir Newbie

          run to standalone.bat in folder  jboss/bin

          here is standalone.bat

          • 2. Re: start.demo fails to start jbpm-console v6
            Tanya Ruttenberg Expert

            I don't understand what you are saying.  There is something to change/look at in standalone.bat?

             

            The server is starting, the app jbpm-console is not deploying.

             

            The error seems to start with an inability to get to github.com.    This is the apparent beginning of the problems?  Maybe?

             

            I can't seem to copy/paste the salient parts of the server.log into this buffer.

            Too much to type.  Someone please look at the server.log.

             

            Well.. if there is a way to get around having to access github.com I'd like to know what it is.  My organization prevents access to the internet via any client other than IE.  It's not a proxy problem, it's a client problem. Only IE can use the internet. :-(

            • 3. Re: start.demo fails to start jbpm-console v6
              GulamNadim Mansuri Newbie

              have you install JBPM 6? First write ant install.demo, then ant start,demo, then ant install.dashboard.into.jboss, then try to open first localhost:8080, then add console-jbpm, I hope it will work for you. If still not work then check whether 8080 port not in use.

              • 4. Re: start.demo fails to start jbpm-console v6
                Tanya Ruttenberg Expert

                I found teh specific problem and posted it in a new discussion where it was resolved.

                Unfortunately I can't paste the dang URL in here. (It's a problem with my local browser - very restricted at work)

                It had to do with accessing the internet (something else I can't do).

                1 of 1 people found this helpful
                • 5. Re: start.demo fails to start jbpm-console v6
                  Diyar Bakir Newbie

                  in the jbpm installer folder there is another folder called bin, bin inside there is a file standalone.bat, runs this file

                  • 6. Re: start.demo fails to start jbpm-console v6
                    xu rui Newbie

                    Hi ,sir

                    I have the same problem!!!

                    I delete "jbpm-console.war" from "wildfly-8.1.0.Final\standalone\deployments", and replace with "jbpm-console-6.1.0.Final.war" and "dashboard-builder-6.1.0.Final.war" from "\jbpm-installer\lib"  , restart the demo~~~~, these two wars can be deployed successfully .

                    But when I change the database , and modify the files named persistence.xml which are located in "jbpm-console-6.1.0.Final.war" and "dashboard-builder-6.1.0.Final.war" , restart jboss . They are all field........


                    Do you have found the raight way with our problems!?


                    Hope your Reply!!!!

                    Thank you!

                    • 7. Re: start.demo fails to start jbpm-console v6
                      Luís Cachulo Newbie

                      Yes, i found that file in jbpm-installer\wildfly-8.1.0.Final\bin, but i get the same result, i.e., the same errors.

                      In my case, in windows 10, i have first error :

                       

                      ERROR [org.jboss.msc.service.fail] (MSC service thread 1-7) MSC000001: Failed to start service jboss.deployment.unit."jbpm-console.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."jbpm-console.war".PARSE: JBAS018733: Failed to process phase PARSE of deployment "jbpm-console.war"

                              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:166) [wildfly-server-8.1.0.Final.jar:8.1.0.Final]

                              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1948) [jboss-msc-1.2.2.Final.jar:1.2.2.Final]

                              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1881) [jboss-msc-1.2.2.Final.jar:1.2.2.Final]

                              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_60]

                              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_60]

                              at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_60]

                      Caused by: org.jboss.msc.service.ServiceNotFoundException: Service service jboss.ejb.default-resource-adapter-name-service not found

                              at org.jboss.msc.service.ServiceContainerImpl.getRequiredService(ServiceContainerImpl.java:668) [jboss-msc-1.2.2.Final.jar:1.2.2.Final]