1 Reply Latest reply on Jan 9, 2014 3:34 PM by jay shaughnessy

    Jboss ON Installation problems

    Vijay Patel Newbie

      Hi All,

       

      We are planning to migrate from Oracle Weblogic Portal to Jboss Portal. We are planning to use Jboss ON 3.2 for Management and Monitoring. We are currently evaluating our application functionality on Jboss Portal and trying to install Jboss ON. Going through Redhat's documentation on Jboss ON I am bit of confused.

       

      • Before installing Jboss ON server do we have to start Jboss Portal?
      • When I run rhqctl install --start, I keep on getting following message and nothing happens after that

      10:33:15,718 INFO  [org.rhq.enterprise.server.installer.Installer] The installer has already been told to perform its work. The server should be ready soon.

      10:33:39,258 INFO  [org.rhq.server.control.command.Install] Still waiting for server to initialize...

      10:34:09,510 INFO  [org.rhq.server.control.command.Install] Still waiting for server to initialize...

      10:34:39,817 INFO  [org.rhq.server.control.command.Install] Still waiting for server to initialize...

      10:35:10,187 INFO  [org.rhq.server.control.command.Install] It has been over [2] minutes - you may want to ensure your server initialization is proceeding as expected. You can check the log at [/opt/jon/jon-server-3.2.0.GA/logs/server.log].

       

       

      • Database is on Oracle 11gR2 running on different server.
      • When I run rhqctl status I don't see any info about server.

      [root@jboss-jon bin]# ./rhqctl status

      10:37:10,763 INFO  [org.jboss.modules] JBoss Modules version 1.2.2.Final-redhat-1

      RHQ Storage Node               (pid 4251   ) IS running

      RHQ Agent                      (pid 3469   ) IS running

      [root@jboss-jon bin]#

       

      Thanks in advance for your time. Please let me know if I have to post anything more in order to help troubleshooting.

        • 1. Re: Jboss ON Installation problems
          jay shaughnessy Expert

          Hi Vijay, first off, if you're using JON you can directly open support cases for any issues you have.

           

          The way the server installation works is that it starts up a "vanilla" EAP Server and then the installer modifies it to be a JON server.  For some reason the initial EAP server startup is either failing or is not accessible to the installer.  Check the rhq-server/logs/server.log for any indication as to what may be wrong.  There are other logs there as well but the server.log may indicate the startup issue.  Typically this kind of issue is due to a host address issue, like a resolution problem.