0 Replies Latest reply on Jan 23, 2014 2:56 PM by Oscar Martinez

    SPRING WEB SERVICES -  HTTPS ISSUE WITH LOAD BALANCE

    Oscar Martinez Newbie

      We have one load balance + 2 jboss 7 servers. We are using spring web services version 2.1.0.RELEASE

      The load balance is set to : 

       

      HTTP profile set to ‘http’ a forced  redirect to https.

       

      The problem is that Spring is not updating the SOAP address inside the WSDL file, we are expecting to see HTTPS however this is not happening:

       

      <soap:address xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" location="http://wcs.stage.budco.com:80/ws"/>

       

      We have enable the WSDL locations in the web.xml file.

      <servlet>

              <servlet-name>spring-ws</servlet-name>

              <servlet-class>org.springframework.ws.transport.http.MessageDispatcherServlet</servlet-class>

              <init-param>

                  <param-name>transformWsdlLocations</param-name>

                  <param-value>true</param-value>

              </init-param>

          </servlet>

          <servlet-mapping>

              <servlet-name>spring-ws</servlet-name>

              <url-pattern>/ws/*</url-pattern>

          </servlet-mapping>

       

       

      Also our standlaone.xml for jboss have the following connectors, and the corresponding bidings

       

       

      <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host" native="false">

                  <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>

                  <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https" enable-lookups="false" secure="true"/>

                  <virtual-server name="default-host" enable-welcome-root="false">

                      <alias name="localhost"/>

                      <alias name="example.com"/>

                  </virtual-server>

              </subsystem>

       

       

      <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">

              <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>

              <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>

              <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>

              <socket-binding name="ajp" port="8009"/>

              <socket-binding name="http" port="8080"/>

              <socket-binding name="https" port="8443"/>

              <socket-binding name="osgi-http" interface="management" port="8090"/>

              <socket-binding name="remoting" port="4447"/>

              <socket-binding name="txn-recovery-environment" port="4712"/>

              <socket-binding name="txn-status-manager" port="4713"/>

              <outbound-socket-binding name="mail-smtp">

                  <remote-destination host="localhost" port="25"/>

              </outbound-socket-binding>

          </socket-binding-group>

       

       

      Is there configurations that we are missing?  Any help would be appreciated.