5 Replies Latest reply on Jan 22, 2004 5:18 PM by Darran Lofthouse

    NoSuchMethodError....  Solution

    ianlinsdell Newbie

       

      "IanLinsdell" wrote:
      Hopefully this information will prevent other people
      from wasting 2 days trying to find the problem like I have.

      I have noticed several others using this forum with the same
      problem, I am a little suprised that no one has posted the
      solution yet ?

      Journal
      ~~~~~~~
      I installing JBoss3.2.2 but everytime I tried to deploy a CMP2.0
      entity bean I got a MethodNotFoundError.

      I then tried installing JBoss3.2.3. ( still the same )

      I then tried configuring JBoss to use MySQL instead of the supplied
      Hypersonic SQL database. ( still the same )

      I downloaded the JBoss source and debuged the deployment, the problem
      was comming from the EJBQL token parser.

      I compiled the testsuite, in particular the cmp2-simple.jar as a good
      CMP2.0 sample. ( still the same )

      I deduced from this that there was not a problem with my code,
      which in fact is what turned out to be the case !

      bearing this in mind I tried different environments, the very last
      thing I tried.....

      The Jboss download page says: 'JBoss 3.2 and earlier will run on 1.3+ JVMs. JBoss 4.0 requires 1.4+ JVMs'

      wholy smoke I should know better than to believe what I read and also
      you would have thought I have lernt the lesson by now that Java is:

      Write many times, run onece and not Write onece, run many times.

      I can confirm that JBoss3.x will not run correctly on JVM1.3.1_02

      Changing to JVM1.4 fixed my problem and no more NoSuchMethodError.

      Hope this helps others.