1 Reply Latest reply on Feb 10, 2014 1:00 PM by Horia Chiorean

    CAN"T BUILD MODESHAPE QUICK STARTS.

    Mark Dzmura Newbie

      I have modeshape 3.6.0-final installed on a JBoss EAP 6.1 instance.  The basic install checks seem to work.  Now I am trying to build the quick starts which I have cloned from GitHub.  I have Maven3 and have set up MAVEN_OPTS as described, and am using the mvn build line given in the Building section of the Modeshape Wiki main page.  Each of the subprojects gives a set of errors that looks like this:

       

      [ERROR]   The project org.modeshape.quickstarts:modeshape-servlet:4.0-SNAPSHOT (/home/mdzmura/projects/quickstart/modeshape-servlet/pom.xml) has 10 errors

      [ERROR]     Non-resolvable import POM: Failure to find org.modeshape.bom:modeshape-bom-jbossas:pom:4.0-SNAPSHOT in http://repository.jboss.org/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced @ line 42, column 25 -> [Help 2]

      [ERROR]     'dependencies.dependency.version' for javax.jcr:jcr:jar is missing. @ line 53, column 21

      [ERROR]     'dependencies.dependency.version' for org.jboss.logging:jboss-logging:jar is missing. @ line 58, column 21

      [ERROR]     'dependencies.dependency.version' for javax.enterprise:cdi-api:jar is missing. @ line 64, column 21

      [ERROR]     'dependencies.dependency.version' for org.jboss.spec.javax.annotation:jboss-annotations-api_1.1_spec:jar is missing. @ line 72, column 21

      [ERROR]     'dependencies.dependency.version' for org.jboss.spec.javax.servlet:jboss-servlet-api_3.0_spec:jar is missing. @ line 79, column 21

      [ERROR]     'dependencies.dependency.version' for junit:junit:jar is missing. @ line 86, column 21

      [ERROR]     'dependencies.dependency.version' for org.jboss.arquillian.junit:arquillian-junit-container:jar is missing. @ line 99, column 21

      [ERROR]     'dependencies.dependency.version' for org.jboss.arquillian.protocol:arquillian-protocol-servlet:jar is missing. @ line 104, column 21

      [ERROR]     'dependencies.dependency.version' for org.jboss.shrinkwrap.resolver:shrinkwrap-resolver-depchain:pom is missing. @ line 109, column 21

      [ERROR]

       

      I'm no Maven Guru, but I assume that this is the root cause:

       

          Non-resolvable import POM: Failure to find org.modeshape.bom:modeshape-bom-jbossas:pom:4.0-SNAPSHOT in http://repository.jboss.org/nexus/content/groups/public/

       

      Is this because the artifact is missing from the JBoss repository, or something else?  Can somebody help me resolve this?

       

      The web page also says that the quick starts have been updated for WildFly 8.  Does that break the support for JBoss EAP 6.1 ??

       

      Thanks,

      Mark