4 Replies Latest reply on Feb 19, 2014 12:18 PM by and and

    mod_cluster_manager problem

    and and Newbie

      Hi,

       

      I downloaded mod_cluster 1.2.0.Final tar bundles, extracted, copied opt to /opt, run from /opt/jboss/httpd/sbin/apachectl start and I had access to localhost:6666/mod_cluster_manager

      For the first run everything was ok, but then I turned off my vm with ubuntu and started again.

      I started again /opt/jboss/httpd/sbin/apachectl start and I didn't have access to localhost:6666/mod_cluster_manager - 404 page not found.

       

      I didn't change anything in configuration.

      When I created againa new VM with ubuntu and installed new mod_cluster for the first run everything was ok but after second run it didn't started too.

       

      Can anyone know what is wrong?

        • 1. Re: mod_cluster_manager problem
          nathan dennis Expert

          without looking at your config no one can really answer this. might want to post that. but just speaking from experience here, things that consistently create these type of after reboot problems for me are iptables and selinux.

          • 2. Re: mod_cluster_manager problem
            and and Newbie

            I have default configuration which is in binaries linux2-x86, mod_cluster 1.2.0.Final tar bundles downloaded from Mod_cluster 1.2.0.Final - JBoss Community. No other changes.

            • 3. Re: mod_cluster_manager problem
              nathan dennis Expert

              may be a silly question, but is the correct apache server running? what does your httpd log say? use tail -f and monitor it as you try to access the manager.

              • 4. Re: mod_cluster_manager problem
                and and Newbie

                logs from error_log when run sudo /opt/jboss/httpd/sbin/apachectl start

                 

                [Wed Feb 19 18:15:09 2014] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]

                [Wed Feb 19 18:15:09 2014] [warn] No JkLogFile defined in httpd.conf. Using default /opt/jboss/httpd/httpd/logs/mod_jk.log

                [Wed Feb 19 18:15:09 2014] [warn] No JkShmFile defined in httpd.conf. Using default /opt/jboss/httpd/httpd/logs/jk-runtime-status

                [Wed Feb 19 18:15:09 2014] [notice] Digest: generating secret for digest authentication ...

                [Wed Feb 19 18:15:09 2014] [notice] Digest: done

                [Wed Feb 19 18:15:10 2014] [warn] No JkLogFile defined in httpd.conf. Using default /opt/jboss/httpd/httpd/logs/mod_jk.log

                [Wed Feb 19 18:15:10 2014] [warn] No JkShmFile defined in httpd.conf. Using default /opt/jboss/httpd/httpd/logs/jk-runtime-status

                [Wed Feb 19 18:15:10 2014] [notice] Advertise initialized for process 2502

                [Wed Feb 19 18:15:10 2014] [notice] Apache/2.2.21 (Unix) mod_cluster/1.2.0.Final mod_ssl/2.2.21 OpenSSL/0.9.8r DAV/2 mod_jk/1.2.30 configured -- resuming normal operations

                 

                 

                No new logs when accessing localhost:6666/mod_cluster_manager