2 Replies Latest reply on Feb 18, 2014 8:34 AM by Alexey Shashov

    Exception occurred org.apache.lucene.store.LockObtainFailedException: Lock obtain timed out

    Alexey Shashov Newbie

      Hello.

      I'm migrating my java application using modeshape 2.8 to modeshape 3.7.1.Final . My application is using javax.jcr.RepositoryFactory to load modeshape repository. After I changed my xml modeshape configuration to json modeshape configuration and infinispan xml configuration, I'm using oracle DB for infinispan. I tried to deploy my application. It deployed without errors, but when I tried to create a folder it said that it doesn't recognize "cf" prefix. I figured, that it happened, because I forgot to add nodetypes, that the application is using, to my configuration. After I added .cnd file to the configuration I got the following error, that I couldn't figure out how to fix.

       

      ERROR [org.hibernate.search.exception.impl.LogErrorHandler] (Hibernate Search: Index updates queue processor for index nodeinfo-1) HSEARCH000058: Exception occurred org.apache.lucene.store.LockObtainFailedException: Lock obtain timed out: SimpleFSLock@target\content\index\nodeinfo\write.lock

      Primary Failure:

          Entity org.modeshape.jcr.query.lucene.basic.NodeInfo  Id a7ca237317f1e7/jcr:system/jcr:nodeTypes/{http????www.<mywebsite>.com}Folder/{http????www.<mywebsite>.com}LastUpdateUser/String/1  Work Type  org.hibernate.search.backend.UpdateLuceneWork

      Subsequent failures:

          Entity org.modeshape.jcr.query.lucene.basic.NodeInfo  Id a7ca237317f1e7/jcr:system/jcr:nodeTypes/{http????www.<mywebsite>.com}File/{http????www.<mywebsite>.com}SystemFileType/String/1  Work Type  org.hibernate.search.backend.UpdateLuceneWork

          Entity org.modeshape.jcr.query.lucene.basic.NodeInfo  Id a7ca237317f1e7/jcr:system/jcr:nodeTypes/{http????www.<mywebsite>.com}Folder/{http????www.<mywebsite>.com}CreationDate/Date/1  Work Type  org.hibernate.search.backend.UpdateLuceneWork

           ...

       

      Then it lists all my other custom node properties with the same message. I attached part of log about modeshape.

      Is this a known issue? Do you know where I should look?

       

      Thanks,

      Alexey