2 Replies Latest reply on Mar 3, 2014 11:15 PM by Rakesh Balguri

    Building JBoss EAP 6.1.0 Final from source

    Rakesh Balguri Expert

      Hi all,

       

      I have been trying to build the JBoss EAP6.1.0Final by downloading the sources but with no luck.

       

      I am using maven 3.0.4 and I get the following errors when I run the build as mvn package. Looks like there are some problems with the pom.xml of some of the osgi modules.

       

      E:\RAKESH\JBoss_Upgrade\jboss-eap-6.1.0-src\jboss-eap-6.1-src>mvn package

      [INFO] Scanning for projects...

      [WARNING] The POM for org.apache.felix:maven-bundle-plugin:jar:2.3.7-redhat-1 is missing, no dependency information available

      [ERROR] The build could not read 3 projects -> [Help 1]

      [ERROR]

      [ERROR]   The project org.jboss.as:jboss-as-osgi-configadmin:7.2.0.Final-redhat-8 (E:\RAKESH\JBoss_Upgrade\jboss-eap-6.1.0-src\jboss-eap-6.1-src\osgi\in

      tegration\configadmin\pom.xml) has 2 errors

      [ERROR]     Unresolveable build extension: Plugin org.apache.felix:maven-bundle-plugin:2.3.7-redhat-1 or one of its dependencies could not be resolved: Fai

      lure to find org.apache.felix:maven-bundle-plugin:jar:2.3.7-redhat-1 in http://repository.jboss.org/nexus/content/groups/public/ was cached in the local re

      pository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced -> [Help 2]

      [ERROR]     Unknown packaging: bundle @ line 35, column 16

      [ERROR]

      [ERROR]   The project org.jboss.as:jboss-as-osgi-http:7.2.0.Final-redhat-8 (E:\RAKESH\JBoss_Upgrade\jboss-eap-6.1.0-src\jboss-eap-6.1-src\osgi\integrati

      on\http\pom.xml) has 2 errors

      [ERROR]     Unresolveable build extension: Plugin org.apache.felix:maven-bundle-plugin:2.3.7-redhat-1 or one of its dependencies could not be resolved: Fai

      lure to find org.apache.felix:maven-bundle-plugin:jar:2.3.7-redhat-1 in http://repository.jboss.org/nexus/content/groups/public/ was cached in the local re

      pository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced -> [Help 2]

      [ERROR]     Unknown packaging: bundle @ line 38, column 16

      [ERROR]

      [ERROR]   The project org.jboss.as:jboss-as-osgi-jpa:7.2.0.Final-redhat-8 (E:\RAKESH\JBoss_Upgrade\jboss-eap-6.1.0-src\jboss-eap-6.1-src\osgi\integratio

      n\jpa\pom.xml) has 2 errors

      [ERROR]     Unresolveable build extension: Plugin org.apache.felix:maven-bundle-plugin:2.3.7-redhat-1 or one of its dependencies could not be resolved: Fai

      lure to find org.apache.felix:maven-bundle-plugin:jar:2.3.7-redhat-1 in http://repository.jboss.org/nexus/content/groups/public/ was cached in the local re

      pository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced -> [Help 2]

      [ERROR]     Unknown packaging: bundle @ line 38, column 16

      [ERROR]

      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

      [ERROR] Re-run Maven using the -X switch to enable full debug logging.

      [ERROR]

      [ERROR] For more information about the errors and possible solutions, please read the following articles:

      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException

      [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException

       

      Can anyone please let me know the steps that re needed to be followed in order for a successfull JBoss build?

       

      Thanks

      Rakesh.