0 Replies Latest reply on Feb 28, 2014 8:51 AM by pegazus

    JBoss 6.1.0 ClassLoad informations: MissUnDerstanding.

    pegazus Newbie

      Hi all,

       

      I am noob in classloader on jboss-6.1.0.Final.

      I am working in an application which use different type of external interfaces by webServices.

      My app listen on weblogic queues, the app use an welfullclient.jar which is placed in rar module on the folder deployment.

      The app is in my /deploy/folder_app/my.ear and use httpsClient to contact other internal WebServices.

      The problem is I want to use cxf native version of jboss <version>2.3.1-PATCH-01<version> present in /opt/jboss6/jboss-6.1.0.Final/common/lib

      but when I call my external partner by webservice I use     weblogic.net .. from  weblogicfullclient.jar ( I have notice that by the stack trace error below).

       

      Here a scheme of the app:

      --/opt/jboss6/jboss-6.1.0.Final/server/default/deploy

                   --folder-app

                            -- Data_sources.

                            --app  (which is the ear).

                   --folder_rar

                            -- wlfullclient.jar     (which include weblogic.net).

                            -- /META-INF/ra.xml .

       

      I have notice the problem because of this errors:

              at java.io.BufferedInputStream.read(BufferedInputStream.java:317) [:1.6.0_25]

              at weblogic.net.http.MessageHeader.isHTTP(MessageHeader.java:224) [:10.3.5.0]

              at weblogic.net.http.MessageHeader.parseHeader(MessageHeader.java:148) [:10.3.5.0]

              at weblogic.net.http.HttpClient.parseHTTP(HttpClient.java:468) [:10.3.5.0]

              at weblogic.net.http.HttpURLConnection.getInputStream(HttpURLConnection.java:377) [:10.3.5.0]

              at weblogic.net.http.SOAPHttpsURLConnection.getInputStream(SOAPHttpsURLConnection.java:37) [:10.3.5.0]

              at weblogic.net.http.HttpURLConnection.getResponseCode(HttpURLConnection.java:965) [:10.3.5.0]

       

      In an other jboss i have reproduce the same error without  the folder_rar:

              at java.io.BufferedInputStream.read(Unknown Source) ~[na:1.6.0_22]

              at sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source) ~[na:1.6.0_22]

              at sun.net.www.http.HttpClient.parseHTTP(Unknown Source) ~[na:1.6.0_22]

              at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) ~[na:1.6.0_22]

              at java.net.HttpURLConnection.getResponseCode(Unknown Source) ~[na:1.6.0_22]

              at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(Unknown Source) ~[na:1.6]

              at org.apache.cxf.transport.http.URLConnectionHTTPConduit$URLConnectionWrappedOutputStream.getResponseCode(URLConnectionHTTPConduit.java:260) ~[cxf-rt-transports-http-2.7.5.jar:2.7.5]

       

      So i have noticed that when jboss load my rar it overload the package sun.net.www.protocol.

       

      - I have tried to move the weblogicfullclient.jar in an folder_rar/lib but the jboss failed to load the ra .

      - I have tried to delete httpclient.class and httpsclient.class in the wlfullclient.jar. => jboss boot but when the app want to contact the external webservice the app didn't find the class  httpsclient.class .

       

      Thanks for reading my problem.