0 Replies Latest reply on Mar 7, 2014 4:46 AM by smog

    arquillian-persistence-api sql scripts

    smog Newbie

      Hi, i am using

      arquillian-persistence-api version:1.0.0.Alpha6

      wildfly 8.0.0 Final

       

      The problem is my sql scripts are not called. I tried it out with H2 and PostgreSql both not working ;/

      My scripts are located under src/test/resources/scripts (i tried other locations same result)

       

      This is my H2 jbossas-ds.xml

       

          <datasource enabled="true"

                      jndi-name="jdbc/arquillian"

                      pool-name="ArquillianEmbeddedH2Pool">

              <connection-url>jdbc:h2:mem:arquillian;DB_CLOSE_DELAY=-1;MODE=Oracle</connection-url>

              <driver>h2</driver>

          </datasource>

       

      Works fine, datasource is bound, everything is ok.

       

      My Test class:

       

      @RunWith(Arquillian.class)

      @CreateSchema({"scripts/create.sql"})

      public class ServiceTest {

      ...

       

      No exceptions, nothing, scripts are just not loaded. I tried to specify startup scripts in arquillian.xml, same result


          <extension qualifier="persistence-script">

              <property name="scriptsToExecuteBeforeTest">scripts/create.sql</property>

          </extension>

       

      This driving my crazy

       

      tnx in advance!

      Cheers!

       

       

      PS Problem is solved, wrong dependency instead of api i should include impl

       

              <dependency>

                  <groupId>org.jboss.arquillian.extension</groupId>

                  <artifactId>arquillian-persistence-impl</artifactId>

                  <version>1.0.0.Alpha6</version>

                  <scope>test</scope>

              </dependency>