0 Replies Latest reply on Mar 9, 2014 11:45 PM by manjunath Nakshathri

    JBoss Fuse and JBoss A-MQ : Messages are not getting consumed

    manjunath Nakshathri Newbie

      Hello,

       

      We are facing intermittent issue with the JBoss Fuse and JBoss A-MQ while consuming messages. The Consumer after consuming several messages, its getting stopped (or hanged). JMS Consumer running is inside the Fuse ESB 6.0.0 using the JBoss Active MQ (5.8.0.redhat-60024) org.apache.activemq.ActiveMQConnectionFactory and a Failover over transport url. In the fuse.log, there are no specific exception in this scenario to pin point the exact problem.

       

      Below are the configurations what we have as part of the bean definitons :

       

      <bean id="amqConnectionFactory" class="org.apache.activemq.ActiveMQConnectionFactory">

        <property name="brokerURL">

             <value>failover:(tcp://localhost:61616)</value>

      </property>

      <property name="userName" value="xxxx"/>

      <property name="password" value="xxxx"/>

        </bean>

       

      <bean id="jmsTransactionMgr"

        class="org.springframework.jms.connection.JmsTransactionManager">

        <property name="connectionFactory" ref="amqConnectionFactory" />

        </bean>

       

      <bean id="amqComponent" class="org.apache.activemq.camel.component.ActiveMQComponent">

        <property name="connectionFactory" ref="amqConnectionFactory" />

        <property name="transacted" value="true" />

        <property name="transactionManager" ref="jmsTransactionMgr" />

        <property name="acceptMessagesWhileStopping" value="false" />

        <property name="alwaysCopyMessage" value="true" />

        <property name="userName" value="xxxx"/>

        <property name="password" value="xxxx"/>

      </bean>

       

      Within the routes we have specified:

       

      <route id="send-notification-handler" autoStartup="{{send.notification.task.autostart}}">

        <description>Send Notification Handler</description>

        <from uri="amqComponent:queue:send-notification-queue"/>

        <bean ref="sendNotificationHandler" method="handle" />

        </route>

       

      Can you please help us in identifying the actual root cause for this? Your help will be highly appreciated.

       

      Regards,

      Manjunath