3 Replies Latest reply on Mar 14, 2014 2:18 PM by Troy Bronzan

    Pubishing to topic from client app: JBAS011806: Channel end notification received

    Troy Bronzan Newbie

      I seem to be having an issue with a remote connection to a JMS topic.  I have a client application which connects to a topic and attempts to publish a message, which results in the following errors:

       

      2014-03-14 12:57:15,602 INFO  [org.jboss.as.naming] (default task-10) JBAS011806: Channel end notification received, closing channel Channel ID 1ba4e44e (inbound) of Remoting connection 20ffc2cf to /127.0.0.1:60694
      2014-03-14 12:57:15,608 INFO  [org.jboss.as.naming] (default task-13) JBAS011806: Channel end notification received, closing channel Channel ID 2eb71bad (inbound) of Remoting connection 23a82780 to /127.0.0.1:60691
      2014-03-14 12:57:15,615 INFO  [org.jboss.as.naming] (default task-15) JBAS011806: Channel end notification received, closing channel Channel ID 057a2868 (inbound) of Remoting connection 642822b6 to null
      2014-03-14 12:57:15,620 INFO  [org.jboss.as.naming] (default task-3) JBAS011806: Channel end notification received, closing channel Channel ID 689d6039 (inbound) of Remoting connection 34fea07d to null
      2014-03-14 12:57:15,622 INFO  [org.jboss.as.naming] (default task-7) JBAS011806: Channel end notification received, closing channel Channel ID 02c8c7ba (inbound) of Remoting connection 6a5ada32 to /127.0.0.1:60693
      2014-03-14 12:57:15,625 INFO  [org.jboss.as.naming] (default task-9) JBAS011806: Channel end notification received, closing channel Channel ID 74af2e46 (inbound) of Remoting connection 5db09b90 to /127.0.0.1:60692
      2014-03-14 12:57:15,628 INFO  [org.jboss.as.naming] (default task-13) JBAS011806: Channel end notification received, closing channel Channel ID 019a59be (inbound) of Remoting connection 6fbb6071 to /127.0.0.1:60769
      
      

       

      The MDB which listens on the topic never receives the message published.  I can publish to the topic just fine from an EAR deployed on the application server.  I don't seem to be having a problem connecting to the topic, just publishing to it.

       

      Here is the code related to the connection.  A user called jmsuser was created using add-user.bat and was given the guest role.

       

      <jms-topic name="FooCacheChange">
           <entry name="java:jboss/jms/FooCacheChange"/>
           <entry name="java:jboss/exported/jms/FooCacheChange"/>
      </jms-topic>
      
      

       

      protected InitialContext getInitialContext() throws NamingException
      {
        Properties jndiProps = new Properties( );
        jndiProps.put(Context.INITIAL_CONTEXT_FACTORY, "org.jboss.naming.remote.client.InitialContextFactory");
        jndiProps.put(Context.PROVIDER_URL,"http-remoting://localhost:8080");
        return new InitialContext(jndiProps);
      }
      
      
      protected void initialize()
      {
        InitialContext context = getInitialContext();
        ConnectionFactory cf = (ConnectionFactory) context.lookup("jms/FooCacheChange");
        this.topic = (Topic) context.lookup(sDestination);
        this.connection = cf.createConnection("jmsuser", "password");
        this.session = this.connection.createSession(false, Session.AUTO_ACKNOWLEDGE);
        this.connection.start();
      }