1 Reply Latest reply on Mar 19, 2014 10:14 AM by Arnaud Bos

    Deployment issue with Jboss AS7( Child container with name  already exists)

    jitendra daswani Newbie

      Hi,

       

      I am getting following error while deploying the war file.

      I am using Jboss AS7

       

      2014-03-17 08:46:29,357 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC000001: Failed to start service jboss.web.deployment.default-host./: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./: Failed to start service

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc.jar:1.0.4.GA-redhat-1]

        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_25]

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_25]

        at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_25]

      Caused by: java.lang.IllegalArgumentException: JBWEB000250: Child container with name  already exists

        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:794)

        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:785)

        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:353)

        at org.jboss.as.web.deployment.WebContextInjector.inject(WebContextInjector.java:62)

        at org.jboss.as.web.deployment.WebContextInjector.inject(WebContextInjector.java:38)

        at org.jboss.msc.inject.CastingInjector.inject(CastingInjector.java:55) [jboss-msc.jar:1.0.4.GA-redhat-1]

        at org.jboss.msc.service.ServiceControllerImpl.doInject(ServiceControllerImpl.java:1549) [jboss-msc.jar:1.0.4.GA-redhat-1]

        at org.jboss.msc.service.ServiceControllerImpl.access$1900(ServiceControllerImpl.java:49) [jboss-msc.jar:1.0.4.GA-redhat-1]

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.performInjections(ServiceControllerImpl.java:1780) [jboss-msc.jar:1.0.4.GA-redhat-1]

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1741) [jboss-msc.jar:1.0.4.GA-redhat-1].

       

      I did some changes in standalone.xml file "enable-welcome-root="true" to " enable-welcome-root="false" without restarting the server.

       

      Attached server.log file also for details information.

       

      Can anybody help me to resolve this issue?

       

       

      Regards,

      Jitendra daswani

        • 1. Re: Deployment issue with Jboss AS7( Child container with name  already exists)
          Arnaud Bos Newbie

          I'm new to JBoss but it looks like you've overriden the default settings with a WEB-INF/jboss-web.xml in your WAR file.

           

          I personally followed this post a few hours ago and I've had the exact same error message with:

          <?xml version="1.0" encoding="UTF-8"?>

          <jboss-web>

              <context-root>/</context-root>

          </jboss-web>

           

          and

           

          <?xml version="1.0" encoding="UTF-8"?>

          <jboss-web>

              <context-root></context-root>

          </jboss-web>

           

          Depending on your need, just don't override this setting to have the default behavior or use <context-root>myapp</context-root>

           

          Hope this helps.