10 Replies Latest reply on May 14, 2014 1:54 AM by veenaonnet

    Different HornetQ Timeout messages seen in logs for jboss7.2.0, HornetQ2.4 in HA, collocated in-vm topology

    veenaonnet Newbie

      Hi,

       

      We are using Jboss7.2 with HornetQ2.4. Topology is collocated HA using in-vm connection factory.

      We have not set connection-ttl and client-failure-check-period. So it is using the default values.

       

      Not often, but when system has huge load, we have seen below messages sometimes. We have connectionfactory pooled. For sending messages, we are creating a new connection every time and closing that in a finally block.

      Is it sufficient to close connection? Do not see any leak here.

       

      WARN  [org.hornetq.core.client] (hornetq-failure-check-thread) HQ212037: Connection failure has been detected: HQ119014: Did not receive data from invm:0. It is likely the client has exited or crashed without closing its connection, or the network between the server and client has failed. You also might have configured connection-ttl and client-failure-check-period incorrectly. Please check user manual for more information. The connection will now be closed. [code=CONNECTION_TIMEDOUT]

       

      HQ119014: Timed out waiting for response when sending packet"

       

      HQ224062: Queue jms.queue.FileChangeNotificationJobs was busy for more than 1,000 milliseconds. There are possibly consumers hanging on a network operation

       

      If my understanding is correct, these issues should not come with in-vm connection factory.

      Is it ok to set connection-ttl to -1 for in-vm connection factory? Please guide.

       

      What can be done to fix these issues?

       

      Regards,

      Veena

        • 2. Re: Different HornetQ Timeout messages seen in logs for jboss7.2.0, HornetQ2.4 in HA, collocated in-vm topology
          Justin Bertram Master

          It is OK to set the connection-ttl to -1 for in-vm connections.  That is actually now the default for in-vm connections.

          • 3. Re: Different HornetQ Timeout messages seen in logs for jboss7.2.0, HornetQ2.4 in HA, collocated in-vm topology
            veenaonnet Newbie

            Hi Justin,

             

            Under heavy load, I still see exceptions for in-vm connection.

            I have set connection-ttl to -1. My setup is - Clustered, HA collocated topology using in-vm connection factory.

            Errors I am getting:

            Node 1:

            Queue jms.queue.xxx was busy for more than 1,000 milliseconds. There are possibly consumers hanging on a network operation

             

            Node 2:

            2014-04-30 07:20:16,625 WARN  [org.hornetq.core.client] (hornetq-failure-check-thread) HQ212037: Connection failure has been detected: HQ119014: Did not receive data from invm:0. It is likely the client has exited or crashed without closing its connection, or the network between the server and client has failed. You also might have configured

             

            connection-ttl and client-failure-check-period incorrectly. Please check user manual for more information. The connection will now be closed. [code=CONNECTION_TIMEDOUT]

            2014-04-30 07:20:16,639 WARN  [org.hornetq.core.server] (hornetq-failure-check-thread) HQ222061: Client connection failed, clearing up resources for session bce54f18-d037-11e3-a29e-4d0f2934304d

             

            Configurations are as below:

            Node 1:

            <?xml version="1.0" encoding="UTF-8" standalone="no"?><server xmlns="urn:jboss:domain:1.4">
            <profile>
              <subsystem xmlns="urn:jboss:domain:messaging:1.3">
               <hornetq-server>
                <clustered>true</clustered>
                <persistence-enabled>true</persistence-enabled>
                <security-enabled>true</security-enabled>
                <cluster-user>xyz</cluster-user>
                <cluster-password>xyz</cluster-password>
                <failover-on-shutdown>true</failover-on-shutdown>
                <shared-store>false</shared-store>
                <journal-type>ASYNCIO</journal-type>
                <journal-file-size>10485760</journal-file-size>
                <journal-min-files>2</journal-min-files>
                <check-for-live-server>true</check-for-live-server>
                <backup-group-name>x.x.x.1</backup-group-name>
                <paging-directory path="x.x.x.1/paging"/>
                <bindings-directory path="x.x.x.1/bindings"/>
                <journal-directory path="x.x.x.1/journal"/>
                <large-messages-directory path="x.x.x.1/large-messages"/>
                <max-saved-replicated-journals-size>40
                </max-saved-replicated-journals-size>
                <connectors>
                 <connector name="netty">
                  <factory-class>org.hornetq.core.remoting.impl.netty.NettyConnectorFactory
                  </factory-class>
                  <param key="host" value="x.x.x.1"/>
                  <param key="port" value="5445"/>
                 </connector>
                 <netty-connector name="netty-throughput" socket-binding="messaging-throughput">
                  <param key="batch-delay" value="50"/>
                 </netty-connector>
                 <in-vm-connector name="in-vm" server-id="0"/>
                </connectors>

                <acceptors>
                 <acceptor name="netty">
                                    <factory-class>org.hornetq.core.remoting.impl.netty.NettyAcceptorFactory</factory-class>
                                    <param key="host" value="0.0.0.0"/>
                                    <param key="port" value="5445"/>
                                </acceptor>
                 <netty-acceptor name="netty-throughput" socket-binding="messaging-throughput">
                  <param key="batch-delay" value="50"/>
                  <param key="direct-deliver" value="false"/>
                 </netty-acceptor>
                 <in-vm-acceptor name="in-vm" server-id="0"/>
                </acceptors>

                <broadcast-groups>
                 <broadcast-group name="bg-group">
                  <group-address>228.x.x.99</group-address>
                  <group-port>9876</group-port>
                  <broadcast-period>5000</broadcast-period>
                  <connector-ref>netty</connector-ref>
                 </broadcast-group>
                </broadcast-groups>
                <discovery-groups>
                 <discovery-group name="dg-group">
                  <group-address>228.x.x.99</group-address>
                  <group-port>9876</group-port>
                  <refresh-timeout>10000</refresh-timeout>
                 </discovery-group>
                </discovery-groups>
                <cluster-connections>
                 <cluster-connection name="msf-cluster-x.x.x.99">
                  <address>jms</address>
                  <connector-ref>netty</connector-ref>
                  <discovery-group-ref discovery-group-name="dg-group"/>
                  <retry-interval>1000</retry-interval>
                  <use-duplicate-detection>true</use-duplicate-detection>
                  <forward-when-no-consumers>false</forward-when-no-consumers>
                  <max-hops>1</max-hops>
                 </cluster-connection>
                </cluster-connections>
                <security-settings>
                 <security-setting match="#">
                  <permission roles="guest" type="send"/>
                  <permission roles="guest" type="consume"/>
                  <permission roles="guest" type="createDurableQueue"/>
                  <permission roles="guest" type="deleteDurableQueue"/>
                  <permission roles="guest" type="createNonDurableQueue"/>
                  <permission roles="guest" type="deleteNonDurableQueue"/>
                  <permission roles="guest" type="manage"/>
                 </security-setting>
                </security-settings>
                <address-settings>
                
                 <address-setting match="#">
                  <dead-letter-address>jms.queue.DLQ</dead-letter-address>
                  <expiry-address>jms.queue.ExpiryQueue</expiry-address>
                  <redelivery-delay>0</redelivery-delay>
                  <redistribution-delay>0</redistribution-delay>
                  <page-size-bytes>10485760</page-size-bytes>
                  <max-size-bytes>104857600</max-size-bytes>
                  <address-full-policy>PAGE</address-full-policy>
                  <message-counter-history-day-limit>1
                  </message-counter-history-day-limit>
                 </address-setting>
                </address-settings>
                <jms-connection-factories>
                 <connection-factory name="InVmConnectionFactory">
                  <connectors>
                   <connector-ref connector-name="in-vm"/>
                  </connectors>
                  <entries>
                   <entry name="java:/ConnectionFactory"/>
                  </entries>
                  <ha>true</ha>
                           <block-on-acknowledge>true</block-on-acknowledge>
                                    <retry-interval>1000</retry-interval>
                           <retry-interval-multiplier>1.0</retry-interval-multiplier>
                                    <reconnect-attempts>3</reconnect-attempts>
                  <client-failure-check-period>-1</client-failure-check-period>
                                    <connection-ttl>-1</connection-ttl>
                                    <confirmation-window-size>1000000</confirmation-window-size>
                  <call-timeout>180000</call-timeout>
                 </connection-factory>
                 <connection-factory name="RemoteConnectionFactory">
                  <connectors>
                   <connector-ref connector-name="netty"/>
                  </connectors>
                  <entries>
                   <entry name="java:jboss/exported/jms/RemoteConnectionFactory"/>
                  </entries>
                  <ha>true</ha>
                  <block-on-acknowledge>true</block-on-acknowledge>
                  <retry-interval>1000</retry-interval>
                  <retry-interval-multiplier>1.0</retry-interval-multiplier>
                  <reconnect-attempts>3</reconnect-attempts>
                  <client-failure-check-period>60000</client-failure-check-period>
                                    <connection-ttl>600000</connection-ttl>
                  <confirmation-window-size>1000000</confirmation-window-size>
                  <call-timeout>180000</call-timeout>
                 </connection-factory>
                 <pooled-connection-factory name="hornetq-ra">
                  <transaction mode="xa"/>
                  <connectors>
                   <connector-ref connector-name="in-vm"/>
                  </connectors>
                  <entries>
                   <entry name="java:/JmsXA"/>
                  </entries>
                 </pooled-connection-factory>
                </jms-connection-factories>
                <jms-destinations>
                 <jms-queue name="Jobs">
                  <entry name="queue/Jobs"/>
                  <durable>true</durable>
                 </jms-queue>
                 <jms-topic name="Notification">
                  <entry name="topic/Notification"/>
                 </jms-topic>
                </jms-destinations>
               </hornetq-server>
               <hornetq-server name="backup">
                <clustered>true</clustered>
                <backup>true</backup>
                <persistence-enabled>true</persistence-enabled>
                <security-enabled>true</security-enabled>
                <cluster-user>xyz</cluster-user>
                <cluster-password>xyz</cluster-password>
                <allow-failback>true</allow-failback>
                <failover-on-shutdown>true</failover-on-shutdown>
                <shared-store>false</shared-store>
                <journal-type>ASYNCIO</journal-type>
                <journal-file-size>102400</journal-file-size>
                <journal-min-files>2</journal-min-files>
                <check-for-live-server>true</check-for-live-server>
                <backup-group-name>x.x.x.2
                </backup-group-name>
                <paging-directory path="x.x.x.2/paging"/>
                <bindings-directory path="x.x.x.2/bindings"/>
                <journal-directory path="x.x.x.2/journal"/>
                <large-messages-directory path="x.x.x.2/large-messages"/>
                <max-saved-replicated-journals-size>40
                </max-saved-replicated-journals-size>
                <live-connector-ref>netty</live-connector-ref>
                <connectors>
                 <connector name="netty-backup">
                  <factory-class>org.hornetq.core.remoting.impl.netty.NettyConnectorFactory
                  </factory-class>
                  <param key="host" value="x.x.x.1"/>
                  <param key="port" value="5446"/>
                 </connector>
                 <in-vm-connector name="in-vm" server-id="1"/>
                </connectors>

                <acceptors>
                 <in-vm-acceptor name="in-vm" server-id="1"/>
                                <acceptor name="netty-backup">
                                    <factory-class>org.hornetq.core.remoting.impl.netty.NettyAcceptorFactory</factory-class>
                                    <param key="host" value="0.0.0.0"/>
                                    <param key="port" value="5446"/>
                                </acceptor>
                </acceptors>

                <broadcast-groups>
                 <broadcast-group name="bg-group-backup">
                  <group-address>228.x.x.99</group-address>
                  <group-port>9876</group-port>
                  <broadcast-period>5000</broadcast-period>
                  <connector-ref>netty-backup</connector-ref>
                 </broadcast-group>
                </broadcast-groups>
                <discovery-groups>
                 <discovery-group name="dg-group-backup">
                  <group-address>228.x.x.99</group-address>
                  <group-port>9876</group-port>
                  <refresh-timeout>10000</refresh-timeout>
                 </discovery-group>
                </discovery-groups>
                <cluster-connections>
                 <cluster-connection name="msf-cluster-x.x.x.99">
                  <address>jms</address>
                  <connector-ref>netty-backup</connector-ref>
                  <discovery-group-ref discovery-group-name="dg-group-backup"/>
                  <retry-interval>1000</retry-interval>
                  <use-duplicate-detection>true</use-duplicate-detection>
                  <forward-when-no-consumers>false</forward-when-no-consumers>
                  <max-hops>1</max-hops>
                 </cluster-connection>
                </cluster-connections>
                <security-settings>
                 <security-setting match="#">
                  <permission roles="guest" type="send"/>
                  <permission roles="guest" type="consume"/>
                  <permission roles="guest" type="createDurableQueue"/>
                  <permission roles="guest" type="deleteDurableQueue"/>
                  <permission roles="guest" type="createNonDurableQueue"/>
                  <permission roles="guest" type="deleteNonDurableQueue"/>
                  <permission roles="guest" type="manage"/>
                 </security-setting>
                </security-settings>
                <address-settings>
                 <address-setting match="#">
                  <dead-letter-address>jms.queue.DLQ</dead-letter-address>
                  <expiry-address>jms.queue.ExpiryQueue</expiry-address>
                  <redelivery-delay>0</redelivery-delay>
                  <redistribution-delay>0</redistribution-delay>
                  <page-size-bytes>10485760</page-size-bytes>
                  <max-size-bytes>104857600</max-size-bytes>
                  <address-full-policy>PAGE</address-full-policy>
                  <message-counter-history-day-limit>1
                  </message-counter-history-day-limit>
                 </address-setting>
                </address-settings>
               </hornetq-server>
              </subsystem>
            </profile>
            <socket-binding-group default-interface="public" name="standard-sockets" port-offset="${jboss.socket.binding.port-offset:0}">
              <socket-binding interface="management" name="management-native" port="${jboss.management.native.port:9999}"/>
              <socket-binding interface="management" name="management-http" port="${jboss.management.http.port:9990}"/>
              <socket-binding interface="management" name="management-https" port="${jboss.management.https.port:9443}"/>
              <socket-binding name="ajp" port="8009"/>
              <socket-binding name="http" port="80"/>
              <socket-binding name="https" port="443"/>
              <socket-binding interface="unsecure" name="jacorb" port="3528"/>
              <socket-binding interface="unsecure" name="jacorb-ssl" port="3529"/>
              <socket-binding multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45700" name="jgroups-mping" port="0"/>
              <socket-binding name="jgroups-tcp" port="7600"/>
              <socket-binding name="jgroups-tcp-fd" port="57600"/>
              <socket-binding multicast-address="228.x.x.99" multicast-port="45688" name="jgroups-udp" port="55200"/>
              <socket-binding name="jgroups-udp-fd" port="54200"/>
              <socket-binding name="messaging" port="5445"/>
              <socket-binding name="messaging-throughput" port="5455"/>
              <socket-binding multicast-address="228.x.x.99" multicast-port="23364" name="modcluster" port="0"/>
              <socket-binding interface="management" name="osgi-http" port="8090"/>
              <socket-binding name="remoting" port="4447"/>
              <socket-binding name="txn-recovery-environment" port="4712"/>
              <socket-binding name="txn-status-manager" port="4713"/>
              <socket-binding name="messaging-backup" port="5446"/>
              <outbound-socket-binding name="mail-smtp">
               <remote-destination host="localhost" port="25"/>
              </outbound-socket-binding>
            </socket-binding-group>
            </server>

             

            Node2:

            <?xml version="1.0" encoding="UTF-8" standalone="no"?><server xmlns="urn:jboss:domain:1.4">
            <profile>
              <subsystem xmlns="urn:jboss:domain:messaging:1.3">
               <hornetq-server>
                <clustered>true</clustered>
                <persistence-enabled>true</persistence-enabled>
                <security-enabled>true</security-enabled>
                <cluster-user>xyz</cluster-user>
                <cluster-password>xyz</cluster-password>
                <failover-on-shutdown>true</failover-on-shutdown>
                <shared-store>false</shared-store>
                <journal-type>ASYNCIO</journal-type>
                <journal-file-size>10485760</journal-file-size>
                <journal-min-files>2</journal-min-files>
                <check-for-live-server>true</check-for-live-server>
                <backup-group-name>x.x.x.2</backup-group-name>
                <paging-directory path="x.x.x.2/paging"/>
                <bindings-directory path="x.x.x.2/bindings"/>
                <journal-directory path="x.x.x.2/journal"/>
                <large-messages-directory path="x.x.x.2/large-messages"/>
                <max-saved-replicated-journals-size>40
                </max-saved-replicated-journals-size>
                <connectors>
                 <connector name="netty">
                  <factory-class>org.hornetq.core.remoting.impl.netty.NettyConnectorFactory
                  </factory-class>
                  <param key="host" value="x.x.x.2"/>
                  <param key="port" value="5445"/>
                 </connector>
                 <netty-connector name="netty-throughput" socket-binding="messaging-throughput">
                  <param key="batch-delay" value="50"/>
                 </netty-connector>
                 <in-vm-connector name="in-vm" server-id="0"/>
                </connectors>

                <acceptors>
                 <acceptor name="netty">
                                    <factory-class>org.hornetq.core.remoting.impl.netty.NettyAcceptorFactory</factory-class>
                                    <param key="host" value="0.0.0.0"/>
                                    <param key="port" value="5445"/>
                                </acceptor>
                 <netty-acceptor name="netty-throughput" socket-binding="messaging-throughput">
                  <param key="batch-delay" value="50"/>
                  <param key="direct-deliver" value="false"/>
                 </netty-acceptor>
                 <in-vm-acceptor name="in-vm" server-id="0"/>
                </acceptors>

                <broadcast-groups>
                 <broadcast-group name="bg-group">
                  <group-address>228.x.x.99</group-address>
                  <group-port>9876</group-port>
                  <broadcast-period>5000</broadcast-period>
                  <connector-ref>netty</connector-ref>
                 </broadcast-group>
                </broadcast-groups>
                <discovery-groups>
                 <discovery-group name="dg-group">
                  <group-address>228.x.x.99</group-address>
                  <group-port>9876</group-port>
                  <refresh-timeout>10000</refresh-timeout>
                 </discovery-group>
                </discovery-groups>
                <cluster-connections>
                 <cluster-connection name="msf-cluster-x.x.x.99">
                  <address>jms</address>
                  <connector-ref>netty</connector-ref>
                  <discovery-group-ref discovery-group-name="dg-group"/>
                  <retry-interval>1000</retry-interval>
                  <use-duplicate-detection>true</use-duplicate-detection>
                  <forward-when-no-consumers>false</forward-when-no-consumers>
                  <max-hops>1</max-hops>
                 </cluster-connection>
                </cluster-connections>
                <security-settings>
                 <security-setting match="#">
                  <permission roles="guest" type="send"/>
                  <permission roles="guest" type="consume"/>
                  <permission roles="guest" type="createDurableQueue"/>
                  <permission roles="guest" type="deleteDurableQueue"/>
                  <permission roles="guest" type="createNonDurableQueue"/>
                  <permission roles="guest" type="deleteNonDurableQueue"/>
                  <permission roles="guest" type="manage"/>
                 </security-setting>
                </security-settings>
                <address-settings>
                
                 <address-setting match="#">
                  <dead-letter-address>jms.queue.DLQ</dead-letter-address>
                  <expiry-address>jms.queue.ExpiryQueue</expiry-address>
                  <redelivery-delay>0</redelivery-delay>
                  <redistribution-delay>0</redistribution-delay>
                  <page-size-bytes>10485760</page-size-bytes>
                  <max-size-bytes>104857600</max-size-bytes>
                  <address-full-policy>PAGE</address-full-policy>
                  <message-counter-history-day-limit>1
                  </message-counter-history-day-limit>
                 </address-setting>
                </address-settings>
                <jms-connection-factories>
                 <connection-factory name="InVmConnectionFactory">
                  <connectors>
                   <connector-ref connector-name="in-vm"/>
                  </connectors>
                  <entries>
                   <entry name="java:/ConnectionFactory"/>
                  </entries>
                  <ha>true</ha>
                           <block-on-acknowledge>true</block-on-acknowledge>
                                    <retry-interval>1000</retry-interval>
                           <retry-interval-multiplier>1.0</retry-interval-multiplier>
                                    <reconnect-attempts>3</reconnect-attempts>
                  <client-failure-check-period>-1</client-failure-check-period>
                                    <connection-ttl>-1</connection-ttl>
                                    <confirmation-window-size>1000000</confirmation-window-size>
                  <call-timeout>180000</call-timeout>
                 </connection-factory>
                 <connection-factory name="RemoteConnectionFactory">
                  <connectors>
                   <connector-ref connector-name="netty"/>
                  </connectors>
                  <entries>
                   <entry name="java:jboss/exported/jms/RemoteConnectionFactory"/>
                  </entries>
                  <ha>true</ha>
                  <block-on-acknowledge>true</block-on-acknowledge>
                  <retry-interval>1000</retry-interval>
                  <retry-interval-multiplier>1.0</retry-interval-multiplier>
                  <reconnect-attempts>3</reconnect-attempts>
                  <client-failure-check-period>60000</client-failure-check-period>
                                    <connection-ttl>600000</connection-ttl>
                  <confirmation-window-size>1000000</confirmation-window-size>
                  <call-timeout>180000</call-timeout>
                 </connection-factory>
                 <pooled-connection-factory name="hornetq-ra">
                  <transaction mode="xa"/>
                  <connectors>
                   <connector-ref connector-name="in-vm"/>
                  </connectors>
                  <entries>
                   <entry name="java:/JmsXA"/>
                  </entries>
                 </pooled-connection-factory>
                </jms-connection-factories>
                <jms-destinations>
                 <jms-queue name="Jobs">
                  <entry name="queue/ProxyJobs"/>
                  <durable>true</durable>
                 </jms-queue>
                 <jms-topic name="Notification">
                  <entry name="topic/Notification"/>
                 </jms-topic>
                </jms-destinations>
               </hornetq-server>
               <hornetq-server name="backup">
                <clustered>true</clustered>
                <backup>true</backup>
                <persistence-enabled>true</persistence-enabled>
                <security-enabled>true</security-enabled>
                <cluster-user>xyz</cluster-user>
                <cluster-password>xyz</cluster-password>
                <allow-failback>true</allow-failback>
                <failover-on-shutdown>true</failover-on-shutdown>
                <shared-store>false</shared-store>
                <journal-type>ASYNCIO</journal-type>
                <journal-file-size>102400</journal-file-size>
                <journal-min-files>2</journal-min-files>
                <check-for-live-server>true</check-for-live-server>
                <backup-group-name>x.x.x.1
                </backup-group-name>
                <paging-directory path="x.x.x.1/paging"/>
                <bindings-directory path="x.x.x.1/bindings"/>
                <journal-directory path="x.x.x.1/journal"/>
                <large-messages-directory path="x.x.x.1/large-messages"/>
                <max-saved-replicated-journals-size>40
                </max-saved-replicated-journals-size>
                <live-connector-ref>netty</live-connector-ref>
                <connectors>
                 <connector name="netty-backup">
                  <factory-class>org.hornetq.core.remoting.impl.netty.NettyConnectorFactory
                  </factory-class>
                  <param key="host" value="x.x.x.2"/>
                  <param key="port" value="5446"/>
                 </connector>
                 <in-vm-connector name="in-vm" server-id="1"/>
                </connectors>

                <acceptors>
                 <in-vm-acceptor name="in-vm" server-id="1"/>
                                <acceptor name="netty-backup">
                                    <factory-class>org.hornetq.core.remoting.impl.netty.NettyAcceptorFactory</factory-class>
                                    <param key="host" value="0.0.0.0"/>
                                    <param key="port" value="5446"/>
                                </acceptor>
                </acceptors>

                <broadcast-groups>
                 <broadcast-group name="bg-group-backup">
                  <group-address>228.x.x.99</group-address>
                  <group-port>9876</group-port>
                  <broadcast-period>5000</broadcast-period>
                  <connector-ref>netty-backup</connector-ref>
                 </broadcast-group>
                </broadcast-groups>
                <discovery-groups>
                 <discovery-group name="dg-group-backup">
                  <group-address>228.x.x.99</group-address>
                  <group-port>9876</group-port>
                  <refresh-timeout>10000</refresh-timeout>
                 </discovery-group>
                </discovery-groups>
                <cluster-connections>
                 <cluster-connection name="msf-cluster-x.x.x.99">
                  <address>jms</address>
                  <connector-ref>netty-backup</connector-ref>
                  <discovery-group-ref discovery-group-name="dg-group-backup"/>
                  <retry-interval>1000</retry-interval>
                  <use-duplicate-detection>true</use-duplicate-detection>
                  <forward-when-no-consumers>false</forward-when-no-consumers>
                  <max-hops>1</max-hops>
                 </cluster-connection>
                </cluster-connections>
                <security-settings>
                 <security-setting match="#">
                  <permission roles="guest" type="send"/>
                  <permission roles="guest" type="consume"/>
                  <permission roles="guest" type="createDurableQueue"/>
                  <permission roles="guest" type="deleteDurableQueue"/>
                  <permission roles="guest" type="createNonDurableQueue"/>
                  <permission roles="guest" type="deleteNonDurableQueue"/>
                  <permission roles="guest" type="manage"/>
                 </security-setting>
                </security-settings>
                <address-settings>
                 <address-setting match="#">
                  <dead-letter-address>jms.queue.DLQ</dead-letter-address>
                  <expiry-address>jms.queue.ExpiryQueue</expiry-address>
                  <redelivery-delay>0</redelivery-delay>
                  <redistribution-delay>0</redistribution-delay>
                  <page-size-bytes>10485760</page-size-bytes>
                  <max-size-bytes>104857600</max-size-bytes>
                  <address-full-policy>PAGE</address-full-policy>
                  <message-counter-history-day-limit>1
                  </message-counter-history-day-limit>
                 </address-setting>
                </address-settings>
               </hornetq-server>
              </subsystem>
            </profile>
            <socket-binding-group default-interface="public" name="standard-sockets" port-offset="${jboss.socket.binding.port-offset:0}">
              <socket-binding interface="management" name="management-native" port="${jboss.management.native.port:9999}"/>
              <socket-binding interface="management" name="management-http" port="${jboss.management.http.port:9990}"/>
              <socket-binding interface="management" name="management-https" port="${jboss.management.https.port:9443}"/>
              <socket-binding name="ajp" port="8009"/>
              <socket-binding name="http" port="80"/>
              <socket-binding name="https" port="443"/>
              <socket-binding interface="unsecure" name="jacorb" port="3528"/>
              <socket-binding interface="unsecure" name="jacorb-ssl" port="3529"/>
              <socket-binding multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45700" name="jgroups-mping" port="0"/>
              <socket-binding name="jgroups-tcp" port="7600"/>
              <socket-binding name="jgroups-tcp-fd" port="57600"/>
              <socket-binding multicast-address="228.x.x.99" multicast-port="45688" name="jgroups-udp" port="55200"/>
              <socket-binding name="jgroups-udp-fd" port="54200"/>
              <socket-binding name="messaging" port="5445"/>
              <socket-binding name="messaging-throughput" port="5455"/>
              <socket-binding multicast-address="228.x.x.99" multicast-port="23364" name="modcluster" port="0"/>
              <socket-binding interface="management" name="osgi-http" port="8090"/>
              <socket-binding name="remoting" port="4447"/>
              <socket-binding name="txn-recovery-environment" port="4712"/>
              <socket-binding name="txn-status-manager" port="4713"/>
              <socket-binding name="messaging-backup" port="5446"/>
              <outbound-socket-binding name="mail-smtp">
               <remote-destination host="localhost" port="25"/>
              </outbound-socket-binding>
            </socket-binding-group>
            </server>

             

            Is there anything wrong in the configuration?

            If connection-ttl is -1 how come these CONNECTION_TIMEOUT errors are coming? In my code, I am not using the entry for pooled connection. To send and receive messages I am using ConnectionFactory, still is there a chance of it using pooled connection factory?

            Can connection-ttl be specified for pooled connection factory?

             

            Regards,

            Veena

            • 4. Re: Different HornetQ Timeout messages seen in logs for jboss7.2.0, HornetQ2.4 in HA, collocated in-vm topology
              Justin Bertram Master

              Is there anything wrong in the configuration?

              Yes, I believe so.

               

              If connection-ttl is -1 how come these CONNECTION_TIMEOUT errors are coming?

              I believe this is because you also set client-failure-check-period to -1.  In my previous comment I asked you to set connection-ttl to -1, but I didn't mention client-failure-check-period so I'm not sure why you change it.  By setting client-failure-check-period to -1 that means the client will never send a ping which means the connection-ttl will never actually get set to -1 since the connection-ttl is set to -1 by the first ping from the client.  As I indicated previously, this has been changed in later versions.  In any event, please unset client-failure-check-period in your configuration.

               

              In my code, I am not using the entry for pooled connection. To send and receive messages I am using ConnectionFactory, still is there a chance of it using pooled connection factory?

              If you are using ConnectionFactory then it shouldn't be using the pooled-connection-factory.  However, if you are sending messages within the container then you should be using a pooled-connection-factory for best performance and code simplicity.

               

              Can connection-ttl be specified for pooled connection factory?

              Yes, of course.

               

               

              BTW, the next time you paste a big chunk of XML please ensure it is formatted well so it's easier to read.

              1 of 1 people found this helpful
              • 5. Re: Different HornetQ Timeout messages seen in logs for jboss7.2.0, HornetQ2.4 in HA, collocated in-vm topology
                veenaonnet Newbie

                Thanks Justin.

                Yes, initially I set only client-failure-check-period to -1. However I faced these timeout errors. Hence I also set client-failure-check-period.

                But as you have mentioned, I will unset this parameter and try the tests again.

                 

                I will well format xml next time

                 

                Regards,

                Veena

                • 6. Re: Different HornetQ Timeout messages seen in logs for jboss7.2.0, HornetQ2.4 in HA, collocated in-vm topology
                  veenaonnet Newbie

                  Hi Justin,

                   

                  I tested with the settings

                  client-failure-check-period = -1 and client-failure-check-period=60000

                  However after removing -1 value for client-failure-check-period I started getting errors "Error while sending packet 71".

                  Last time also, I was getting the same errors and adding client-failure-check-period=-1 resolved the issue.

                   

                  Any suggestions? I cannot move to the latest version as of now.

                   

                  Regards,

                  Veena

                  • 7. Re: Different HornetQ Timeout messages seen in logs for jboss7.2.0, HornetQ2.4 in HA, collocated in-vm topology
                    Justin Bertram Master

                    You are getting "Error while sending packet 71" when the client and the server are in the same JVM?

                    • 8. Re: Different HornetQ Timeout messages seen in logs for jboss7.2.0, HornetQ2.4 in HA, collocated in-vm topology
                      veenaonnet Newbie

                      Hi Justin,

                       

                      I am using HA/clustered setup with collocated topology.

                      In this setup if client-failure-check-period is set up to any value other than -1 then I am getting error  "Error while sending packet 71"

                       

                      2014-04-01 02:57:34,889 10.4.167.27 (synchronizeFolderJobsWorker-p72-101) ERROR [com.omneon.common.msg.MessageFactory] {MsfMessaging} Unable to send message (HQ119014: Timed out waiting for response when sending packet 71)

                      javax.jms.JMSException: HQ119014: Timed out waiting for response when sending packet 71

                        at org.hornetq.core.protocol.core.impl.ChannelImpl.sendBlocking(ChannelImpl.java:379)

                        at org.hornetq.core.client.impl.ClientProducerImpl.sendRegularMessage(ClientProducerImpl.java:333)

                        at org.hornetq.core.client.impl.ClientProducerImpl.doSend(ClientProducerImpl.java:303)

                        at org.hornetq.core.client.impl.ClientProducerImpl.send(ClientProducerImpl.java:135)

                        at org.hornetq.jms.client.HornetQMessageProducer.doSendx(HornetQMessageProducer.java:506)

                        at org.hornetq.jms.client.HornetQMessageProducer.send(HornetQMessageProducer.java:196)

                      • 9. Re: Different HornetQ Timeout messages seen in logs for jboss7.2.0, HornetQ2.4 in HA, collocated in-vm topology
                        Justin Bertram Master

                        That error suggests to me that your network or server is simply too slow to respond in the allotted time.  You could try increasing the call-timeout, but it would probably be better to investigate the underlying cause of the delay.