0 Replies Latest reply on Apr 8, 2014 7:35 AM by Raghu Marimuthu

    Deployable DataSource Issue -JBoss EAP 6.0

    Raghu Marimuthu Newbie

      Hi,

       

      I am in the process of migrating from JBoss 4.3 to JBoss EAP 6.0(AS 7.1.2.Final-redhat-1) for deploying my myfaces war application.

       

      I modified the standalone.xml by including myojdbc14.jar file and added the module.xml in $JBOSS_HOME /modules/oracle/ folder and I was able to connect to the database without any issue.


      But I have issue when deploying the  datasource in deploy folder similar to jboss 4.3.by placing the jar file and myapp-ds.xml in $JBOSS_HOME/standalone/deployments/.


      In log I can see this xml file was deployed :

      19:15:34,202 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 28) JBAS018559: Deployed "myapp-ds.xml"

      19:15:34,203 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 28) JBAS018559: Deployed "ojdbc14.jar"

      myapp-ds.xml code:

       

      datasources xmlns="http://www.jboss.org/ironjacamar/schema"> 

      <datasource jndi-name="java:jboss/datasources/myDBSource" pool-name="myDBSource" enabled="true" use-java-context="true">

      <connection-url>jdbc:oracle:thin:@myDB</connection-url>

      <driver-class>oracle.jdbc.driver.OracleDriver</driver-class>

      <pool>

      <min-pool-size>1</min-pool-size>    

      <max-pool-size>100</max-pool-size> 

      </pool>

      <security>      

      <user-name>username</user-name>     

      <password>pwd</password>

      </security>

      </datasource>

      </datasources>

       

      I also tried by replacing the <driver-class> with <driver>ojdbc14.jar</driver> in the above xml code.

       

      19:52:51,644 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report

      JBAS014775:    New missing/unsatisfied dependencies:

            service jboss.jdbc-driver.ojdbc14_jar (missing) dependents: [service jboss.data-source.jboss/datasources/myDBSource]

       

       

      But it is not working and not connecting to the DB.Could anyone tell how to make the datasource as deployable and work as similar to JBoss 4.3.0.

       

      Thanks,

      Raghu