3 Replies Latest reply on Apr 7, 2014 9:22 AM by Jesper Skov

    EAP 6.2.2 invalid zip files - server runtime include pattern tweaks?

    Jesper Skov Newbie

      For reasons I will not attempt to understand, patching EAP6 leaves some jars as invalid Zip archives.

       

      I have just patched my container to EAP 6.2.2, and creating a JBossTools-based runtime based on this installation, makes Eclipse unhappy:

      ("Archive for required library '...jboss-el-api_2.2_spec-1.0.2.Final-redhat-1.jar' cannot be read or is not a valid ZIP file")

       

      What is the intended way to handle this with Eclipse/JBossTools?

      I guess I could alter the default classpath entries for the runtime, depending on the patch-level of the container.

       

      But I must admit I expect JBossTools to do that out of the box, without me having to figure out what jars was broken by the latest patch and tweaking the preferences.

       

       

      Any help or insight appreciated.

       

      Thanks,

      Jesper