6 Replies Latest reply on Apr 11, 2014 7:24 AM by Bill R

    min-large-message-size does not reflect number of message bytes

    Bill R Newbie

      We are using HornetQ 2.2.3 with JMS messages.   When we send JMS messages to HornetQ queues, sometimes we get large message files created which we dont want.   Our min-large-message-size is set at 10 Meg.   But messages of only about 5 meg are getting large message files created.

       

      Far as i can tell, this is because Hornetq stores messages with a 2 byte encoding.  The large message files are double the size of the original text message.

       

      Is there a way to control how HornetQ stores large messages, so that it uses 1 ascii byte instead of 2 bytes?

       

      Shouldnt the min-large-message-size parameter reflect the number of characters in the message?

       

      Does this sound like a bug?

       

      Thanks,

      Bill R