0 Replies Latest reply on Apr 11, 2014 2:40 AM by Amit S

    java.lang.ClassNotFoundException: org.omg.CORBA.ObjectHelper

    Amit S Newbie

      i am newbie to Wildly. I am using wildly as application for application. when I tried to access some functionality, I am getting "java.lang.ClassNotFoundException: org.omg.CORBA.ObjectHelper".

      I tried with Jboss-deployment-structure.xml to access class,  but still I am getting  same exception

       

      My Jboss-deployment-structure.xml

       

      <jboss-deployment-structure xmlns="urn:jboss:deployment-structure:1.1">

          <deployment>

              <dependencies>

                  <system export="true">

                      <paths>

                         <path name="org.omg.CORBA.ObjectHelper"/>

                      </paths>

                  </system>

              </dependencies>

          </deployment>

      </jboss-deployment-structure>

       

      Also I tried to set path in module.xml file, but still have same issue.

       

      <dependencies>

              <module name="org.jacorb" export="false">

                  <exports>

                      <include-set>

      <path name="org/omg/CORBA/ORBPackage"/>

        <path name="org/omg/CORBA/ObjectHelper"/>

         <path name="org/omg/CORBA/TypeCodePackage"/>

      </include-se

        </exports>

      </module>

       

      Is I miss something or any other alternative to resolve this issue.