0 Replies Latest reply on Apr 11, 2014 4:54 PM by Daniel Castro

    OPENJPA Not Loading - Problems deploying JUDDIv3 over JBoss As 7.1.1 Final + MySQL 5.5

    Daniel Castro Newbie

      Guys,

       

      I followed what was written in README.TXT file (attached).  The step I took inside README.TXT was:

       

      6. Target platform JBoss 7,8,EAP-6.x running OpenJPA and CXF

       

      Also, I created a DataSource named juddiv3 (jndi-name="java:jboss/datasources/juddiv3").  The standalone.xml attached shows my datasource configuration.

       

      But when I try to deploy the war file, also attached, I get the error shown inside the server.log also attached.

      The error can be seen by looking for the line below

       

      17:43:14,383 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-8) MSC00001: Failed to start service jboss.module.service."deployment.juddiv3.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.juddiv3.war".main: Failed to load module: deployment.juddiv3.war:main

       

      Inside this path

      C:\Java\jboss-as-7.1.1.Final\modules\system\layers\base\org\jboss\as\jpa\openjpa\main
      

       

      I have the file jboss-as-jpa-openjpa-7.1.1.Final.jar and the respective module.xml with the content below

       

      <?xml version="1.0" encoding="UTF-8"?>
      <!-- contains the JPA integration classes for OpenJPA 2.x --> 
      <module xmlns="urn:jboss:module:1.1" name="org.jboss.as.jpa.openjpa">
          <properties>
              <property name="jboss.api" value="private"/>
          </properties>
      
      
          <resources>
              <resource-root path="jboss-as-jpa-openjpa-7.1.1.Final.jar"/>
              <!-- Insert resources here -->
          </resources>
      
      
          <dependencies>
              <module name="javax.annotation.api"/>
              <module name="javax.persistence.api"/>
              <module name="javax.transaction.api"/>
      
      
              <module name="org.jboss.as.jpa.spi"/>
              <module name="org.jboss.logging"/>
              <module name="org.jboss.jandex"/>
      
      
              <module name="org.apache.openjpa" optional="true"/>
        <!-- org.apache.openjpa:main must be created manually with OpenJPA jars -->
          </dependencies>
      </module>
      

       

      Inside this path

      C:\Java\jboss-as-7.1.1.Final\modules\system\layers\base\org\apache\openjpa\main
      

      I have openjpa-2.2.1.jar, serp-1.13.1.jar and a module.xml with the content

       

      <?xml version="1.0" encoding="UTF-8"?>
      <module xmlns="urn:jboss:module:1.1" name="org.apache.openjpa"> 
          <resources> 
              <resource-root path="openjpa-2.2.1.jar"/> 
              <resource-root path="serp-1.13.1.jar"/> 
          </resources> 
              <dependencies> 
                  <module name="javax.persistence.api"/> 
                  <module name="javax.transaction.api"/> 
                  <module name="javax.validation.api"/> 
                  <module name="org.apache.commons.lang"/> 
                  <module name="org.apache.commons.collections"/> 
                  <module name="org.apache.log4j"/> 
              </dependencies> 
      </module>
      

       

      But, even with all that done, I get the error below (also present inside error.log).

       

      17:43:14,342 INFO  [org.jboss.as.jpa] (MSC service thread 1-6) JBAS011401: Read persistence.xml for juddiDatabase
      17:43:14,383 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-8) MSC00001: Failed to start service jboss.module.service."deployment.juddiv3.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.juddiv3.war".main: Failed to load module: deployment.juddiv3.war:main
        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:91) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_51]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_51]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51]
      Caused by: org.jboss.modules.ModuleNotFoundException: Module org.apache.openjpa:main is not found in local module loader @1dd0fe7 (roots: C:\Java\jboss-as-7.1.1.Final\modules)
        at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:126) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:94) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.Module.addPaths(Module.java:841) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.Module.link(Module.java:1181) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.Module.relinkIfNecessary(Module.java:1207) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:70) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
        ... 5 more
      
      
      17:43:14,589 INFO  [org.jboss.as.server] (HttpManagementService-threads - 1) JBAS015870: Deploy of deployment "juddiv3.war" was rolled back with failure message {"JBAS014671: Failed services" => {"jboss.module.service.\"deployment.juddiv3.war\".main" => "org.jboss.msc.service.StartException in service jboss.module.service.\"deployment.juddiv3.war\".main: Failed to load module: deployment.juddiv3.war:main"}}
      17:43:14,837 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015877: Stopped deployment juddiv3.war in 246ms
      17:43:14,838 INFO  [org.jboss.as.controller] (HttpManagementService-threads - 1) JBAS014774: Service status report
      JBAS014777:   Services which failed to start:      service jboss.module.service."deployment.juddiv3.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.juddiv3.war".main: Failed to load module: deployment.juddiv3.war:main
      
      

       

      Why?  Why JBoss is not loading openjpa?