8 Replies Latest reply on Apr 16, 2014 8:03 AM by Max Rydahl Andersen

    JBoss Tools on Eclipse Kepler Mac

    Hatem Alimam Newbie

      On my Mac, JBoss tools is somehow acting strangely with JBoss AS 7.1.3, I have configured my projects as always as I do on other OS like linux and windows. But this time on Mac the full publish is very slow and won't package normally.

       

      I've got an Ear project inside it I have ejb jar and war, sometimes the ejb jar has folders but without any classes, and sometimes the war is empty... after I do multiple Full Publish the project works (happens 1 out of 100 tries),
      On the other hand If i package my project using maven everything is working as expected on JBoss AS.

       

      What I can imagine that the functionally of the Full Publish by Jboss tools to JBoss AS is broken on Mac. As I have tested with the same steps on Ubuntu and windows XP it works fine.

       

      Any advice ?

       

      I'm using:

      JBoss Tools 4.1.2 Final

      JBoss AS 7.1.3

      Eclipse Kepler  Version: Kepler Service Release 2 Build id: 20140224-0627

      Mac os x mavericks Version 10.9.2

        • 1. Re: JBoss Tools on Eclipse Kepler Mac
          Max Rydahl Andersen Master

          Hi Hatem,

           

          Sorry you are having problems - lets see what we can do.

           

          I run it on Mavericks and do not see these problems (but I also haven't tried 100 times in a row yet .

           

          There must be something causing this - like a permission error or something "special" about the project is my guess.

           

          Is it possible for you to describe the steps to make it happen so we can reproduce ? maybe even give us an example project to play with ?

           

          Also have you tried using latest Beta and see if it happens there too ?

          • 2. Re: JBoss Tools on Eclipse Kepler Mac
            Max Rydahl Andersen Master

            Also, if you could check the error log view and tell if any errors in there that would be great!

            • 3. Re: JBoss Tools on Eclipse Kepler Mac
              Hatem Alimam Newbie

              Apparently I didn't notice that JBoss AS is running on Java 6! it's my fault it should run on at least 7. now the full  publish is working fine, but still so slow on mac (well it's not "slow", it's different from linux behaviour. When the full publish finishes on mac you can see right away that the project is deployed. but on linux the full publish finishes so fast after that you can see that the app is still deploying)...
              Note: I have a good hardware here, i7 Processor 16 GB RAM. also I have tuned eclipse, AS, and Java runtime for memory!

               

              If I check, run this always in the background of the dialog of the full publish.. strangely everything goes fast and the full publish takes 2 seconds... I think the dialog is blocking some other things, that my guess.

               

              Thanks for your help.

              • 4. Re: JBoss Tools on Eclipse Kepler Mac
                Max Rydahl Andersen Master

                So it was actually deploying fine but you used java 7 classes so it failed to deploy ?

                 

                "but on linux the full publish finishes so fast after that you can see that the app is still deploying"

                 

                did you mean to say "you *cannot* see that app is still deploying" ?

                 

                Are we talking a few seconds  here or 10-50 seconds delay ?

                • 5. Re: JBoss Tools on Eclipse Kepler Mac
                  Hatem Alimam Newbie
                  So it was actually deploying fine but you used java 7 classes so it failed to deploy ?

                   

                  It was failing the deploy, because some classes are not being copied to the deployment folder thus ClassNotFoundException was present. (When using Java 6)

                   

                  did you mean to say "you *cannot* see that app is still deploying" ?

                  Now when I have put the run in background option, I can see everything, the dialog was blocking the process of the deployment (this is my guess).


                  Are we talking a few seconds  here or 10-50 seconds delay ?

                   

                  The project is somehow Big... So normally the full publish would take up to 10 seconds, But on mac if I have the full publish dialog ( the one would show the files being transferred) opened, this process takes up to 1 minute !! again if I click run in background or run always in background the process goes incredibly fast compared to that 1 minute before !

                   

                  I hope I explained well.

                   

                  Thank you again

                  • 6. Re: Re: JBoss Tools on Eclipse Kepler Mac
                    Max Rydahl Andersen Master

                    That the server runs with Java 7 or JAva 6 should *not* affect the deployment folder content! IF that is happening please open a bug report at  https://jira.jboss.org/jira/browse/JBIDE

                     

                    Your problem about publishing for large projects I now understand. This is caused by a bug or "Feature" of SWT on Mac that makes it *very slow* for progress monitors provdiing feedback.

                     

                    How big is your project ? could you go to the deployed directory and run `find . -type f -not -path '*/\.*' | sed 's/.*\.//' | sort | uniq -c` and paste the content here ? (that gives an idea of the size of your deployment)

                    • 7. Re: Re: JBoss Tools on Eclipse Kepler Mac
                      Hatem Alimam Newbie

                      That the server runs with Java 7 or JAva 6 should *not* affect the deployment folder content! IF that is happening please open a bug report at  https://jira.jboss.org/jira/browse/JBIDE

                      Maybe I should open a ticket, as I see this as a critical problem.

                       

                      How big is your project ? could you go to the deployed directory and run `find . -type f -not -path '*/\.*' | sed 's/.*\.//' | sort | uniq -c` and paste the content here ? (that gives an idea of the size of your deployment)

                      Result:

                       

                      • 3 MF
                      • 777 class
                      •   24 css
                      •   27 eot
                      •   32 gif
                      •    1 ico
                      • 158 jar
                      •   58 js
                      •    1 otf
                      •    4 pdf
                      •   65 png
                      •    4 sql
                      •   27 svg
                      •   27 ttf
                      •    3 txt
                      •   27 woff
                      • 107 xhtml
                      •   11 xml

                       

                      Note we have some Jars as Utility Modules ... I don't know if that's big enough to cause such problem (I don't think so)

                      • 8. Re: Re: JBoss Tools on Eclipse Kepler Mac
                        Max Rydahl Andersen Master

                        158 jars - impressive

                         

                        so I reproduced the problem of the progressbar and opend at eclipse here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=432826 its an OSX only issue but yes, its making things annoyingly slow even though it actually does complete way before the progressmonitor ends ;/

                         

                        about java6 making things not deploy/package properly - yes please open an issue on that.