0 Replies Latest reply on Apr 20, 2014 7:45 PM by Mike Doyle

    Virtual hosts all show up unders single virtual host in mod_cluster

    Mike Doyle Newbie

      Hi, I have two virtual hosts configured in domain.xml:

       

                  <subsystem xmlns="urn:jboss:domain:web:1.4" native="false">
                      <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>
                      <connector name="ajp" protocol="AJP/1.3" scheme="http" socket-binding="ajp"/>
                      <virtual-server name="acme25-host" default-web-module="ROOT.war">
                          <alias name="acme25.xxxxxx.com"/>
                      </virtual-server>
                      <virtual-server name="base-host" default-web-module="ROOT.war">
                          <alias name="host25.xxxx.com"/>
                      </virtual-server>
                  </subsystem>

       

      I have wars deployed to each host and all the contexts show up in mod_cluster however they are all listed under a single virtual host with all the aliases listed. I would expect them to be listed in two virtual hosts and with each listing their respective aliases?

      from mod_cluster_manager page:

      Aliases:

      acme25.xxxx.com acme25-host host25.xxxx.com base-host 

       

      fedora 19

      boss-eap-6.1

      httpd.x86_64                    2.4.7-1.fc19
      mod_cluster.x86_64              1.2.1-5.fc19

       

      Any idea's one what I might have wrong?

       

      Thanks