13 Replies Latest reply on Apr 24, 2014 8:13 AM by Anna Green

    Deploying with wildfly

    Anna Green Newbie

      I think this should be a fairly basic question, but I can't find the solution to my problem anywhere.  I've recently installed Wildfly8.0.0.Final on OSX Mountain Lion and I've set up an admin user using the management domain.  I've been working with a team where we have created a JBoss enabled product, which seems to have worked on everyone else's system (most of them using Windows), but when I try and run this project on Eclipse by clicking Run as > Run on server, I get the following printed to the console:

       

      13:51:38,498 INFO  [org.jboss.modules] JBoss Modules version 1.0.1.GA

      13:51:38,759 INFO  [org.jboss.msc] JBoss MSC version 1.0.0.GA

      13:51:38,798 INFO  [org.jboss.as] JBoss AS 7.0.1.Final "Zap" starting

      13:51:39,420 WARN  [org.jboss.as] No security realm defined for native management service, all access will be unrestricted.

      13:51:39,440 INFO  [org.jboss.as] creating http management service using network interface (management) port (9990)

      13:51:39,441 WARN  [org.jboss.as] No security realm defined for http management service, all access will be unrestricted.

      13:51:39,448 INFO  [org.jboss.as.logging] Removing bootstrap log handlers

      13:51:39,461 INFO  [org.jboss.as.connector.subsystems.datasources] (Controller Boot Thread) Deploying JDBC-compliant driver class org.h2.Driver (version 1.2)

      13:51:39,472 INFO  [org.jboss.as.clustering.infinispan.subsystem] (Controller Boot Thread) Activating Infinispan subsystem.

      13:51:39,551 INFO  [org.jboss.as.naming] (Controller Boot Thread) Activating Naming Subsystem

      13:51:39,560 INFO  [org.jboss.as.naming] (MSC service thread 1-2) Starting Naming Service

      13:51:39,562 INFO  [org.jboss.as.osgi] (Controller Boot Thread) Activating OSGi Subsystem

      13:51:39,578 INFO  [org.jboss.as.security] (Controller Boot Thread) Activating Security Subsystem

      13:51:39,589 INFO  [org.jboss.remoting] (MSC service thread 1-4) JBoss Remoting version 3.2.0.Beta2

      13:51:39,602 INFO  [org.xnio] (MSC service thread 1-4) XNIO Version 3.0.0.Beta3

      13:51:39,615 INFO  [org.xnio.nio] (MSC service thread 1-4) XNIO NIO Implementation Version 3.0.0.Beta3

      13:51:39,815 INFO  [org.apache.catalina.core.AprLifecycleListener] (MSC service thread 1-4) The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: .:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java

      13:51:39,829 INFO  [org.jboss.as.ee] (Controller Boot Thread) Activating EE subsystem

      13:51:39,840 INFO  [org.jboss.as.jmx.JMXConnectorService] (MSC service thread 1-5) Starting remote JMX connector

      13:51:39,852 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC00001: Failed to start service jboss.serverManagement.controller.management.http: org.jboss.msc.service.StartException in service jboss.serverManagement.controller.management.http: Address already in use /127.0.0.1:9990

        at org.jboss.as.server.mgmt.HttpManagementService.start(HttpManagementService.java:95)

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765)

        at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291)

        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [:1.6.0_65]

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [:1.6.0_65]

        at java.lang.Thread.run(Thread.java:695) [:1.6.0_65]

      Caused by: java.net.BindException: Address already in use

        at sun.nio.ch.Net.bind(Native Method) [:1.6.0_65]

        at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:124) [:1.6.0_65]

        at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59) [:1.6.0_65]

        at org.jboss.sun.net.httpserver.ServerImpl.<init>(ServerImpl.java:112)

        at org.jboss.sun.net.httpserver.HttpServerImpl.<init>(HttpServerImpl.java:47)

        at org.jboss.sun.net.httpserver.DefaultHttpServerProvider.createHttpServer(DefaultHttpServerProvider.java:37)

        at org.jboss.com.sun.net.httpserver.HttpServer.create(HttpServer.java:126)

        at org.jboss.as.domain.http.server.ManagementHttpServer.create(ManagementHttpServer.java:99)

        at org.jboss.as.server.mgmt.HttpManagementService.start(HttpManagementService.java:87)

        ... 5 more

       

      13:51:39,871 ERROR [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-3) Error initializing endpoint: java.net.BindException: Address already in use /127.0.0.1:8080

        at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:1005)

        at org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:190)

        at org.apache.catalina.connector.Connector.init(Connector.java:976)

        at org.apache.catalina.core.StandardService.addConnector(StandardService.java:351)

        at org.jboss.as.web.WebServerService.addConnector(WebServerService.java:121)

        at org.jboss.as.web.WebConnectorService.start(WebConnectorService.java:223)

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765)

        at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291)

        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [:1.6.0_65]

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [:1.6.0_65]

        at java.lang.Thread.run(Thread.java:695) [:1.6.0_65]

       

      13:51:39,873 ERROR [org.apache.catalina.core.StandardService] (MSC service thread 1-3) Connector.initialize: LifecycleException:  Protocol handler initialization failed: java.net.BindException: Address already in use /127.0.0.1:8080

        at org.apache.catalina.connector.Connector.init(Connector.java:978)

        at org.apache.catalina.core.StandardService.addConnector(StandardService.java:351)

        at org.jboss.as.web.WebServerService.addConnector(WebServerService.java:121)

        at org.jboss.as.web.WebConnectorService.start(WebConnectorService.java:223)

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765)

        at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291)

        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [:1.6.0_65]

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [:1.6.0_65]

        at java.lang.Thread.run(Thread.java:695) [:1.6.0_65]

       

      13:51:39,875 ERROR [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-3) Error starting endpoint: java.net.BindException: Address already in use /127.0.0.1:8080

        at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:1005)

        at org.apache.tomcat.util.net.JIoEndpoint.start(JIoEndpoint.java:1021)

        at org.apache.coyote.http11.Http11Protocol.start(Http11Protocol.java:218)

        at org.apache.catalina.connector.Connector.start(Connector.java:1051)

        at org.apache.catalina.core.StandardService.addConnector(StandardService.java:359)

        at org.jboss.as.web.WebServerService.addConnector(WebServerService.java:121)

        at org.jboss.as.web.WebConnectorService.start(WebConnectorService.java:223)

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765)

        at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291)

        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [:1.6.0_65]

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [:1.6.0_65]

        at java.lang.Thread.run(Thread.java:695) [:1.6.0_65]

       

      13:51:39,877 ERROR [org.apache.catalina.core.StandardService] (MSC service thread 1-3) Connector.start: LifecycleException:  service.getName(): "jboss.web";  Protocol handler start failed: java.net.BindException: Address already in use /127.0.0.1:8080

        at org.apache.catalina.connector.Connector.start(Connector.java:1058)

        at org.apache.catalina.core.StandardService.addConnector(StandardService.java:359)

        at org.jboss.as.web.WebServerService.addConnector(WebServerService.java:121)

        at org.jboss.as.web.WebConnectorService.start(WebConnectorService.java:223)

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765)

        at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291)

        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [:1.6.0_65]

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [:1.6.0_65]

        at java.lang.Thread.run(Thread.java:695) [:1.6.0_65]

       

      13:51:39,903 INFO  [org.jboss.as.remoting] (MSC service thread 1-6) Listening on /127.0.0.1:9999

      13:51:40,095 INFO  [org.jboss.as.connector] (MSC service thread 1-3) Starting JCA Subsystem (JBoss IronJacamar 1.0.3.Final)

      13:51:40,136 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-4) Bound data source [java:jboss/datasources/ExampleDS]

      13:51:40,448 INFO  [org.jboss.as.deployment] (MSC service thread 1-4) Started FileSystemDeploymentService for directory /Users/dannyflynn/jboss-as-7.0.1.Final/standalone/deployments

      13:51:40,462 INFO  [org.jboss.as.deployment] (DeploymentScanner-threads - 1) Found Loki.war in deployment directory. To trigger deployment create a file called Loki.war.dodeploy

      13:51:40,659 INFO  [org.jboss.as.controller] (Controller Boot Thread) Service status report

        Services which failed to start:

            service jboss.serverManagement.controller.management.http: org.jboss.msc.service.StartException in service jboss.serverManagement.controller.management.http: Address already in use /127.0.0.1:9990

       

      13:51:40,663 ERROR [org.jboss.as] (Controller Boot Thread) JBoss AS 7.0.1.Final "Zap" started (with errors) in 2409ms - Started 91 of 148 services (2 services failed or missing dependencies, 55 services are passive or on-demand)

      13:51:40,672 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) Starting deployment of "Loki.war"

      13:51:44,218 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-7) Class Path entry xml-apis.jar in "/Users/dannyflynn/jboss-as-7.0.1.Final/standalone/deployments/Loki.war/WEB-INF/lib/serializer-2.7.1.jar"  does not point to a valid jar for a Class-Path reference.

      13:51:44,218 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-7) Class Path entry xercesImpl.jar in "/Users/dannyflynn/jboss-as-7.0.1.Final/standalone/deployments/Loki.war/WEB-INF/lib/xalan-2.7.1.jar"  does not point to a valid jar for a Class-Path reference.

      13:51:44,219 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-7) Class Path entry xml-apis.jar in "/Users/dannyflynn/jboss-as-7.0.1.Final/standalone/deployments/Loki.war/WEB-INF/lib/xalan-2.7.1.jar"  does not point to a valid jar for a Class-Path reference.

      13:51:44,219 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-7) Class Path entry serializer.jar in "/Users/dannyflynn/jboss-as-7.0.1.Final/standalone/deployments/Loki.war/WEB-INF/lib/xalan-2.7.1.jar"  does not point to a valid jar for a Class-Path reference.

      13:51:44,387 INFO  [org.jboss.jpa] (MSC service thread 1-7) read persistence.xml for dt340a

      13:51:44,406 INFO  [org.jboss.as.jpa] (MSC service thread 1-1) added javax.persistence.api, javaee.api, org.jboss.as.jpa, org.javassist dependencies to Loki.war

      13:51:44,407 INFO  [org.jboss.as.jpa] (MSC service thread 1-1) added (default provider) org.hibernate dependency to application deployment (since 1 PU(s) didn't specify jboss.as.jpa.providerModule)

      13:51:44,407 INFO  [org.jboss.as.jpa] (MSC service thread 1-1) added org.hibernate dependency to application deployment

      13:51:44,620 WARN  [org.jboss.modules] (MSC service thread 1-7) Failed to define class webservice.Users in Module "deployment.Loki.war:main" from Service Module Loader: java.lang.UnsupportedClassVersionError: webservice/Users : Unsupported major.minor version 51.0

        at java.lang.ClassLoader.defineClass1(Native Method) [:1.6.0_65]

        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637) [:1.6.0_65]

        at java.lang.ClassLoader.defineClass(ClassLoader.java:621) [:1.6.0_65]

        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) [:1.6.0_65]

        at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:397)

        at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:261)

        at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:76)

        at org.jboss.modules.Module.loadModuleClass(Module.java:588)

        at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:183)

        at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:358)

        at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:307)

        at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:101)

        at org.jboss.as.ejb3.deployment.processors.BusinessViewAnnotationProcessor.getEjbClass(BusinessViewAnnotationProcessor.java:195)

        at org.jboss.as.ejb3.deployment.processors.BusinessViewAnnotationProcessor.deploy(BusinessViewAnnotationProcessor.java:77)

        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:115)

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765)

        at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291)

        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [:1.6.0_65]

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [:1.6.0_65]

        at java.lang.Thread.run(Thread.java:695) [:1.6.0_65]

       

      13:51:44,623 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-7) MSC00001: Failed to start service jboss.deployment.unit."Loki.war".POST_MODULE: org.jboss.msc.service.StartException in service jboss.deployment.unit."Loki.war".POST_MODULE: Failed to process phase POST_MODULE of deployment "Loki.war"

        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:121)

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765)

        at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291)

        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [:1.6.0_65]

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [:1.6.0_65]

        at java.lang.Thread.run(Thread.java:695) [:1.6.0_65]

      Caused by: java.lang.UnsupportedClassVersionError: webservice/Users : Unsupported major.minor version 51.0

        at java.lang.ClassLoader.defineClass1(Native Method) [:1.6.0_65]

        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637) [:1.6.0_65]

        at java.lang.ClassLoader.defineClass(ClassLoader.java:621) [:1.6.0_65]

        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) [:1.6.0_65]

        at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:397)

        at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:261)

        at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:76)

        at org.jboss.modules.Module.loadModuleClass(Module.java:588)

        at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:183)

        at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:358)

        at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:307)

        at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:101)

        at org.jboss.as.ejb3.deployment.processors.BusinessViewAnnotationProcessor.getEjbClass(BusinessViewAnnotationProcessor.java:195)

        at org.jboss.as.ejb3.deployment.processors.BusinessViewAnnotationProcessor.deploy(BusinessViewAnnotationProcessor.java:77)

        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:115)

        ... 5 more

       

      13:51:44,627 INFO  [org.jboss.as.server.controller] (DeploymentScanner-threads - 2) Deployment of "Loki.war" was rolled back with failure message {"Failed services" => {"jboss.deployment.unit.\"Loki.war\".POST_MODULE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"Loki.war\".POST_MODULE: Failed to process phase POST_MODULE of deployment \"Loki.war\""}}

      13:51:44,684 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) Stopped deployment Loki.war in 57ms

      13:51:44,688 ERROR [org.jboss.as.deployment] (DeploymentScanner-threads - 1) {"Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"Failed services" => {"jboss.deployment.unit.\"Loki.war\".POST_MODULE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"Loki.war\".POST_MODULE: Failed to process phase POST_MODULE of deployment \"Loki.war\""}}}}

       

       

      It may also be worth noting that since the first time I tried this, Eclipse has opened with the popup window you can see below

      Screen Shot 2014-04-21 at 13.49.53.png

      I'm entirely new to JBoss/Wildfly, so there could be something fundamentally wrong with my setup for all I know, but I don't see myself figuring it out without help.  I've been working on this for three days now.

        • 1. Re: Deploying with wildfly
          David Lloyd Master

          These "port already in use" types of errors almost always mean that there's another instance of the AS already running.  Use ps or something to find it and shut it down before starting up another instance.

          1 of 1 people found this helpful
          • 2. Re: Deploying with wildfly
            Anna Green Newbie

            I think you were right.  I hadn't cancelled my initial call to standalone.sh from the command line.  I seem to have a different error now, where I cannot connect to the server:

            Screen Shot 2014-04-21 at 14.10.25.png

            Perhaps I'm being naïve, but a failed connection problem at least seems like it shouldn't be too complicatedPlease tell me that's the case

            • 3. Re: Deploying with wildfly
              Anna Green Newbie

              I just noticed this after clicking the pom file.  Is that no plugin found warning something I should worry about?

              Screen Shot 2014-04-21 at 17.28.22.png

              • 4. Re: Deploying with wildfly
                Tomaz Cerar Master

                All your stacktraces, logs  and screenshots are coming from JBoss AS 7.0.1.Final which is extra old.

                 

                Also you have your application compiled agains JDK7 but deploying on JDK6.

                 

                Please sort out what JDK are you using and make sure you are running WildFly 8 not AS7.0.

                1 of 1 people found this helpful
                • 5. Re: Deploying with wildfly
                  Anna Green Newbie

                  Right.  I  thought I had properly uninstalled that.  Guess not.  Let me go fix that and I'll get back.

                  • 6. Re: Deploying with wildfly
                    Anna Green Newbie

                    Okay.  I've deleted any trace I could find of any JBoss server 7.1 and below.  I also created a new Wildfly server, made sure it was using the Java 7 JRE and that its home directory was my most recently downloaded wildly directory.  Now when I click run as > run on server on my project, and select the relevant wildfly server, this is the result.  No localhost window pops up anymore, but  a great deal of text is printed to the console, ending with the statement.  "To trigger deployment create a file called Loki.war.dodeploy"

                    Screen Shot 2014-04-21 at 21.00.56.png

                    The pop-up window shown above occurs after waiting for the server for a while.  Do I at least appear to be getting on the right track now?

                    • 7. Re: Deploying with wildfly
                      Kuldeep Sharma Novice

                      I think you should increase the start up time in eclipse configurations.

                      • 8. Re: Deploying with wildfly
                        Tomaz Cerar Master

                        Kuldeep Sharma wrote:

                         

                        I think you should increase the start up time in eclipse configurations.

                        That has noting to do with it, you can see in log file why startup failed.

                        • 9. Re: Deploying with wildfly
                          Tomaz Cerar Master

                          You have problem as management interface cannot bind to port.

                          I would say you have something else running on that same port.

                           

                          netstat -anp

                           

                          you should show you what you have already running on that port...

                          • 10. Re: Deploying with wildfly
                            Anna Green Newbie

                            This question will probably strike you as remarkably stupid, but how do I know the name of the port I want to check? I know that the mysql connector datasource is connected to 3306, so I tried "netstat -anp tcp | grep 3306", which returns "tcp46      0      0  *.3306                 *.*                    LISTEN"  just in case that's relevant.  But that's completely separate from the port I'm using to deploy the wildfly project on, isn't it?  I would have assumed localhost was the port, but it doesn't return anything when I try some variation of that, including the numbers that come up in the console after the word "listening". 

                             

                            It may be worth noting that after some configuration (I had help), I've managed to deploy the project in such a way that no errors occur on the console anymore.  Every line has the INFO tag:

                             

                            .........................................................

                             

                            17:52:10,865 INFO  [org.jboss.modules] (main) JBoss Modules version 1.3.0.Final

                            17:52:11,648 INFO  [org.jboss.msc] (main) JBoss MSC version 1.2.0.Final

                            17:52:11,781 INFO  [org.jboss.as] (MSC service thread 1-6) JBAS015899: WildFly 8.0.0.Final "WildFly" starting

                            17:52:13,243 INFO  [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015003: Found Loki.war in deployment directory. To trigger deployment create a file called Loki.war.dodeploy

                            17:52:13,284 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http)

                            17:52:13,325 INFO  [org.xnio] (MSC service thread 1-4) XNIO version 3.2.0.Final

                            17:52:13,342 INFO  [org.xnio.nio] (MSC service thread 1-4) XNIO NIO Implementation Version 3.2.0.Final

                            17:52:13,452 INFO  [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 28) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3)

                            17:52:13,482 INFO  [org.jboss.as.clustering.infinispan] (ServerService Thread Pool -- 33) JBAS010280: Activating Infinispan subsystem.

                            17:52:13,636 INFO  [org.jboss.as.naming] (ServerService Thread Pool -- 41) JBAS011800: Activating Naming Subsystem

                            17:52:13,641 INFO  [org.jboss.as.security] (ServerService Thread Pool -- 46) JBAS013171: Activating Security Subsystem

                            17:52:13,657 INFO  [org.jboss.as.security] (MSC service thread 1-2) JBAS013170: Current PicketBox version=4.0.20.Final

                            17:52:13,663 INFO  [org.jboss.as.jsf] (ServerService Thread Pool -- 39) JBAS012615: Activated the following JSF Implementations: [main]

                            17:52:13,718 INFO  [org.jboss.remoting] (MSC service thread 1-8) JBoss Remoting version 4.0.0.Final

                            17:52:13,727 INFO  [org.wildfly.extension.undertow] (ServerService Thread Pool -- 49) JBAS017502: Undertow 1.0.0.Final starting

                            17:52:13,727 INFO  [org.wildfly.extension.undertow] (MSC service thread 1-6) JBAS017502: Undertow 1.0.0.Final starting

                            17:52:13,742 INFO  [org.jboss.as.webservices] (ServerService Thread Pool -- 50) JBAS015537: Activating WebServices Extension

                            17:52:13,777 INFO  [org.jboss.as.naming] (MSC service thread 1-1) JBAS011802: Starting Naming Service

                            17:52:13,778 INFO  [org.jboss.as.mail.extension] (MSC service thread 1-5) JBAS015400: Bound mail session [java:jboss/mail/Default]

                            17:52:13,789 INFO  [org.jboss.as.connector.logging] (MSC service thread 1-2) JBAS010408: Starting JCA Subsystem (IronJacamar 1.1.3.Final)

                            17:52:13,810 INFO  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-5) JBAS010417: Started Driver service with driver-name = h2

                            17:52:14,022 INFO  [org.wildfly.extension.undertow] (ServerService Thread Pool -- 49) JBAS017527: Creating file handler for path /Users/dannyflynn/Desktop/wildfly-8.0.0.Final/welcome-content

                            17:52:14,185 INFO  [org.wildfly.extension.undertow] (MSC service thread 1-3) JBAS017525: Started server default-server.

                            17:52:14,226 INFO  [org.wildfly.extension.undertow] (MSC service thread 1-3) JBAS017531: Host default-host starting

                            17:52:14,351 INFO  [org.wildfly.extension.undertow] (MSC service thread 1-8) JBAS017519: Undertow HTTP listener default listening on localhost/127.0.0.1:8080

                            17:52:15,068 INFO  [org.jboss.as.server.deployment.scanner] (MSC service thread 1-6) JBAS015012: Started FileSystemDeploymentService for directory /Users/dannyflynn/Desktop/wildfly-8.0.0.Final/standalone/deployments

                            17:52:15,078 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015876: Starting deployment of "mysql-connector-java-5.1.18-bin.jar" (runtime-name: "mysql-connector-java-5.1.18-bin.jar")

                            17:52:15,078 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015876: Starting deployment of "Loki.jar" (runtime-name: "Loki.jar")

                            17:52:15,982 INFO  [org.jboss.ws.common.management] (MSC service thread 1-4) JBWS022052: Starting JBoss Web Services - Stack CXF Server 4.2.3.Final

                            17:52:16,007 INFO  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-4) JBAS010404: Deploying non-JDBC-compliant driver class com.mysql.jdbc.Driver (version 5.1)

                            17:52:16,029 INFO  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-3) JBAS010417: Started Driver service with driver-name = mysql-connector-java-5.1.18-bin.jar

                            17:52:16,103 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-5) JBAS010400: Bound data source [java:/mySQL]

                            17:52:16,175 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 29) JBAS018559: Deployed "mysql-connector-java-5.1.18-bin.jar" (runtime-name : "mysql-connector-java-5.1.18-bin.jar")

                            17:52:16,176 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 29) JBAS018559: Deployed "Loki.jar" (runtime-name : "Loki.jar")

                            17:52:16,200 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management

                            17:52:16,201 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990

                            17:52:16,201 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: WildFly 8.0.0.Final "WildFly" started in 5863ms - Started 248 of 309 services (96 services are lazy, passive or on-demand)

                             

                            .........................................................

                             

                            Now a .deployed file is being created from the war when I run it.  This was always creating a .failed file before

                            Screen Shot 2014-04-22 at 18.11.33.png

                            Loki.jar has also appeared on the management console

                            Screen Shot 2014-04-22 at 18.13.32.png

                            I am told that this is exactly what should happen.  But I was also told that http://localhost:8080/Loki/index.jsp should now get me to the main screen of the project.  That's giving me a 404 error.  Is it still the same port problem? I don't know how to use that command properly.  Forgive my ignorance, but I only started software engineering last year and I certainly haven't gotten accustomed to all the basic mac terminal commands yet. 

                            • 11. Re: Deploying with wildfly
                              Rituraj Sinha Novice

                              i cant see anything related to your loki.war deployment in the server log ...how are you deploying your war ...are you using the management console/maven or cli ..or just keeping the war in the deployments directory...

                              please read down the JBOSS_HOME/standalone/deployments/README.txt  for more detail...

                              • 12. Re: Deploying with wildfly
                                Tomaz Cerar Master

                                You are deploying loki.jar, which deployed successfully.

                                 

                                but there is no loki.war, so you cannot access anything trough web...

                                • 13. Re: Deploying with wildfly
                                  Anna Green Newbie

                                  This problem is solved. I did the following:

                                  1. Ran Mvn clean and Mvn install on the project from eclipse

                                  2. Ran Update Project

                                  3. Only then did I export it as a WAR file to the deployments.

                                  4. I then executed it using standalone.sh

                                   

                                  The project is running fine (I have it on both OSX and Windows now)

                                   

                                  Sometimes creating Loki.war as a folder rather than a war seems to be an irritating quirk of Eclipse that happens every now and then.