1 Reply Latest reply on Apr 21, 2014 4:38 PM by labo32

    Simple osgi bundle shows Unresolved constraint in bundle

    labo32 Newbie

      Hello,

       

      I am trying to create a simple osgi bundle (camel 2.12.3) but during deployment in a karaf instance (2.3.2, 2.3.5, 3.0.1) I am getting

      follwing exception:

       

       

      org.osgi.framework.BundleException: Unresolved constraint in bundle test-source [152]: Unable to resolve 152.1: missing requirement [152.1] osgi.wiring.package; (osgi.wiring.package=com.sun.xml.fastinfoset.sax)

       

      The only dependencies in my project are:

      <dependency>

        <groupId>org.apache.camel</groupId>

        <artifactId>camel-core</artifactId>

        <version>2.12.3</version>

        </dependency>

       

      Next try with some log4j dependencies shows

       

      org.osgi.framework.BundleException: Unresolved constraint in bundle test-source [152]: Unable to resolve 152.2: missing requirement [152.2] osgi.wiring.package; (osgi.wiring.package=com.ibm.uvm.tools)

       

       

      But I cannot find com.ibm.uvm.tools in maven central.....

       

      What are the required dependencies for a simple bundle only using camel-core and logging ?

       

      Thanks

      labo